External disk trash not shown by trash applet

Bug #32466 reported by MKersloot on 2006-02-22
110
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Applets
Fix Released
Medium
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

When I attach an usb stick and delete some files on it. The files are moved to the trash, but the trash-applet still says: There are no objects.
If I click on it, it does open an filemanager window with the files in the trash.

Version: 2.12.1-0ubuntu1

MKersloot (micha-kovoks) on 2006-02-22
description: updated
Sebastien Bacher (seb128) wrote :

Thanks for your bug. I think we already have some bug mentionning issues when deleting from other drives by example

Changed in gnome-applets:
assignee: nobody → desktop-bugs
Daniel Holbach (dholbach) wrote :

bug 12893 mentions .Trash-<USER> and really-delete vs move-to-trash

MKersloot (micha-kovoks) wrote :

Bug 12893 and others are about not creating a trash. This one is about not showing it in the applet when there is content in the trash.

MKersloot (micha-kovoks) wrote :

Seems that it is fixed in dapper.

Daniel Holbach (dholbach) wrote :

Thanks for following up. I closed the bug as fixed, please reopen if the issue occurs again.

Changed in gnome-applets:
status: Unconfirmed → Fix Released
Paul Sladen (sladen) wrote :

I'm still seeing this bug as of 2006-03-12.

  https://launchpad.net/distros/ubuntu/+source/gnome-applets/+bug/34541

Implementing the following wishlist/bug ("always do a real _delete_ on removable or network storage"):

https://launchpad.net/distros/ubuntu/+source/nautilus/+bug/12893

would cure this issue and prevent leaving the tempoary .Trash-$user around.

Changed in gnome-applets:
status: Fix Released → Confirmed
towsonu2003 (towsonu2003) wrote :

seems to me this and all its duplicates are the exact same bug as bug# 12893

Sebastien Bacher (seb128) wrote :

no, they are not: bug #12893 is about not creating a crash on a camera device by example, that bug is about listing trash for those devices correctly when they have one

towsonu2003 (towsonu2003) wrote :

Uhm, I see. I guess I meant that the "solution" is the same.

From description of this bug:
> When I attach an usb stick and delete some files on it. The files are moved to the trash,
> but the trash-applet still says: There are no objects.

trash-applet says "there are no objects" because it looks at ~/.Trash , which is the proper place to look. I guess this issue would be resolved if trash of removable drives is located at ~/.Trash as well, instead of /media/drive/.Trash

From description of bug# 12893
> Ty digital camera card is full after deleting
> all the pictures, and my iAudio still plays deleted files.
> This is because instead of deleting files from removal devices, Nautilus creates
> a .Trash-$USER directory and moves the files into there.

iAudio still plays deleted files or the digital camera is still full bc the trash is created at /media/drive/.Trash - If deleted items were moved to one central place ~/.Trash, this wouldn't be a problem. The camera/iaudio would be emptied even without "real_delete_if_drive_removable" (which is a very bad idea imho).

Le mardi 19 septembre 2006 à 13:24 +0000, towsonu2003 a écrit :

> trash-applet says "there are no objects" because it looks at ~/.Trash ,
> which is the proper place to look. I guess this issue would be resolved
> if trash of removable drives is located at ~/.Trash as well, instead of
> /media/drive/.Trash

That would mean copying all the datas you delete from your removable
media to your computer. I don't think that people who want to clean
their USB disk wants to wait half an hour for that because it's copying
the datas on the computer

towsonu2003 (towsonu2003) wrote :

Is there any way to compress the data transaction (like in an ssh session)? Here is my comment to another bug that seems to apply here as good as it applies there:

- From https://launchpad.net/distros/ubuntu/+source/nautilus/+bug/12893/comments/43

A real-life case:
Prof Dr. Jane clicked the delete key and than (as most of us will do after our Windows experiences) confirmed a dialogue without thinking twice, and thus deleting a paper her student emailed to her a month ago. The paper was in her usb stick that she was browsing. The student's email is already deleted and purged. The student came by two days later, telling her that his hard drive was wiped and he lost that paper for good. He wants that paper back.

In Windows:
The paper is gone because Windows (afaik) deletes remote files.

In Dapper:
The paper is still in .Trash-Jane, hidden. Jane most probably doesn't know it exists.

In Edgy (my proposition):
The paper is in ~/.Trash thanks to a script that links /media/removable/.Trash-Jane to ~/.Trash once the media is inserted / mounted. This link is removed once the media is unmounted. Jane doesn't know or care how this works: the paper is recovered.

In Edgy (your proposition):
The paper is gone.

Sebastien Bacher (seb128) wrote :

Le jeudi 21 septembre 2006 à 00:37 +0000, towsonu2003 a écrit :
> Is there any way to compress the data transaction (like in an ssh
> session)?

whatever you do, copying datas will take some time, especially if the
media is a slow one

unggnu (unggnu) wrote :

Why make it such complicated like copying files to another partition. I think "Prompt for empty trash on unmount (Ubuntu: #12893)" is a great idea for removal medias. The only missing thing is that Gnome Trash should show all MEDIA/.Trash-$USER files so that files could be cleared on static medias too. I am pretty sure that KDE-Trash do this already.

I confirm this bug under Gutsy uptodate

Yann Rouillard (yann-pleiades) wrote :

What is the filesystem used on the usb key ?

AFAIR it was FAT32. Meanwhile I use Fedora and cannot test it anymore...

Am Samstag, den 20.10.2007, 23:07 +0000 schrieb Yann Rouillard:
> What is the filesystem used on the usb key ?
>

GortiZ (mlista6) wrote :

I can confirm this bug / feature to add too.
IMHO we could let the trash applet know when a device is attached and let it search for a trash entry also in the removable devices...
Is that possible?

Thanks for your help

Yann Rouillard (yann-pleiades) wrote :

It is how it is supposed to work and it usually works.
I noticed it doesn't currently work on ntfs partition ( see https://bugs.launchpad.net/ubuntu/+source/gnome-vfs2/+bug/106621 and https://bugs.launchpad.net/gnome-vfs/+bug/140968 ), do you have this problem with another filesystem ?

GermanSub77 said it had the problem with FAT32 but he can't reproduce it anymore to confirm.

GortiZ (mlista6) wrote :

Ok, I can confirm it with Fat32 and NTFS and you're right I've tried with an ext3 external drive and it works fine.

I can confirm this bug is present in vfat volumes (memory sticks), when I open the trash the deleted items appear there but the trash applet says the trash is empty. For NTFS volumes when I delete an item the trash applet does not say there is anything in trash and when I open the trash none of the deleted items are there, and when I empty the trash the deleted items remain in the .Trash-<username> directory on that drive (32-bit Ubuntu 7.10)

Tessa (unit3) wrote :

I'm seeing this on Hardy/amd64 with gnome-applets-2.22.1. On my system, it seems like GNOME is creating the trash on the removable media with the name /media/USB/.Trash-<uid number> instead of /media/USB/.Trash-<username> like it used to, and the trash applet (or nautilus desktop icon) isn't seeing it correctly.

Sebastien Bacher (seb128) wrote :

could somebody having the issue send it to bugzilla.gnome.org?

Sebastien Bacher (seb128) wrote :

does anybody still get the issue in intrepid?

Luca Ferretti (elle.uca) wrote :

> could somebody having the issue send it to bugzilla.gnome.org?

Really late, sorry. I'll do it.

> does anybody still get the issue in intrepid?

Yes, me :)

Tessa (unit3) wrote :

I'm also still seeing this on Intrepid.

Changed in gnome-applets:
status: Confirmed → Triaged
Changed in gnome-applets:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed in jaunty now

Changed in gnome-applets:
status: Triaged → Fix Released
Changed in gnome-applets:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.