Wrong HTTP command for Webdav with Nautilus

Bug #310967 reported by netAction on 2008-12-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Ubuntu 8.10 i386:

I have Webdav enabled in Apache2. In Nautilus I can see the root directory of the webspace. But if I want to move to a directory I get an error 301 "Permanently Moved".

Move to directory /Backup:
84.134.20.250 - tomi [23/Dec/2008:18:35:48 +0100] "PROPFIND /Backup HTTP/1.1" 301 388 "-" "gvfs/1.0.2"

It works with Konqueror:
84.134.20.250 - tomi [23/Dec/2008:18:49:36 +0100] "PROPFIND /Backup/ HTTP/1.1" 207 3012 "-" "Mozilla/5.0 (compatible; Konqueror/4.1; Linux) KHTML/4.1.3 (like Gecko)"

Nautilus does not add the slash as it should do.
It is the same if i click on the icon of the directory or enter it (with or without slash at the end) in the navigation bar.

A. Walton (awalton) wrote :

Thank you for reporting. Looks like a pretty clear-cut bug. Forwarding upstream.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Changed in gvfs:
status: Confirmed → Triaged
Changed in gvfs:
status: Unknown → New
Changed in gvfs:
importance: Unknown → Medium
Changed in gvfs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.