copying a folder from a secure webdav server to disk results in a html file

Bug #267642 reported by Henry S. on 2008-09-08
90
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Intention: To copy a folder (empty or containing files) from a Secure Webdav server to any location (local, or on the dav server)

Result: A fully formatted html file with the same filename as the folder I was trying to copy. It contains hierarchical links to the files contained within the original folder (if any). This is repeatable every time. An example of one such html file for the empty folder "Folder" is attached.

I am running a fully updated Intrepid .

kernel: 2.6.27-2-generic
gvfs 0.99.6-0ubuntu3
nautilus 1:2.23.91-0ubuntu1

I'm not sure what other information to provide. I'll help in any way I can.

Henry S. (snowball2050-gmail) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=551339

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Christian Kellner (gicmo) wrote :

Bad bug, bad bug

Changed in nautilus:
assignee: desktop-bugs → gicmo
Changed in nautilus:
status: New → In Progress
Jacopo Lorenzetti (jacopol) wrote :

Dependencies:
 gvfs 1.4.1-0ubuntu1
DistroRelease: Ubuntu 9.10
Package: nautilus 1:2.28.1-0ubuntu3
Uname: Linux 2.6.31-17-generic i686

still here on karmic.

ugly workaround: you can copy the folder from outside nautilus, in the terminal, accessing the ~/.gvfs directory

Still in 10.04 LTS - Lucid Lynx

This issue is not restricted to secure WebDAV (in Lucid, at least...) I'm able to reproduce it over plain old HTTP. Not sure who or how to route this information to the right maintainer, but what is needed is a full-depth PROPFIND call to precede the actual GETs that do the copying. For each resource returned by the PROPFIND, a quick check for 'iscollection' = TRUE or 'resourcetype' = '<DAV:collection />' will reveal if the given resource should be treated as a folder (instead of a file).

As a nice side effect, the PROPFIND will provide enough information to populate a progress dialog, too.

Christian Kellner (gicmo) wrote :

I have created an (locally tested but not in-depth reviewed) fix for that bug. If you feel brave you can try the package with the fix in it: https://launchpad.net/~gicmo/+archive/packagedump . If you want to help out the upstream bug report has the info where the source code is.

Changed in nautilus:
importance: Unknown → Medium
Loic Dreux (loic.dreux) wrote :

two years later and no fix...

Changed in nautilus:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed in the oneiric version

Changed in gvfs (Ubuntu):
assignee: Christian Kellner (gicmo) → nobody
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

it should also be fixed in 1.8.2 if somebody wants to work on a stable update for natty

This should be fixed at least in the LTS version (10.04) ASAP.

Quite a huge inconvinience.

Michael Nagel (nailor) wrote :

As indicated in the GNOME bug and verified by me with an up-to-date lucid install:
This does not only affect COPY but also MOVE.

Whereas the situation for COPY is unfortunate, because the contents of the folder are not copied, for MOVE it results in a massive data loss, because not only are the original files not moved/renamed, but also they are deleted, leaving you with just a listing of them...

This should therefore clearly be raised in priority and fixed in the LTS release.

we're offering network storage space through this interface for non-tech users, and some of them don't even know how to open a terminal and type in 'cp -r ..', it would be really great if this patch went in 10.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.