sftp mount fails to copy files in nautilus

Bug #263986 reported by Sindhudweep Sarkar on 2008-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

Connect to server works fine in nautilus but attempting to move files gives me the error
DBus error org.freedesktop.DBus.Error.UnknownMethod: Method "Upload" with signature "ayayuo" on interface "org.gtk.vfs.Mount" doesn't exist

(obtained from dpkg -l |grep (gvfs|fuse|etc))

gvfs 0.99.6-0ubuntu2
gvfs-fuse 0.99.6-0ubuntu2
libfuse2 2.7.3-4ubuntu1

Description: Ubuntu intrepid (development branch)
Release: 8.10

Sebastien Bacher (seb128) wrote :

thank you for your bug report, did you restart your session since the upgrade? that could be a mismatch between the running version and the installed one

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

how do you try to do the move too?

I restarted my machine after the upgrade.

I selected two png's and dragged them to a folder on the remote machine.

Sebastien Bacher (seb128) wrote :

weird, do you get the issue on any share using any file? I just tried and it works correctly there. could you try if using gvfs-copy gives the same error?

I have tried to reproduce it just now and i am unable to with any reasonable permutation.

I have tried cutting and pasting, dragging into the nautlius window, dragging to a selected folder, etc. I am not getting this bug anymore. Please mark this as closed as i guess it is not repeatable.

Sebastien Bacher (seb128) wrote :

closing the bug, feel free to reopen if you get the issue again

Changed in gvfs:
status: Incomplete → Invalid
disturbedsaint (disturbedsaint) wrote :

Reopening since I am also experiencing this bug.

Just connected to an FTP server with username/password.
Uploading (via copy/paste or dragging) doesn´t work, downloading (via copy/paste or dragging) works fine.

Tried it with 3 different FTP servers (all with username/password) and all of them give the same error message:
DBus error org.freedesktop.DBus.Error.UnknownMethod: Method "Upload" with signature "ayayuo" on interface "org.gtk.vfs.Mount" doesn't exist

Copying via gvfs-copy does work though.

Uptime 15 hours and haven't restarted my session since the upgrade yet.

Changed in gvfs:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

could you try after restarting the session?

Changed in gvfs:
status: New → Incomplete
disturbedsaint (disturbedsaint) wrote :

After a restart everything seems fine.

Sebastien Bacher (seb128) wrote :

closing the bug, that's a transitional upgrade issue and sessions should be restarted after upgrades

Changed in gvfs:
status: Incomplete → Invalid
Referat Technik (technik-t) wrote :

mount works fine in nautilus but attempting to move or copy files gives me the error

"Keine Berechtigung" - engl. "access denied"
-
> sometimes it can be moved / copy with the tool midinight comander (mc) by using copy/move without "attributes save"
> independently file-types png,jpg,pdf a.s.o.
> on thunderbird,
               > select and send works can not open files from there ...
               > opening dont work
                           >> "/tmp/P6ybY6iC.pdf.part konnte nicht geöffnet werden, weil ein unbekannter Fehler aufgetreten ist. "
> pdf programms did not open "access denied"

+
> rename or edit works

Version gvfs:
~$ dpkg -l | grep 'gvfs' | awk '{print $2,$3}'
deja-dup-backend-gvfs 30.0-0ubuntu4
gvfs:amd64 1.20.1-1ubuntu1
gvfs-backends 1.20.1-1ubuntu1
gvfs-bin 1.20.1-1ubuntu1
gvfs-common 1.20.1-1ubuntu1
gvfs-daemons 1.20.1-1ubuntu1
gvfs-fuse 1.20.1-1ubuntu1
gvfs-libs:amd64 1.20.1-1ubuntu1

ubuntu 7.8

Changed in gvfs (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers