Cannot authenticate to some webdav shares

Bug #251822 reported by Mads Chr. Olesen on 2008-07-25
6
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
High
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Unassigned
libsoup2.4 (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned

Bug Description

Binary package hint: gvfs

When trying to mount some webdav shares (which worked fine under gnomevfs), gvfs is unable to authenticate.
This is due to the server not returning an algorithm to use, and libsoup (which gvfs uses for webdav) interprets this wrongly. The RFC is clear that this must be interpreted as MD5 should be used.

Attached (one-liner) patch fixes this issue for me.

Bug #223521 is possibly a dupe of this one.

Changed in gvfs:
status: Unknown → New
Changed in gvfs:
status: New → Fix Released
Mads Chr. Olesen (shiyee) wrote :

This issue has now been resolved in libsoup trunk.

Sebastien Bacher (seb128) wrote :

that's not a gvfs bug

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

thank you for your work on that, will be fixed in the next update, could also be something to consider for an hardy stable update

Changed in libsoup2.4:
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

the bug is fixed in intrepid now

Changed in libsoup2.4:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is not a gvfs one

Changed in gvfs:
importance: Undecided → Low
status: New → Invalid
Changed in libsoup2.4:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
assignee: desktop-bugs → nobody
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libsoup2.4:
status: Confirmed → Fix Committed
Mads Chr. Olesen (shiyee) wrote :

I can confirm that the package from -proposed fixes this problem.

Mads Chr. Olesen (shiyee) wrote :

If access to an affected server is required for testing, please ping me and I can probably set one up.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in libsoup2.4:
status: Fix Committed → Fix Released
Changed in gvfs:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.