gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()

Bug #235698 reported by Chris Coulson on 2008-05-29
402
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Critical
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

I'm not sure when this crash happened. I was notified when I logged in first thing this morning

ProblemType: Crash
Architecture: amd64
Date: Thu May 29 00:27:34 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/gvfs/gvfs-fuse-daemon
NonfreeKernelModules: nvidia
Package: gvfs-fuse 0.2.4-0ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/gvfs//gvfs-fuse-daemon /home/username/.gvfs
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/opt/bin:/opt/share/modeltech/linux_x86_64:/opt/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 pthread_mutex_lock () from /lib/libpthread.so.0
 g_main_loop_quit () from /usr/lib/libglib-2.0.so.0
 ?? ()
 fuse_fs_destroy () from /lib/libfuse.so.2
 ?? () from /lib/libfuse.so.2
Title: gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
Uname: Linux 2.6.24-17-generic x86_64
UserGroups: adm admin audio cdrom chrisandjo-rw dialout dip fax floppy fuse lpadmin plugdev sambashare scanner shared-rw tape tilp video vmware xp-write

Chris Coulson (chrisccoulson) wrote :

StacktraceTop:pthread_mutex_lock () from /lib/libpthread.so.0
IA__g_main_loop_quit (loop=0x656970)
?? ()
fuse_fs_destroy (fs=0x610fa0) at fuse.c:1347
fuse_lib_destroy (data=0x610e80) at fuse.c:1360

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
ingo (ingo-steiner) wrote :

had the very same crash this morning just after booting and log-in.

To obtain a backtrace we need the -dbgsym or -dbg packages for 'gfs-fuse'.
They are not available in the Hardy repositories :-(

Kjell Braden (afflux) wrote :

This crash occurs in my current intrepid system with

#0 0x00007f225fb86a5a in pthread_mutex_lock () from /lib/libpthread.so.0
#1 0x00007f226083f07e in IA__g_main_loop_quit (loop=0x658f00) at /build/buildd/glib2.0-2.17.0/glib/gmain.c:2946
#2 0x0000000000403bea in vfs_destroy (param=<value optimized out>) at gvfsfusedaemon.c:2145
#3 0x00007f22603b3359 in fuse_fs_destroy (fs=0x611fa0) at fuse.c:1347
#4 0x00007f22603b33b8 in fuse_lib_destroy (data=0x611e80) at fuse.c:1360

$ LC_ALL=C apt-cache policy gvfs gvfs-fuse libfuse2 libgvfscommon0
gvfs:
  Installed: 0.99.1-0ubuntu1
  Candidate: 0.99.1-0ubuntu1
  Version table:
 *** 0.99.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
gvfs-fuse:
  Installed: 0.99.1-0ubuntu1
  Candidate: 0.99.1-0ubuntu1
  Version table:
 *** 0.99.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
libfuse2:
  Installed: 2.7.3-4ubuntu1
  Candidate: 2.7.3-4ubuntu1
  Version table:
 *** 2.7.3-4ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
libgvfscommon0:
  Installed: 0.99.1-0ubuntu1
  Candidate: 0.99.1-0ubuntu1
  Version table:
 *** 0.99.1-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Changed in gvfs:
status: Incomplete → Confirmed
ingo (ingo-steiner) wrote :

happened again today just after login, seems it is somting essential!

Sebastien Bacher (seb128) wrote :

the intrepid issue is an another bug than the hardy one and seems to be due to some other component update there

Kjell Braden (afflux) wrote :

Sebastien, no offense meant, but the backtraces of hardy and intrepid look very similar, what makes you think it'd be a different issue?

Sebastien Bacher (seb128) wrote :

could be the same issue but almost nobody is getting the issue in hardy where it seems to crash at each session change on intrepid

Chris Coulson (chrisccoulson) wrote :

Sebastien - I'm not sure it is possible to say that almost nobody is suffering this bug in Hardy. Bare in mind that Apport is disabled by default, so the only people who will ever notice the crash are the people who have manually re-enabled Apport (like myself). The bug seems to have no other noticeable effect other than causing Apport to pop up a dialog on the next session. I don't think the typical Ubuntu user will seek out how to enable Apport (so it will remain disabled for most people), and this bug has 7 duplicates.

Sebastien Bacher (seb128) wrote :

could you try to obtain a valgrind log following the instructions at [WWW] https://wiki.ubuntu.com/Valgrind and attach the file to the bug report?

Changed in gvfs:
status: Confirmed → Incomplete
Adam Petaccia (mighmos) wrote :

I'm already waiting for it to crash but I'm not sure what triggers it (I was one of the duplicates).

sam tygier (samtygier) wrote :

i submitted Bug #240840 which is with the dbgsyms installed.

Kjell Braden (afflux) wrote :

I'm not sure if those logs are complete, but I think they look like the program finished.

Kjell Braden (afflux) on 2008-06-19
Changed in gvfs:
status: Incomplete → Confirmed
nullack (nullack) wrote :

This is occurring to me on Hardy Proposed during user login from the GDM screen. Ive attached the apport crash log.

Pedro Villavicencio (pedro) wrote :

nullack, please do not attach .crash files to the report, use apport to send it rather, thanks.

Sense Egbert Hofstede (sense) wrote :

I got the same error message. I've still got the .crash file if another apport report is needed.

Walter_Wittel (wittelw) wrote :

I also got the crash on 8.10 and can upload the .crash to another bug if it would help (although I didn't have debug symbols installed at the time of the crash).

Niels Egberts (nielsegberts) wrote :

I've had the crash also in Intrepid 8.10

Ashwin (cybernytrix) wrote :

Please fix

I have this problem, too, since updating last night hardy-proposed. After gdm login, apport told me about the crash.

Some days ago, I played with intrepid and go that same error. Because of many problems, I reinstalled hardy in 64 bit. I did not have this bug anymore. I think that something has changed in the code from version 0.2.4-0ubuntu1 to 0.2.5-0ubuntu1 in gvfs-fuse.

Does this package belong to GNOME 2.22.3?

Austin Lund (austin-lund) wrote :

Just some comments in case they are useful.

The program crashes at the line which calls fs->op.destroy in fuse_fs_destroy.

The ?? in frame 2 is this function. This function must be set by something that calls the library.

I cannot find any source code for whatever this function is. But it crashes at this line:

0x0000000000403b3a <g_file_create@plt+3122>: mov 0x2032c0(%rip),%edx # 0x606e00 <g_threads_got_initialized>

This seems awfully weird to me. Mixing 32bit registers and 64bit registers. I'm sure there is a compatibility mode for 32bit code but does it really let you do this? Any why on earth is it gathering data from points relative to the instruction pointer?

I guess finding source code for this function would help greatly.

Austin Lund (austin-lund) wrote :

Well duh. The source code is in gvfs.

And the function is vfs_destroy as shown above.

Austin Lund (austin-lund) wrote :

Sorry about all the spam. But it appears that subthread_main_loop has uninitialised data in it when the g_main_loop_quit() function is called. From my core file:

(gdb) print *subthread_main_loop
$10 = {context = 0x62696c0062696c2f, is_running = 1600349031, ref_count = 1869819507}

That's a lot of running and references.

I want to unsuscribe myself from the updates. How do I do this? Whenever I try to do so, I get to a Forbidden page.

--- On Mon, 14/7/08, Austin Lund <email address hidden> wrote:

> From: Austin Lund <email address hidden>
> Subject: [Bug 235698] Re: gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> To: <email address hidden>
> Date: Monday, 14 July, 2008, 2:03 PM
> Well duh. The source code is in gvfs.
>
> And the function is vfs_destroy as shown above.
>
> --
> gvfs-fuse-daemon crashed with SIGSEGV in
> pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/235698
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>
> Status in “gvfs” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gvfs
>
> I'm not sure when this crash happened. I was notified
> when I logged in first thing this morning
>
> ProblemType: Crash
> Architecture: amd64
> Date: Thu May 29 00:27:34 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/lib/gvfs/gvfs-fuse-daemon
> NonfreeKernelModules: nvidia
> Package: gvfs-fuse 0.2.4-0ubuntu1
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/gvfs//gvfs-fuse-daemon
> /home/username/.gvfs
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/opt/bin:/opt/share/modeltech/linux_x86_64:/opt/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: gvfs
> StacktraceTop:
> pthread_mutex_lock () from /lib/libpthread.so.0
> g_main_loop_quit () from /usr/lib/libglib-2.0.so.0
> ?? ()
> fuse_fs_destroy () from /lib/libfuse.so.2
> ?? () from /lib/libfuse.so.2
> Title: gvfs-fuse-daemon crashed with SIGSEGV in
> pthread_mutex_lock()
> Uname: Linux 2.6.24-17-generic x86_64
> UserGroups: adm admin audio cdrom chrisandjo-rw dialout dip
> fax floppy fuse lpadmin plugdev sambashare scanner shared-rw
> tape tilp video vmware xp-write

      Explore your hobbies and interests. Go to http://in.promos.yahoo.com/groups/

Austin Lund (austin-lund) wrote :

I am able to recreate this one now. The following is the recipe:

1. Start with a working DBus session.
2. Run the gvfs-fuse-daemon
3. Kill the DBus session without disconnecting the gvfs-fuse-daemon session.

You should find that it crashes under these conditions and gives exactly the backtraces given above.

Note that most of your desktop will also be killed off.

Austin Lund (austin-lund) wrote :

It is not possible to create this in the single thread mode. So here is a snippit from valgrind from the thread that dies:

==13915== Invalid read of size 4
==13915== at 0x5929D06: g_main_loop_quit (gmain.c:2875)
==13915== by 0x403B39: vfs_destroy (gvfsfusedaemon.c:2147)
==13915== by 0x5DFA888: fuse_fs_destroy (fuse.c:1347)
==13915== by 0x5DFA8E7: fuse_lib_destroy (fuse.c:1360)
==13915== by 0x5DFFE69: fuse_ll_destroy (fuse_lowlevel.c:1254)
==13915== by 0x5E02EF2: fuse_session_destroy (fuse_session.c:96)
==13915== by 0x5DF9792: fuse_destroy (fuse.c:3251)
==13915== by 0x5E031FD: fuse_teardown_common (helper.c:303)
==13915== by 0x5E03702: fuse_main_common (helper.c:331)
==13915== by 0x685A1C3: (below main) (in /lib/libc-2.7.so)
==13915== Address 0x70e4c0c is 12 bytes inside a block of size 16 free'd
==13915== at 0x4C22B2E: free (vg_replace_malloc.c:323)
==13915== by 0x403F73: subthread_main (gvfsfusedaemon.c:2035)
==13915== by 0x5951053: g_thread_create_proxy (gthread.c:635)
==13915== by 0x66263F6: start_thread (in /lib/libpthread-2.7.so)
==13915== by 0x6913B2C: clone (in /lib/libc-2.7.so)
==13915==
==13915== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 8 from 1)
==13915== malloc/free: in use at exit: 79,083 bytes in 816 blocks.
==13915== malloc/free: 1,691 allocs, 875 frees, 1,025,879 bytes allocated.
==13915== For counts of detected errors, rerun with: -v
==13915== searching for pointers to 816 not-freed blocks.
==13915== checked 291,296 bytes.
==13915==
==13915== LEAK SUMMARY:
==13915== definitely lost: 4 bytes in 2 blocks.
==13915== possibly lost: 2,592 bytes in 22 blocks.
==13915== still reachable: 76,487 bytes in 792 blocks.
==13915== suppressed: 0 bytes in 0 blocks.

Austin Lund (austin-lund) wrote :

This patch fixes this for me.

I don't know if it is the best way of fixing it. Perhaps someone could suggest something better.

Sebastien Bacher (seb128) wrote :

the issue might be similar to http://bugzilla.gnome.org/show_bug.cgi?id=536614, could you attach you patch upstream and ask for comments there?

Austin Lund (austin-lund) wrote :

This bug has been filed upstream as I cannot seem to find a repeat of it there.

http://bugzilla.gnome.org/show_bug.cgi?id=543552

Sense Egbert Hofstede (sense) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=543552 contains the same patch as bug http://bugzilla.gnome.org/show_bug.cgi?id=536614
Doesn't the rule is that a bug is a duplicate when it has the same cause? This is the case here.

Anyway, there are other bugs at Launchpad that are linked to in gnome bug 536614 , so it's possible that there are also more duplicates here. Someone who knows in detail the stories behind these bugs probably should have a look at it. Austin, you seem to have written the patch, what are your reasons for filing a second bug at GNOME Bugzilla?

Austin Lund (austin-lund) wrote :

My patch addresses a completely different issue to the bug that was already linked.

The bug I was fixing has nothing to do with http://bugzilla.gnome.org/show_bug.cgi?id=536614. In particular, the problem itemized in this bug is very different to that bug.

My patch can _only_ fix bugs when the dbus connection is severed. This is not he case with http://bugzilla.gnome.org/show_bug.cgi?id=536614.

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.99.3-0ubuntu1

---------------
gvfs (0.99.3-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Fix frequent crasher in volume monitor

gvfs (0.99.2-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Move hal and gphoto volume monitors out of process
    - Fix recursive copying (lp: #205370)
    - Require glib >= 2.17.4
    - Make the fuse daemon more reliable (lp: #235698)
    - Many smaller bugfixes
  * debian/control.in:
    - updated libglib requirement
  * debian/patches/80_samba_browsing_authentification.patch:
    - dropped since the changes create some issues
  * debian/patches/90_from_svn_fix_fuse_crasher.patch:
    - dropped since the changes are in the new version
  * updated install lists for the new version changes

 -- Sebastien Bacher <email address hidden> Thu, 24 Jul 2008 16:09:03 +0200

Changed in gvfs:
status: Confirmed → Fix Released
ingo (ingo-steiner) wrote :

good to know, but please consider:

1. this bug was reported for Hardy
2. Hardy LTS will survive Intrepid by far with regard to updates.

So, when does the fix come for Hardy?

Sebastien Bacher (seb128) wrote :

the fix will be uploaded as an hardy update candidate after getting some testing in intrepid

Austin Lund (austin-lund) wrote :

I very much doubt that the initial issue has been fixed.

It seems that upstream bug 536614 might have been fixed, but that doesn't deal with shutdown. And if you take 3 seconds to look at the backtraces in the initial reports in this bug, you will see that vfs_destroy predominates.

There appears to be no changes which deal with this issue in the destroy code, and I have clearly identified why this crash is occurring and none of those issues have been fixed.

Unless there is a patch that has been incorporated into the ubuntu release. Unfortunately I cannot easily find the reported fixer version so I'll have to look for it later unless someone can give me a link to the package which I can test.

Hew (hew) wrote :

I got this again just now on Intrepid (gvfs/intrepid uptodate 0.99.3-0ubuntu1). Not fixed, setting status to triaged. If my latest .crash is useful, let me know and I'll submit it.

Changed in gvfs:
status: Fix Released → Triaged
Austin Lund (austin-lund) wrote :

What do you know. I was right!

If anyone has the time..... (which I don't, sorry)..... the please try to recreate this by the procedure I described in the comments above (https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/235698/comments/27). You might need to try this a few times to get it to crash.

Then try my patch (http://launchpadlibrarian.net/16028112/patch1.txt) and do the same.

Sebastien Bacher (seb128) wrote :

could you try to open a bug on bugzilla.gnome.org and attach your patch there rather than add comments rather? the current ubuntu team is overworked and not writting this code so you are just commenting at the wrong place to get feedback on your changes, the bugtriagers can send your patches upstream and forward comments between bugs trackers if you want but that's going to take some time and not being efficient, you should better discuss directly your changes in bugzilla.gnome.org

Sebastien Bacher (seb128) wrote :

alright, you did and that's http://bugzilla.gnome.org/show_bug.cgi?id=543552, there is several bugs described on this launchpad bug and that doesn't make things easier to read, note that dbus should be stable so those crashes are likely triggered on session closing only and not something users notice

Changed in gvfs:
status: Unknown → New
Changed in gvfs:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.99.4-0ubuntu1

---------------
gvfs (0.99.4-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Require glib >= 2.17.6
    - Support und update serialization of GEmblem and GEmblemedIcon
    - Add x-content/* support to daemon mounts
    - Use standard icon names
    - Bug fixes
      545695 – any new volume is mounted twice (lp: #251991)
      545489 – Nautilus hangs when inserting a CD
      544008 – g_daemon_file_replace_async mode err
      543552 – gvfs-fuse-daemon crashes if dbus dies (lp: #235698)
      528891 – Handle URI schemes case insensitive
      525779 – Dont look for trashs dir on sys mounts
      545968 – leaks xml documents in error cases
      545966 – Disallow net access to WebDAV xml parser
      509740 – Trash icon not updated ..
      539167 – Use g_set_error_literal where appropriate
      528848 – [PATCH] statfs lies
      518284 – need to add i18n on module branching
    - Translation updates
  * debian/control.in:
    - updated libglib requirement
  * debian/patches/90_upstream_change_fix_rhythmbox_crasher.patch:
    - upstream change to fix incorrectly url parsing leading to a rhythmbox
      crasher, thank gicmo (lp: #254617)
  * debian/patches/91_no_autofs_trashs.patch:
    - the change is in the new version now

 -- Sebastien Bacher <email address hidden> Tue, 05 Aug 2008 11:03:15 +0200

Changed in gvfs:
status: Triaged → Fix Released
goto (gotolaunchpad) wrote :

Any ideas when it will be fixed in hardy?

goto (gotolaunchpad) wrote :

Or am I wrong and such bugs don't get fixed usually in "finished" distributions? An answer would be nice, I experience this bug every single boot. /: Thanks!

Austin Lund (austin-lund) wrote :

I think you will find your answer in comment 36.

https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/235698/comments/36

That doesn't mean you will necessarily like the answer.

My patch should apply to the version shipped in Hardy, so you could roll your own in the meantime.

goto (gotolaunchpad) wrote :

Thanks for the answer! And sorry for the noise :$

Keeganza (kevin-liam-keegan) wrote :

How do I implement this patch?

Richard Ayotte (rich-ayotte) wrote :

Has the Intrepid version had enough testing? It's been over a month now.

matthewrebus (mrebus) wrote :

Sorry could you explain what you mean. and what do you think I have to do
with intrepids amount of testing.

2008/9/12 Richard Ayotte <email address hidden>

> Has the Intrepid version had enough testing? It's been over a month now.
>
> --
> gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/235698
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Fix Released
> Status in "gvfs" source package in Ubuntu: Fix Released
> Status in gvfs in Ubuntu Hardy: Confirmed
>
> Bug description:
> Binary package hint: gvfs
>
> I'm not sure when this crash happened. I was notified when I logged in
> first thing this morning
>
> ProblemType: Crash
> Architecture: amd64
> Date: Thu May 29 00:27:34 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/lib/gvfs/gvfs-fuse-daemon
> NonfreeKernelModules: nvidia
> Package: gvfs-fuse 0.2.4-0ubuntu1
> PackageArchitecture: amd64
> ProcCmdline: /usr/lib/gvfs//gvfs-fuse-daemon /home/username/.gvfs
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/opt/bin:/opt/share/modeltech/linux_x86_64:/opt/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: gvfs
> StacktraceTop:
> pthread_mutex_lock () from /lib/libpthread.so.0
> g_main_loop_quit () from /usr/lib/libglib-2.0.so.0
> ?? ()
> fuse_fs_destroy () from /lib/libfuse.so.2
> ?? () from /lib/libfuse.so.2
> Title: gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> Uname: Linux 2.6.24-17-generic x86_64
> UserGroups: adm admin audio cdrom chrisandjo-rw dialout dip fax floppy fuse
> lpadmin plugdev sambashare scanner shared-rw tape tilp video vmware xp-write
>

Richard Ayotte (rich-ayotte) wrote :

@matthewrebus: I was refering to Sebastien Bacher response to ingo on July 24th https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/235698/comments/36. He mentioned that once that patch was tested in Intrepid that it would be uploaded as a Hardy update candidate but I haven't seen it yet so I bumped the thread.

ROCRESPO (ricardoo-crespo) wrote :

please fix, tanks

Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gvfs:
status: Confirmed → Fix Committed
Nick Jenkins (nickpj) wrote :

From the instructions on https://wiki.ubuntu.com/Testing/EnableProposed , I think you can maybe replace this last line
 sudo aptitude -t hardy-proposed
With this command, so as to just install these updates, without the confusing text-based interface:
 sudo aptitude install -t hardy-proposed gvfs-fuse gvfs-backends gvfs
(I'm no expert though, but that's what I did, and rebooted, and it seems to be working okay - no crashes so far).

ingo (ingo-steiner) wrote :

Congratulations to Sebastian for the fix!

Hardy-amd64

I upgraded these packages from hardy-proposed::
gvfs-fuse
gvfs
gvfs-backends

and tried all the things which prior lead to the crash, like switching user, (u)mounting nfs-exports, several reboots, ...
The crash is gone, was unable to get this annoying dayly crashes happen any more.
Please excuse the duplicates that my apport produced in launchpad.

Is there any need to pin those versions, or will they soon move to the standard repository?

ingo [2008-10-30 11:47 -0000]:
> Is there any need to pin those versions, or will they soon move to the
> standard repository?

Yes, they'll move to -updates in a few days, when we don't hear about
regressions.

I've installed the "hardy-proposed" update and it works. No problems.

Thanks!
Klaus

Martin Pitt (pitti) wrote :

Copied hardy-proposed to hardy-updates.

Changed in gvfs:
status: Fix Committed → Fix Released
ingo (ingo-steiner) wrote :

Many thanks, seems this fix really cures the bug.
My 'apport' has become unempoyed since then ;-)

My English is very bad. Sorry. I am very grateful for the efforts they have
taken in this matter, which fortunately was resolved. Many, thank you very
much. See you soon friends.

2008/11/6 ingo <email address hidden>

> Many thanks, seems this fix really cures the bug.
> My 'apport' has become unempoyed since then ;-)
>
> --
> gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/235698
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Ricardo O. Crespo

S B (seuzy8) wrote :

I still don't understand how to fix this in Intrepid. I have the most recent stable version of gvfs, so what is still the problem?

Chris Coulson (chrisccoulson) wrote :

S B - This bug is fixed. If you are still experiencing crashes in gvfs, you should submit a new crash report and let the retracer handle it

S B (seuzy8) wrote :

Thank you. I'm pretty sure it is a crash, or something relating to it is not functioning properly, causing me to lose my sound. When I run the command "sudo alsa reload," I get this error message:

lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/zee/.gvfs
      Output information may be incomplete.

Also:

$ sudo /usr/lib/gvfs/gvfs-fuse-daemon
fuse: missing mountpoint

Should I file a bug report? And, if so, how do I do this? I apologize for posting here somewhat out of topic. I'm a n00b to this web site, and I hope you understand.

Chris Coulson (chrisccoulson) wrote :

That's not a crash and is unrelated to this problem. Your problem is related to bug #225361

ROCRESPO (ricardoo-crespo) wrote :

Ok, thank you for your concern. I see it as a fix to this issue by the time
I was not too bothered going to know that strange reason. Thank you very
much and good life for you. (my english is too bad, sorry!)

2008/11/11 Chris Coulson <email address hidden>

> That's not a crash and is unrelated to this problem. Your problem is
> related to bug #225361
>
> --
> gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/235698
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Ricardo O. Crespo

S B (seuzy8) wrote :

Yeah, you're right. That bug more corresponds to my problem. Thanks!

ROCRESPO (ricardoo-crespo) wrote :

Sorry if I have not lived up to the circumstances, but my English is almost
nothing, I helped with the translator of Google to be able to understand and
answer your mails. You command a very cordial greeting from Buenos Aires,
Argentina, and I remain at your disposal for what we humbly can help you.
Mucha Suerte!
Ricardo O. Crespo

2008/11/11 S B <email address hidden>

> Yeah, you're right. That bug more corresponds to my problem. Thanks!
>
> --
> gvfs-fuse-daemon crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/235698
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Ricardo O. Crespo

Changed in gvfs:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.