Copy files from bluetooth device: Error in stream protocol: end of stream"

Bug #222043 reported by mmalmeida on 2008-04-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gvfs
Expired
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Karmic by kmARC

Bug Description

Binary package hint: bluez-gnome

1) In bluetooth manager (bluez bluetooth applet 0.25), right-click - browse device.
2) I choose my Windows Mobile 5 smartphone
3) I see my smartphone's shared folder

4) If I try to copy a file bigger than 5k FROM the device TO my Ubuntu Hardy, I get the message:

Error in stream protocol: end of stream

Small, 1k files are transfered without a problem

Onkar Shinde (onkarshinde) wrote :

The browsing of bluetooth devices is handled by gvfs, hence changing package.

Can you also tell us if you see any message on device when you are trying to copy file. Some devices show message asking whether you want to allow access.

mmalmeida (mmalmeida) wrote :

The Windows Media 5 device does not show any message. It only turns its background light on when I click the "browse device" option.

mmalmeida (mmalmeida) wrote :

Any update on this issue?

How can one transfer files bigger than 5k without causing this problem?

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you run /usr/lib/gvfs/gvfsd -r on a command line, try to copy the file using nautilus and attach the log to the bug?

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
mmalmeida (mmalmeida) wrote :

Ok, I've just run the command:

/usr/lib/gvfs/gvfsd -r > output

In Bluetooth applet, I've "browse device". In the Nautilus window that opened, I selected "Hugo Boa Morte.doc" (14 k) and tried copying to the desktop.

I attach two files:

1) log - command line information

2) output - the resulting output file of the command I ran.

mmalmeida (mmalmeida) wrote :
Sebastien Bacher (seb128) wrote :

not sure what goes wrong there, could you open the bug directly on bugzilla.gnome.org? the upstream hackers are likely to have better clues about what is going wrong there

mmalmeida (mmalmeida) wrote :
Pedro Villavicencio (pedro) wrote :

linking the report, thanks.

Changed in gvfs:
status: Incomplete → Triaged
Changed in gvfs:
status: Unknown → New
kmARC (korondi-mark) wrote :

Also the same problem in karmic RC.

SamTzu (sami-mattila) wrote :

Same problem in Mint8 SSH copy.

"Error in stream protocol: end of stream"

Related to this error..?

"Error: DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered Please select another viewer and try again."

Changed in gvfs:
importance: Unknown → Medium
remort (master-remort) wrote :

it's because of the memory lacks. i tried to upload ~700 Mb avi movies to my samsung galaxy tab and it worked fine, but PC goes slow down while copying. when i try to upload anything greater than 1,1 Gb it fails. end of stream. i launchet top and found out that free RAM memory goes to zero by the time at the error rizes up. if i had 4Gb ram at my home pc instead of 2Gb - it worked well for me, i think. gvfs sucks hence it's IO ops depends on RAM.

Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.