Ubuntu

Error copying file to bluetooth device

Reported by mrAshley on 2008-03-18
108
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Hardy by Sebastien Bacher
Nominated for Intrepid by Alexander Zolotko

Bug Description

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

blueman perhaps?

From the icon in my tray I was able to access my bluetooth device, and even stream an mp3 to totem, but I can not copy a file to the device (a Sony Ericsson Z710i) which is known to be writable. I've taken a screen cap of the error, but it says "Operation not supported by backend"

mrAshley (launchpad-mrashley) wrote :
Ahmed Osman (ashex) wrote :

Having a similar issue, paired my blackberry to my desktop, can't seem to transfer files to it with the Bluetooth OBEX Object Push Client, devices are paired, trusted, and connected when attempting it. When I try using Dolphin to transfer, the message "Writing to kio_sdp is not supported." appears.

John Cooper (choffee) wrote :

This is because the gvfs-obexftp does not support writing yet. There is an upstream bug at http://bugzilla.gnome.org/show_bug.cgi?id=519071

Changed in gvfs:
status: Unknown → New
Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Martin Leopold (martin-leopold) wrote :

Hi all.
I have the same problem - what is puzzling me is that this used to work just fine prior upgrading to Hardy!?

Is this a problem that is being worked on or is there other application in Ubuntu to browse and upload files?

Regards,
Martin Leopold.

Sebastien Bacher (seb128) wrote :

declining the hardy task since that's not changes for a stable update

Kai Schroeder (kai-schroeder) wrote :

martin: you can use the 'send to' function in gnome bluetooth applet or in the nautilus context menu of a file to upload files.

karlrt (karlrt) wrote :

dear kai!

as described in the duplicate of this bug: https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/227373/comments/1 martin wont be able to upload files easily. Only if the phone is not connected, but then browsing wont work :) thats a really funny behaviour.

Well will this bug be fixed in the near future? id really like to throw away my usb connection cable :)

dancer58 (dancer581) wrote :

The sendto function will only send contacts. It will not send anything thing else
Probably has something to do with the phone with the SD card

reference bug # 291879

Harold

Changed in gvfs:
status: New → Confirmed
Changed in gvfs:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

this has been fixed upstream now.

Changed in gvfs:
status: Triaged → Fix Committed

This is fixed in Jaunty now. Thanks for reporting.

Changed in gvfs:
status: Fix Committed → Fix Released
dancer58 (dancer581) wrote :

I still get "Operation not supported by backend" when trying to paste songs, pictures, ect to phone.
Problem not fixed in Intrepid !!!

Intrepid
Linux asus 2.6.27-13-generic #1 SMP Thu Feb 26 07:26:43 UTC 2009 i686 GNU/Linux
with all current updates

Victor Osadci (victor-os) wrote :

@dancer58,

Are you sure you have all the updates ?

This works for me on 9.04, and my kernel is "2.6.28-9-generic #29-Ubuntu SMP Sun Mar 8 02:03:17 UTC 2009 i686 GNU/Linux"

Marcus Sundman (sundman) wrote :

I'm sure I have all the updates (including backports and security fixes), and writing to bluetooth obex://... dirs does NOT work for me.
I'm running intrepid and "2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux".

jamorod (javier-ecam) wrote :

I still get the error org.openobex.Error.NotSupported ... what could be the reason for this? How can I solve it?

sijk (simo-kivimaki-fi) wrote :

I can still repeat this bug using up-to-date Lucid and Nokia N97 mini.

Changed in gvfs:
importance: Unknown → Medium
PCWinWeb (devlabn) wrote :

Huh? this bug is on me aswell, but for some reason i managed to copy a 4.0 MB song Yet a 7.9/18 MB Song, i can't copy!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.