nautilus hangs after network disconnect

Bug #202861 reported by Robbert on 2008-03-16
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nautilus-cd-burner
Fix Released
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
nautilus-cd-burner (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

Release: Ubuntu Hardy amd64

Gvfs version 0.2.0.1-0ubuntu2

When using Nautilus to browse on a remote location using sftp it hangs after and while my network had a disconnection. Killing gvfs, gvfs-sftp and nautilus is the only solution. It should give an error that my network connection is unavailable instead.

Steps to reproduce:
* Start nautilus
* Browse on a remove location using sftp
* Disconnect your network
* This causes nautilus to hang completely, killing gvfs, gvfs-sftp and nautilus is the only solution

* After a reconnect it sometimes get working again, and sometimes remains dead.

The same here. Also, the panel hangs indefinitly or keeps crashing and restarting until I kill gvfsd, gvfsd-sftp and nautilus.

Sebastien Bacher (seb128) wrote :

The issue is not due to gvfs

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=523146

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in nautilus-cd-burner:
status: Unknown → New
Changed in nautilus-cd-burner:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream. thanks for reporting.

Changed in nautilus-cd-burner:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

 nautilus-cd-burner (2.22.0-0ubuntu2) hardy; urgency=low
 .
   * debian/patches/06_dont_do_sync_calls.patch:
     - don't do sync calls, those are slow and can block nautilus when
       the network disconnects, thanks Christian Kellner (lp: #523146)

Changed in nautilus-cd-burner:
status: Fix Committed → Fix Released

Is the fix incorporated into Hardy?
I'm using sftp intensively and this bug is killing me...

Changed in nautilus-cd-burner:
importance: Unknown → Medium
Odin Hørthe Omdal (velmont) wrote :

Most people probably want this bug instead:

https://bugzilla.gnome.org/show_bug.cgi?id=523146

I don't know what happened to this bug, what should a CD burner program have to do with sftp-connections?

Semo (semox78) wrote :

I use Trusty Thar. After disconnecting the LAN cable and plugging in another, nautilus will not restart. Also in the Terminal, when using "top" program, then a process consuming 100% of CPU power, is called "gvfsd-sftp".

It seems, that this is not an invalid issue. Because it is reproducible.

Regards,
Sebastian

Semo (semox78) wrote :

I use Trusty Thar. After disconnecting the LAN cable and plugging in another, nautilus will not restart. Also in the Terminal, when using "top" program, then a process consuming 100% of CPU power, is called "gvfsd-sftp".

It seems, that this is not an invalid issue. Because it is reproducible.

Regards,
Sebastian

Changed in gvfs (Ubuntu):
status: Invalid → Incomplete
Jérôme Poulin (jeromepoulin) wrote :

This is really annoying and happens on all 4 of my machines.

Changed in gvfs (Ubuntu):
status: Incomplete → Confirmed
Pietro Battiston (toobaz) wrote :

I am pretty sure the bug most of us are experiencing is
https://bugzilla.gnome.org/show_bug.cgi?id=735953
which by the way was fixed in git.

So I'm reassigning from gvfs to gtk+3.0 .

The patch in comment 7:
https://bug735953.bugzilla-attachments.gnome.org/attachment.cgi?id=285251
should really be adopted by distributors.

affects: gvfs (Ubuntu) → gtk+3.0 (Ubuntu)
Jérôme Poulin (jeromepoulin) wrote :

I disagree, the bug shown in the link gives a "ps" output when the problem is present and show no excessive CPU usage while this bug has gvfs stuck in a tight loop somewhere, my backtrace was snapshot when this 100% CPU usage pattern was present, other comments in the bug have the same outcome.

Pietro Battiston (toobaz) wrote :

You are right, sorry for the noise.

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → gvfs (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.