gvfsd-gphoto2 crashed with SIGSEGV in pthread_mutex_lock()

Bug #202304 reported by yannis on 2008-03-14
154
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gvfs
Expired
Critical
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

when dclick on the Canon A510 icon

ProblemType: Crash
Architecture: i386
Date: Fri Mar 14 21:39:37 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/gvfs/gvfsd-gphoto2
Package: gvfs-backends 0.2.0.1-0ubuntu2
PackageArchitecture: i386
ProcCmdline: /usr/lib/gvfs/gvfsd-gphoto2 --spawner :1.5 /org/gtk/gvfs/exec_spaw/5
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gvfs
Stacktrace:
 #0 0xb7d41540 in pthread_mutex_lock ()
    from /lib/tls/i686/cmov/libpthread.so.0
 #1 0x0804f5e2 in ?? ()
 #2 0x00000000 in ?? ()
StacktraceTop:
 pthread_mutex_lock ()
 ?? ()
 ?? ()
Title: gvfsd-gphoto2 crashed with SIGSEGV in pthread_mutex_lock()
Uname: Linux 2.6.24-12-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev video
SegvAnalysis:
 Segfault happened at: 0xb7d41540 <pthread_mutex_lock+32>: mov 0xc(%edi),%edx
 PC (0xb7d41540) ok
 source "0xc(%edi)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA

yannis (yannis-lg) wrote :

StacktraceTop:pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
file_get_info (gphoto2_backend=0x8078818, dir=0x80aa638 "/", name=0x80a9698 "",
try_query_info (backend=0x8078818, job=0x80aa808, filename=0x80a9640 "/",
try (job=0x80aa808) at gvfsjobqueryinfo.c:170
g_vfs_job_try (job=0x80aa808) at gvfsjob.c:216

Changed in gvfs:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=522944

Changed in gvfs:
assignee: nobody → desktop-bugs
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

Comment from upstream:

" Any chance you can reproduce this with the
gphoto commandline tools (e.g. run 'gphoto2 -L') and other gphoto2 using apps
(e.g. f-spot, gthumb)? Thanks."

Changed in gvfs:
status: Triaged → Incomplete
Changed in gvfs:
status: Unknown → Incomplete
Omegamormegil (omegamormegil) wrote :

Pedro, I just experienced a crash which may be related. Here's a link to my bug report: https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/207911

Joachim Beckers (jbeckers) wrote :

omegamoregil: it's most probably is a duplicate of this bug. at least they marked my bug report (202437, also sansa-related) as a dupe.

Florent Mertens (givre) wrote :

I can confirm this bug.
I also can confirm that 'gphoto2 -L' works, so this has nothing to do with the sansa issue.

I also found that when mounting with right-click->mount it works. Can somebody try that ?

Changed in gvfs:
status: Incomplete → Confirmed
Changed in gvfs:
status: Confirmed → Triaged
Changed in gvfs:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

is someone still experiencing this with jaunty or intrepid?

Changed in gvfs:
status: Triaged → Incomplete

I'm using Intrepid and I haven't seen the bug anymore.

On Wed, Jan 28, 2009 at 12:19 PM, Pedro Villavicencio <email address hidden>wrote:

> is someone still experiencing this with jaunty or intrepid?
>
> ** Changed in: gvfs (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> gvfsd-gphoto2 crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/202304
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: New
> Status in "gvfs" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gvfs
>
> when dclick on the Canon A510 icon
>
> ProblemType: Crash
> Architecture: i386
> Date: Fri Mar 14 21:39:37 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/lib/gvfs/gvfsd-gphoto2
> Package: gvfs-backends 0.2.0.1-0ubuntu2
> PackageArchitecture: i386
> ProcCmdline: /usr/lib/gvfs/gvfsd-gphoto2 --spawner :1.5
> /org/gtk/gvfs/exec_spaw/5
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=fr_FR.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: gvfs
> Stacktrace:
> #0 0xb7d41540 in pthread_mutex_lock ()
> from /lib/tls/i686/cmov/libpthread.so.0
> #1 0x0804f5e2 in ?? ()
> #2 0x00000000 in ?? ()
> StacktraceTop:
> pthread_mutex_lock ()
> ?? ()
> ?? ()
> Title: gvfsd-gphoto2 crashed with SIGSEGV in pthread_mutex_lock()
> Uname: Linux 2.6.24-12-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev video
>

Pedro Villavicencio (pedro) wrote :

Great thanks, marking this as fixed then, feel free to reopen if you encounter the same issue with jaunty.

Changed in gvfs:
status: Incomplete → Fix Released
Changed in gvfs:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

reopening there is some recent duplicates

Changed in gvfs:
status: Fix Released → Triaged
mike (ubuntu-holmesfamily) wrote :

I just experienced this in Jaunty Beta

Changed in gvfs:
status: Invalid → New
Kees Cook (kees) on 2009-09-16
description: updated
David Fourer (dfourer) wrote :

Apport reported a crash in Lucid when I plugged in my camera. It was marked as duplicate of this bug.
[Bug 575536] Re: gvfsd-gphoto2 crashed with SIGSEGV in pthread_mutex_lock()
I can move photos from camera to computer as follows:
plug in camera and ignore crash warning.
gThumb opens by default
select from menu--places>cannon powershot 1100IS>un-mount
download photos as usual.

Changed in gvfs:
importance: Unknown → Critical
Bill (hudacek) wrote :

Not seeing exactly the same symptom here....but thought I'd post this as it may help someone else. When connecting camera (Fuji FinePix F30) to USB, it mounts it as disk, AND starts gthumb...though removable drives prefs are *cleared*. Checking the box and unchecking it does nothing, Gnome must be convinced it's the only desktop environment anyone needs... :-)

Linux darla 2.6.28-19-generic #66-Ubuntu SMP Sat Oct 16 17:39:04 UTC 2010 i686 GNU/Linux
Description: Ubuntu 9.04

/var/local/messages:
gvfsd-gphoto2[6541]: segfault at c ip b75fa9e0 sp bfa08ae4 error 4 in libpthread-2.9.so[b75f3000+15000]

Re-installing (not remove+install, or purge+install) the following has cleared the error condition, and the camera is no longer mounted upon connection (?!), but (of course) gthumb still starts, though it's still unchecked in preferences.

gthumb gthumb-data gvfs-backends libgphoto2-2 libgphoto2-port0 dcraw

Hope this helps someone....

/Bill

Bill (hudacek) wrote :

Ah, well, spoke too soon - looks like, if the volume is not mounted as removable media (disk), that the crash does not occur.

What I'm seeing after a reboot is this error on connecting the camera:

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

...and the disk is not mounted when this occurs.

Sure looks like it's related to the volume being mounted that is causing the crash here.

/Bill

GuyR (guy-rouger) wrote :

Occurs when my Nokia Xpress Music was connected through usb

Rolf Leggewie (r0lf) wrote :

Closing as obsolete, this is most likely fixed

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Changed in gvfs:
status: New → Confirmed
Changed in gvfs:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.