Ubuntu

user-mountable (nfs) filesystems are not showing up in Computer view of nautilus

Reported by Michael R. Head on 2008-02-24
48
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gvfs
Fix Released
Medium
gvfs (Debian)
Fix Released
Unknown
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

I have several nfs setup mounts that have the 'user' option in /etc/fstab. Up until hardy (which I just updated to yesterday), these mounts would show up in Computer. This is no longer the case, and I have no way to graphically mount those nfs shares.

This is with nautilus 1:2.21.91-0ubuntu3

Byron Poland (wpoland) wrote :

I agree, I use user mountable nfs shares for my music and video at home, but on my laptop, I don't automount them since there is no use when I'm on the road etc. Double clicking in the "Computer" portion of nautilus was very useful.. is this just a gvfs regression, or is it gone for good?

Joel Oliver (joelol75) wrote :

Yes, this bug hits me hard on my laptop. It was really convenient for me to add nfs shares for every computer I may encounter in travel with nfs shares with noauto,user in the fstab file. Then just click on them in nautilus to mount them. Super quick and easy. Now with hardy I cannot see any of these and must manually mount every share on the command line... Or build a script to do it... Not very user friendy and I am not using Windows computers so I am NOT using samba. If this feature to display unmounted shares is removed, is there a config file I can change this? (Should be in nautilus' preferences but it's not) If not is there another way?

Joel Oliver (joelol75) wrote :
Changed in nautilus:
importance: Undecided → Low
Øyvind Stegard (oyvinst) wrote :

I've been bitten by this as well, after upgrading to Hardy. Although I actually use CIFS, even though I only have Linux-boxes around. In Gutsy, the fstab-mounts would show up in Nautilus, and allow one-click mounting. No more it seems. Even worse is that the smb:/// protocol in Nautilus/gvfs seems buggy at best, with duplicate entries showing up when accessing a share, and problems connecting as my own user and not guest/anonymous (which results in read-only access).

Øyvind Stegard (oyvinst) wrote :

Sorry, I somehow and unintentionally marked the bug as affecting Nautilus as well (well, I guess it does, but ..). Can be removed :)

Sebastien Bacher (seb128) wrote :

the bug is not a nautilus one

Changed in nautilus:
importance: Undecided → Low
status: New → Invalid
Tim Cole (timothy-j-cole) wrote :

I would also like to see this feature reinstated. I used it for both nfs and smbfs mounts.

Jan Rüegg (rggjan) wrote :

Same problem here... Would be nice to reenable this again.

Changed in gvfs:
status: Unknown → New
Changed in gvfs:
status: Unknown → New
Changed in gvfs:
assignee: nobody → desktop-bugs
status: New → Triaged
jdm64 (jdm64) wrote :

Is there some current workaround for this "regression"? I have a friend that I installed Ubuntu on his computer and he uses my nfs server. It's easy for him to right click and mount the drive from nautilus (he's using 7.10). But if he upgrades to 8.4, he would have to use the cli to mount the drive.

Michael R. Head (burner) wrote :

It's possible to use the gnome-mount applet:

Right click on a panel,
select Add to Panel
search for "mount"
double click the "Disk Mounter" line.

A set of buttons (one for each user-mountable point) should appear in the panel.

Peter Garrett (peter-garrett) wrote :

This still exists in Ubuntu 8.04.1

Not only that, but if you right click a directory with the intention to "share" it as NFS, you get:

"! Sharing service is not installed. You need to install the Windows networks sharing service in order to share your folders"

This is demonstrably false, since I am able to "share" my "folders" using nfs-kernel-server as I have always done.

I don't use Windows... How is this remotely applicable? It also gives the impression that the only "sharing" option is a Windows option.

Sam Hathaway (sam.hathaway) wrote :

Peter, what does that have to do with GVFS not reporting NFS mounts to Nautilus? Please file a separate bug for your unrelated issue.

Gergely Csépány (cheoppy) wrote :

Still not fixed as of July 24.
Does a manual workaround exists? I'm a laptop user, and use various windows shares, which now I have to mount in a terminal, not so convenient...

Dmitriy Geels (dmig) wrote :

here was workaround: https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/195180/comments/11

it's ugly, but it's most useful

Gergely Csépány (cheoppy) wrote :

Thanks, I tried that, it's really *ugly* to have 10+ network drives on a panel, but it seems I can use it until a solution is found or created.

Michael R. Head (burner) wrote :

Just updated to intrepid, and now even the gnome-mount workaround fails: (bug #282922)

JediMonkey (jedimonkey) wrote :

I found a workaround whilst trawling for a fix from a mandriva bug report:
http://www.nabble.com/-Bug-42792--nautilus,-NEW:-Nautilus-will-no-longer-show-NFS-shares-from-fstab-in-computer:---td18978063.html

Put the mount point in /media and it automatically appears (as well as ensuring 'user' in the options).

Works under intrepid :)

Jan Rüegg (rggjan) wrote :

This is not working here... My fstab entry is

192.168.1.111:/volume1/public /media/Synology nfs rw,user,hard,noauto 0 0

but there is nowhere any sign of the share in nautilus/gnome until mounting (in console with "mount /media/Synology")...

What exactly did you do, JediMonkey?

Michael R. Head (burner) wrote :

Not working here either. Migrating mountpoints to /media causes the share to appear _once it's been mounted_, but not when it's unmounted.

Also, even if it did work, that is an undue burden on administrators and users.

Wastelander (jack-grumbler) wrote :

The same here. Any changes ?

Pedro Villavicencio (pedro) wrote :

bug was submitted upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=536292 ; if you have further test cases please submit them there, thanks in advance.

Changed in gvfs:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the issue has been fixed upstream now

Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the issue is fixed in karmic now

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: New → Fix Released
Changed in hundredpapercuts:
milestone: none → round-10
Changed in gvfs (Debian):
status: New → Confirmed
Changed in gvfs:
importance: Unknown → Medium
Changed in gvfs (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.