Ubuntu

Couldn't display "network:///" - Nautilus cannot handle network:locations

Reported by Trevsie on 2008-01-24
202
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
High
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Ive got UBUNTU 10.10. When I click on NETWORK it says: ''UNABLE TO MOUNT LOCATION.'' How do I solve this PROBLEM. Im New to Linux Ubuntu 10.10!

Related branches

Shawn vega (svega85-gmail) wrote :

i have this same problem so i am conferming this bug

Changed in nautilus:
status: New → Confirmed
Caleb (caleb-marcus) wrote :

I'm confirming this on my Hardy Alpha 3 install - it was a fresh install, and it's got the latest updates.

Murat Gunes (mgunes) wrote :

Thanks for your report. This is a known problem due to the switch to gvfs.

Kow (kow) wrote :

Simple fix: Go through nautilus source and replace all network:/// with smb:///. :)

network:/// shows more than just Samba shares.
On Sat, 2008-01-26 at 05:39 +0000, Kow wrote:

> Simple fix: Go through nautilus source and replace all network:/// with
> smb:///. :)
>

Kow (kow) wrote :

Good point Caleb. My fix is more of a feature-limiting workaround then. :)

jerrylamos (jerrylamos) wrote :

O.K., where is Nautilus source, then how do I get it to be used?

Thanks, Jerry

Leon (leonbo) wrote :

I encoutered the same issue.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Triaged
Pedro Villavicencio (pedro) wrote :

Thanks friends for the report, that's already known upstream and it's a gvfs issue, you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=509600

warmrobot (imfrolov) wrote :

Yep. The same problem.

Noel J. Bergman (noeljb) wrote :

As noted by http://ubuntuforums.org/showthread.php?t=678760, if one wants just SMB shares, open an nautilus window (e.g., Places->Home Folder), hit CONTROL-L, and enter smb:/// in the location entry field. Just a quick workaround using what you already have.

Changed in nautilus:
status: Unknown → Confirmed
quink (quinks) wrote :

Just wondering...

Is 'fonts:///' working for people - Nautilus is also saying 'Nautilus cannot handle fonts: locations', and this broke in the same upgrade.

stefanlew (stefan-lew) wrote :

"fonts:///" doesn't work for me either.

Michael Losonsky (michl) wrote :

Bug still in Alpha 4.

Changed in gvfs:
milestone: none → ubuntu-8.04
Evgeny Kuznetsov (nekr0z) wrote :

ftp:/// and obex:/// don't work for me either.

ramon (agmonr) wrote :

I also can't mount to nfs

Nikolas Becker (n-becker) wrote :

obex:/// doesn't work, too.

Sebastien Bacher (seb128) wrote :

could people stop adding comments which have nothing to do with the issue? There is a bug open about obex already and nfs was not working when nautilus was using gnome-vfs either

Evgeny Kuznetsov (nekr0z) wrote :

Sebastien, if you're so irritated with the comments of people who just want to be helpful, why are you tracking this bug at all?

Sebastien Bacher (seb128) wrote :

The bug tracker is not an user forum to discuss whatever is wrong on your configuration. I'm reading the comments there because I'm working on this package and I'll make sure the issue is fixed for hardy. The bug is marked as triaged and has been sent upstream which means there is no need for other informations there, the goal of the bug tracker is to describe technical issues and get enough informations to work on those so maintainers can fix the bugs, not to have users discussed whatever is not working. There has been 8 comments added there since the bug has been set to triaged with the upstream url, which means 8 mails have been sent to people who receive already some thousand of those a week, there is no need for that, that's only making the job harder. Now if you find other issue and want to share those that's good, look at the bug list to know if there is already a bug about that and open a new one if there is none yet. The issues about obex, font, ftp are already known for example

Bruce Cowan (bruce89) wrote :

Sebastian is completely right, perhaps he should talk to the people in bug #59695.

wous (wous-deactivatedaccount) wrote :

The same problem.

Bruce Cowan (bruce89) wrote :

On Wed, 2008-02-13 at 21:49 +0000, Jakub Andrzej Michalski wrote:
> The same problem.

Please don't spam this bug (or others) with useless noise.

Chow Loong Jin (hyperair) wrote :

I'd like to mention that the GTK file chooser provided by GIO doesn't show network servers at all. Network mounts due to accessing of Samba shares are also not shown.

Sebastien Bacher (seb128) wrote :

hyperair, when adding a comment to a bug it's polite to subscribe so you get replies to your comment. I asked you on an another bug yesterday to open a new one about the issue, there is no need to comment on a different issue there that's only create noise on the bug, by mails for the people subscribed and doing the work harder for everybody

Chow Loong Jin (hyperair) wrote :

I'm sorry, I did subscribe to the bug. However, when you told me to open a new bug about this issue, I thought I'd just hunt around to see if it had been posted before. This looked rather related, so I posted here. My apologies if I thought wrong.

Sebastien Bacher (seb128) wrote :

That's alright, usually when a bug is marked triaged there is no need for new informations nor extra comments though

Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gvfs:
status: Triaged → Fix Committed
Mr.UNOwen (jerry-comp) wrote :

I selected reinstall, how come nothing is happening? Shouldn't the fix be up in Synaptic package manager?????

Chow Loong Jin (hyperair) wrote :

Bug's fixed upstream, but not yet brought down to Ubuntu. So unless you compile yourself from SVN, it won't be fixed.. for now.

Mr.UNOwen (jerry-comp) wrote :

How come it hasn't? How long till it does?

Chow Loong Jin (hyperair) wrote :

Maybe a week. Maybe more. Maybe less. Who knows?

Bruce Cowan (bruce89) wrote :

GNOME 2.21.92 is scheduled for Thursday, do I'd say a day or so before that.

Changed in nautilus:
status: Confirmed → Fix Released
Liken Otsoa (liken) wrote :

Hardy Alpha 5. When you go to net in menu, error in nautilus:

Couldn't display "network:///" - Nautilus cannot handle network:locations

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.1.8-0ubuntu1

---------------
gvfs (0.1.8-0ubuntu1) hardy; urgency=low

  * New upstream version:
    - Update for gio API changes
    - Add gphoto2 backend
    - Add network: and dns-sd: backend support (lp: #185756)
    - Http and webdav backend updates
    - Keyring support
    - Fix crashes and deadlocks
    - Add trash::item-count attribute to trash:///
    - Fix smb reads > 65535 bytes breaking on some servers
    - Fix cancellation race in reading
    - Fill in thumbnail info for backends
    - sftp: Handle host identity changes (lp: #188790)
    - Enable translations everywhere
    - Add bash completion support for command line apps
    - Fix handling of blank cds and audio cds
    - Support port in sftp uris (lp: #194482)
  * debian/control.in:
    - Build-Depends on libavahi-glib-dev, libavahi-client-dev, libgphoto2-2-dev,
      libgnome-keyring-dev and updated libhal, libglib requirement
    - update the description
  * debian/gvfs-backends.install, debian/gvfs-bin.install:
    - updated to the new version changes
  * debian/patches/80_lists_audio_and_blank_cds.patch,
    debian/patches/81_correct_audio_cds_icon_naming.patch,
    debian/patches/90_from_svn_dont_list_nfs_mounts.patch,
    debian/patches/90_from_svn_fix_fileselector_crash.patch,
    debian/patches/90_from_svn_limit_smb_reads.patch:
    - those are fixed in the new version

 -- Sebastien Bacher <email address hidden> Mon, 25 Feb 2008 23:05:47 +0100

Changed in gvfs:
status: Fix Committed → Fix Released
Liken Otsoa (liken) wrote :

Where can I find gvfs - 0.1.8-0ubuntu1 ?

I have Hardy Alpha 5 and version with last updates and version is:
gvfs - 0.1.7-0ubuntu5

Thx.

Bruce Cowan (bruce89) wrote :

Wait a few hours for it to be build and distributed on the mirror archives.

Mr.UNOwen (jerry-comp) wrote :

Good news, I now get "connect to server..." , but that's not working either when I connect to ssh.

error:
Can't display location "sftp://<my user name>@<address >:22/home/<my user name>"

But when I place the address in the address bar of the file browser, it works fine.

Also I'm still getting an error when I click on network:
network:///
Nautilus cannot handle network: locations.

Mr.UNOwen (jerry-comp) wrote :

Well I still can't connect using connect to server....

error:
Can't display location "sftp://<my user name>@<address >:22/home/<my user name>"
The specified location is not mounted

As for the good news, network now works

barbex (barbex) wrote :

Problem almost fixed.

For the first few tries I get this message:

Fehler: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Then it suddenly works!

drose (ditmar-rose) wrote :

Nautilus chrashed (after Update @ 4th of March) when selecting places/network.

michelem (michele-marcucci) wrote :

I just upgraded to Hardy fro Gutsy and every network places has disappeared (I have them in gconf-editor as /desktop/gnome/connected_servers/), is it related?

nocrack (board-divers) wrote :

I still can't display any cifs network share...

Couldn't display "smb:///london2".

Error: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Please select another viewer and try again.

of course, if I'm trying with the Ip address but it's the same things. My gusty is up-to-date from today, so I suppose I got the bugfix ...
but still nothing

Savvas Radevic (medigeek) wrote :

nocrack, your problem seems similar to mine about sftp:
http://bugs.launchpad.net/bugs/206267

This is marked as "Fix Released", yet it appears that "fonts:///" is still not working for adding and removing fonts.

The inability of Nautilus to view the fonts directory and install fonts etc. is related to this bug is it not?

Murat Gunes (mgunes) wrote :

No, that's covered by bug #193897.

Sebastien Bacher (seb128) wrote :

the issue is not a nautilus one

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
Rocko (rockorequin) wrote :

I got this bug after installing the ubuntu beta and upgrading (as of 14th Oct 09), so it seems to be back in gvfs.

Jmadero (jmadero) wrote :

I'm getting the issue now too, getting it also for ftp locations

vahagn (vahag-1985) wrote :

Same problem with Ubuntu Karmic Koala 64 bit.
Appears only when I run nautilus with gksudo.

This bug report was registered when George W. Bush was the president of the United States.

Same for the fonts:// bug noted in bug #193897

We will have moved to the moon before some of these bugs are actually addressed.

Jason Robinson (jaywink) wrote :

Just installed Lucid beta 1 (yesterday) .. and nautilus started giving this error

nautilus --version gives;
GNOME nautilus 2.29.92.1

Peter B P (peterbp) wrote :

Same error in Lucid Beta 1 updated with latest patches. Unable to browse my local network. Quite a bummer.

jfgordon (jfgordon2) wrote :

Same error here in Lucid Beta 1, also seems to give the same error when I type in fonts:///, smb:///, etc

gardner (gardnerbiggs) wrote :

same problem here with nautilus 2.30.0 running the latest of 10.04.

Zebra-Rake (faheyd) wrote :

For Christ FUCKING sakes, WHEN IS THIS GOING TO BE FIXED? 2012 when the zomibies EAT US?

Roch Delsalle (mnml) wrote :

I have the same issue with Lucid Lynx at the moment.

Alistair (alistair-dibley) wrote :

Lucid Lynx:

Fresh install (29/04/10)

Nautilus 2.30.0 Message box:
Unable to mount location
Failed to retrieve share list from server

However the smb share works with konqueror and cifs

I think that Ubuntu quality is going down!! Sorry, but bugs are so many that I started to think that best solution for all these problems is Windows XP or Windows 7.

Gnome Terminal in Ubuntu 10.04 is 2.29.6. Again beta versions in final build????!!!!

Sorry guys, but reality is reality!!!

This bug annoying me, after Lucid I can't go to my networks;/

morgoth (morgoth-loza) on 2010-05-09
Changed in gvfs (Ubuntu):
status: Fix Released → Fix Committed
Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Alexander Ilyashov (ilyashov) wrote :

I fixed this problem in Lucid Lynx by installing gvfs-backends package.

Alexander,

Thanks you for hint, it helped me a lot! Strange that this package didn't come by default.

TGP1994 (tgp1994) wrote :

I believe this bug should still be considered open. I had the same problem today. After installing gvfs-backends, everything worked fine. Perhaps that should be a depended upon by nautilus.

Sergey (alexeenkosn) wrote :

I've installed maverick a few days ago.
When I try to connect to the network share through the Places\Network and see "Could not display "network:///"" message.
when trying to install gvfs-backends - "gvfs-backends is already the newest version."

Pedro Villavicencio (pedro) wrote :

Maverick issue is being tracked on bug 631960 ; please do not comment on closed bugs, if you think you're having a similar one please do open a new report with : ubuntu-bugs gvfs. Thanks.

Changed in nautilus:
importance: Unknown → High
TGP1994 (tgp1994) wrote :

Why did this old bug just get its importance changed?

Kuzzy (kuz911) on 2011-02-15
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.