gvfs lockup due to max number of connections

Bug #1792878 reported by Ueli Leutwyler on 2018-09-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
dav backend lockups if two files are opened.

* Test case

connect to a webdav share and opens more than 2 files

* Regression potential

the change is in the webdav backend, check that those shares still work correctly

--------------------

Currently, the default value of max-conns-per-host libsoup property is
used, which causes dav backend lockups if two files are opened.

see: https://gitlab.gnome.org/GNOME/gvfs/commit/7b991137b8a820f018ddaa970d54f91d1f411a0f

I've managed to fix the problem by changig the code of Version 1.36 (current ubuntu version) an compile it.

As long as the version of gvfs is not updated to a version with fixing the problem, the patch described in the link above should be backported into version 1.36.

quit urgent for us 'cause our system is heavely dependend on webdav

Thanks
Ueli

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gvfs 1.36.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Sep 17 10:02:36 2018
SourcePackage: gvfs
UpgradeStatus: No upgrade log present (probably fresh install)

Ueli Leutwyler (ueli-rumlikon) wrote :
Changed in gvfs (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

The issue is fixed in >= cosmic, the change is being SRUed to bionic

description: updated

Hello Ueli, or anyone else affected,

Accepted gvfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gvfs/1.36.1-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gvfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Ueli Leutwyler (ueli-rumlikon) wrote :

Dear community
In the version gvfs 1.36.1-0ubuntu1.2 this bug has been fixed.

Reproduce testing:
1. connect to webdav repository in filebrowser (e.g. nemo) like that: davs://your-url.com/repo

2. select two files in file explore (e.g. odt - writer)

3. right mouse click -> open.

in previous version gvfs would lock. in 1.36.1-0ubuntu1.2 both file will be opened (e.g. writer)

tags: added: verification-done-bionic
removed: verification-needed-bionic
Download full text (3.2 KiB)

Dear Brian

I was wondering when the bugfix will be transfered to updates.
I've marked it as solved. At least I hope so. Please let me know.

Thanks

Ueli
Am Dienstag, November 20, 2018 18:57 CET, Brian Murray <email address hidden> schrieb:
 Hello Ueli, or anyone else affected,

Accepted gvfs into bionic-proposed. The package will build now and be
available at https://launchpad.net/ubuntu/+source/gvfs/1.36.1-0ubuntu1.2
in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed. Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested and change the tag from
verification-needed-bionic to verification-done-bionic. If it does not
fix the bug for you, please add a comment stating that, and change the
tag to verification-failed-bionic. In either case, without details of
your testing we will not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: gvfs (Ubuntu Bionic)
Status: New => Fix Committed

** Tags added: verification-needed verification-needed-bionic

-- You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1792878

Title:
gvfs lockup due to max number of connections

Status in gvfs package in Ubuntu:
Fix Released
Status in gvfs source package in Bionic:
Fix Committed

Bug description:
* Impact
dav backend lockups if two files are opened.

* Test case

connect to a webdav share and opens more than 2 files

* Regression potential

the change is in the webdav backend, check that those shares still
work correctly

--------------------

Currently, the default value of max-conns-per-host libsoup property is
used, which causes dav backend lockups if two files are opened.

see:
https://gitlab.gnome.org/GNOME/gvfs/commit/7b991137b8a820f018ddaa970d54f91d1f411a0f

I've managed to fix the problem by changig the code of Version 1.36
(current ubuntu version) an compile it.

As long as the version of gvfs is not updated to a version with fixing
the problem, the patch described in the link above should be
backported into version 1.36.

quit urgent for us 'cause our system is heavely dependend on webdav

Thanks
Ueli

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gvfs 1.36.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Sep 17 10:02:36 2018
SourcePackage: gvfs
UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers