[ffe] Update to 1.38.0

Bug #1791693 reported by Iain Lane on 2018-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Wishlist
Iain Lane

Bug Description

This release corresponds to GNOME 3.30.

I'm not going to be able to test every single change myself like the TCRYPT thing, but I'll give it a good old smoke test.

Major changes in 1.38.0
========================
* Translation updates

Major changes in 1.37.92
========================
* udisks2: Use loop backing file as description for unlock
* Remove workaround for directory / folder icons
* Translation updates

Major changes in 1.37.91
========================
* Translation updates

Major changes in 1.37.90
========================
* ftp: Add implicit TLS mode
* dav: Increase max number of connections to prevent lockups
* smb: Do not claim that mountable can be unmounted
* build: Add proper linker support check
* Several smaller bugfixes
* Translation updates

Major changes in 1.37.4
=======================
* udisks2: Support TCRYPT devices
* google: Do not create .desktop files for native files
* udisks2: Fix crashes caused by missing source tag
* udisks2: Handle x-gvfs- options not only for fstab entries
* Several smaller bugfixes
* Translation updates

Major changes in 1.37.2
=======================
* smb: Fix removal of non-empty dir
* programs: Remove deprecated gvfs utils
* gdu: Remove libgdu support
* gphoto2: Switch to a stable device uri
* mtp: Switch to a stable device uri
* Several smaller bugfixes
* Translation updates

Major changes in 1.37.1
=======================
* udisks2: Remove optical disc volumes/mounts if drive disappears
* daemon: Prevent deadlock and invalid read when closing channels
* metadata: Prevent usage of NULL if GUdevDevice is not found
* mtp: Implement support for move and copy operations
* backend: Fix crashes when "Volume is busy" prompt is shown
* build: Remove autotools
* build: Various meson-related fixes and improvements
* Several smaller bugfixes
* Translation updates

Iain Lane (laney) wrote :

* programs: Remove deprecated gvfs utils

We're providing these from the Debian packaging for now.

Iain Lane (laney) wrote :

I've been testing. It seems good to me so far. Uploaded to https://launchpad.net/~laney/+archive/ubuntu/ppa/+packages to see if it builds on all arches

Changed in gvfs (Ubuntu):
status: In Progress → New
Iain Lane (laney) wrote :

It does.

summary: - Update to 1.38.0
+ [ffe] Update to 1.38.0
Łukasz Zemczak (sil2100) wrote :

Ok, thanks for the explanation in comment #1, otherwise I'd be worried about that particular entry. I approve of the FFe. Just be sure to test a few of its reverse-dependencies, since I see the list is pretty big (not sure to what extent most of them actually use gvfs though).

Changed in gvfs (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.38.0-2ubuntu2

---------------
gvfs (1.38.0-2ubuntu2) cosmic; urgency=medium

  * Cherry-pick patch submitted upstream to fix the tests. We're running them
    in the sandbox, and this case was broken.

 -- Iain Lane <email address hidden> Tue, 25 Sep 2018 12:50:11 +0100

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers