Loss of lan connection causes applications using gvfsd-sftp to hang until demon is killed

Bug #1630905 reported by Paul Kellner on 2016-10-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact

The gvfsd-sftp service sometime hangs

* Test case
- connect to a ssh server from nautilus
- suspend the computer for longer than the ssh timeout (1 hour for example)
- resume and try to use the connection

* Regression potential
Check that nautilus access to remote servers still work correctly

-----------------------------

This affects an installation of Ubuntu 14.04 on a Lenovo laptop.
When applications like nautilus or Bluefish are connected to a remote fileshare using sftp (ssh) via a lan connection, if the connection is lost and re-established the old process seems to hang blocking attempts to save data or use Nautilus in any way.

This typically occurs when the connection is either lost accidentally or when the laptop is suspended and then unsuspended causing a loss of wireless connection.

The workaround is to kill the gvsftp process manually and then recreate the remote connection using Nautilus.

This bug leads to data loss if, for instance, the laptop is closed (starting suspend mode) while in the middle of a task that must be saved.

ERROR: apport (pid 5064) Thu Oct 6 17:38:29 2016: called for pid 3309, signal 6, core limit 0
ERROR: apport (pid 5064) Thu Oct 6 17:38:29 2016: executable: /usr/lib/gvfs/gvfsd-sftp (command line "/usr/lib/gvfs/gvfsd-sftp --spawner :1.4 /org/gtk/gvfs/exec_spaw/28")
ERROR: apport (pid 5064) Thu Oct 6 17:38:29 2016: debug: session gdbus call: (true,)

ERROR: apport (pid 5064) Thu Oct 6 17:38:30 2016: wrote report /var/crash/_usr_lib_gvfs_gvfsd-sftp.1000.crash

Description: Ubuntu 14.04.5 LTS
Release: 14.04

gvfs:
  Installed: 1.20.3-0ubuntu1.2
  Candidate: 1.20.3-0ubuntu1.2
  Version table:
 *** 1.20.3-0ubuntu1.2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.20.1-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
laulau (olaulau) wrote :

still true with ubuntu 16.10
killing nautilus doesn't work, can't relaunch nautilus until killing gvfsd-sftp.

Sebastien Bacher (seb128) wrote :

There was a similar issue fixed in https://gitlab.gnome.org/GNOME/gvfs/commit/1b591b50c338c974d11a53d31356475dcda8bfcd

That's in cosmic and backported to bionic

Changed in gvfs (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
description: updated

Hello Paul, or anyone else affected,

Accepted gvfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gvfs/1.36.1-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gvfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

1.36.1-0ubuntu1.2 keeps working fine after suspend/resume cycles

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers