after upgrading to 16.04 (xubuntu) network drive not mounted

Bug #1544480 reported by Willem Hobers on 2016-02-11
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
High
Unassigned

Bug Description

after upgrading to 16.04 (xubuntu) network drive not mounted
Asked by Willem Hobers on 2016-02-06

I upgraded from Xubuntu 14.04 to 16.04, because I would like to attribute to the testing.

After the upgrade my network drive does not mount.

fstab
//192.168.178.73/Thuis /media/Thuis cifs noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777 0 0

This worked until the upgrade.

When trying to mount I get:

mount: wrong fs type, bad option, bad superblock on //192.168.178.73/Thuis,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

And if I do dmesg | tail, it gives:

[ 21.141585] cgroup: new mount options do not match the existing superblock, will be ignored
[ 24.103109] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 24.103661] forcedeth 0000:00:07.0 eth1: MSI enabled
[ 31.195496] FS-Cache: Loaded
[ 31.232146] FS-Cache: Netfs 'cifs' registered for caching
[ 31.233761] Key type cifs.spnego registered
[ 31.233773] Key type cifs.idmap registered
[ 31.234020] CIFS VFS: No username specified
[ 327.314333] CIFS VFS: No username specified
[ 349.637971] CIFS VFS: No username specified

Also see question https://answers.launchpad.net/ubuntu/+question/284714

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gvfs 1.27.4-1ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-49.55~14.04.1-generic 3.19.8-ckt12
Uname: Linux 3.19.0-49-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.19.4-0ubuntu2
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Feb 11 11:11:57 2016
InstallationDate: Installed on 2016-01-17 (25 days ago)
InstallationMedia: Xubuntu 14.04.3 LTS "Trusty Tahr" - Beta i386 (20150805)
SourcePackage: gvfs
UpgradeStatus: No upgrade log present (probably fresh install)

Willem Hobers (whobers) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Matthew Hudson (layolayo) wrote :

I am using nfs as cifs broke on the update

# QNAP
192.168.0.99:/video /media/video nfs rw,hard,nfsvers=3,rsize=32768,wsize=32768,timeo=14,intr 0 0

however this is still not mounted on reboot - if I run :

sudo mount -a

once logged in the drive is mounted fine

Changed in gvfs (Ubuntu):
importance: Undecided → High
D (darkduck) wrote :

I have the same problem.
CIFS drive does not mount at boot, but works OK after sudo mount -a.
After checking the dmesg output, found the following:
[ 21.401090] IPv6: ADDRCONF(NETDEV_UP): enp14s0: link is not ready
[ 21.409315] r8169 0000:0e:00.0 enp14s0: link down
[ 21.409391] IPv6: ADDRCONF(NETDEV_UP): enp14s0: link is not ready
[ 21.426414] IPv6: ADDRCONF(NETDEV_UP): wlp20s0: link is not ready
[ 21.576880] IPv6: ADDRCONF(NETDEV_UP): wlp20s0: link is not ready
[ 21.784873] IPv6: ADDRCONF(NETDEV_UP): wlp20s0: link is not ready
[ 27.087515] FS-Cache: Loaded
[ 27.113285] FS-Cache: Netfs 'cifs' registered for caching
[ 27.113434] Key type cifs.spnego registered
[ 27.113445] Key type cifs.idmap registered
[ 27.125723] CIFS VFS: Error connecting to socket. Aborting operation.
[ 27.125812] CIFS VFS: cifs_mount failed w/return code = -101
[ 27.440130] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
[ 37.997256] wlp20s0: authenticate with 8c:10:d4:61:7b:8c
[ 38.016336] wlp20s0: send auth to 8c:10:d4:61:7b:8c (try 1/3)
[ 38.120061] wlp20s0: send auth to 8c:10:d4:61:7b:8c (try 2/3)
[ 38.121720] wlp20s0: authenticated
[ 38.124072] wlp20s0: associate with 8c:10:d4:61:7b:8c (try 1/3)
[ 38.127684] wlp20s0: RX AssocResp from 8c:10:d4:61:7b:8c (capab=0x411 status=0 aid=2)
[ 38.129296] wlp20s0: associated

If I understand that correctly, CIFS tries to mount the partition while the network is still down.

Would be happy if that helps.

Silvio Wangler (silvio-wangler) wrote :

A workaround is describe in this thread. http://ubuntuforums.org/showthread.php?t=2131380

Put a script e.g. fstab to /etc/network/if-up.d containing the following content

#!/bin/sh
mount -a

D (darkduck) wrote :

Silvio, it does not work for me.

The following worked for me:

Add to each affected /etc/fsab line:

comment=systemd.automount

So, for example:
//192.168.1.100/shared /media/shared cifs comment=systemd.automount,credentials=

Source:
http://lifeisabug.com/fix-debian-wheezy-mounting-cifs-smb-shares-boot-time/

Related bug:
https://bugs.launchpad.net/ubuntu/+source/cifs-utils/+bug/1544546

D (darkduck) wrote :

Serge, it works for mounting. You are right.
However, when switching off / rebooting the computer, it hangs for ~2 minutes. I think this is because OS first switches off the network interface and then tries to unmount the remote drive. This unmounting obviously times out because there is no network any more. But this timeout is 2 minutes of wasted time.
This is not a solution me thinks.

Paul_S (pslat-8) wrote :

Hi, just came across this when setting up a new Ubuntu 16.04 system. I was taking the settings from a 14.04 system and my fstab line is (more or less);
//x.x.x.x/sharex /mnt/sharex cifs credentials=/home/user/.smbcredentials,iocharset=utf8,_netdev, 0 0
I was getting the same error when trying sudo mount -a until I read through man mount and saw this at about line 1024:
----------
Mount options for cifs
See the options section of the mount.cifs(8) man page (cifs-utils package must be installed).
----------
-So I installed cifs-utils with
sudo apt-get install cifs-utils
and sudo mount-a mounted the network device without any complaints. I hope this helps:)

MDMAHBOOB (mdmahboob) on 2017-01-28
Changed in gvfs (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers