File restore from wastebin not working

Bug #1497175 reported by Kev Bowring on 2015-09-18
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
caja (Ubuntu)
Undecided
Unassigned
gvfs (Ubuntu)
Critical
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned
pcmanfm (Ubuntu)
Undecided
Unassigned
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Create a file on desktop

Delete file to wastebasket.

Open wastebasket - right click on deleted file - select restore

expected behaviour - file restored to desktop

actual behaviour - dialogue opens (screenshot attached)

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: thunar 1.6.10-1
ProcVersionSignature: Ubuntu 4.2.0-10.11-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Sep 18 09:57:23 2015
InstallationDate: Installed on 2015-09-17 (0 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150917)
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.18-0ubuntu9
Architecture: amd64
CurrentDesktop: XFCE
DistroRelease: Ubuntu 15.10
InstallationDate: Installed on 2015-08-12 (36 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150812)
Package: gvfs 1.24.1-1ubuntu4
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Tags: wily
Uname: Linux 4.1.0-3-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) wrote :

Thought this was just Thunar, checked in Ubuntu Wily with nautilus - same issue there.

Installed restore-trash - and that worked.

affects: thunar (Ubuntu) → gvfs (Ubuntu)
Kev Bowring (flocculant) wrote :

Used restore-trash after installing trash-cli ...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1497175

tags: added: iso-testing

apport information

tags: added: apport-collected
description: updated

apport information

apport information

Kev Bowring (flocculant) wrote :

ran apport-collect as originally I'd ubuntu-bug'd thunar

Changed in gvfs (Ubuntu):
importance: Undecided → Critical
sudodus (nio-wiklund) wrote :

This bug affects Lubuntu i386 too. But it is possible to drag and drop a file for example to the desktop.

Ulrich von Augsburg (stulrich) wrote :

Same error here with Xubuntu 15.10 (like original poster).

When you, flocculant, say:
> Used restore-trash after installing trash-cli ...

Do you mean by installing trash-cli and doing a "restore-trash" command once, this Thunar bug is gone? Or, more probably, just for the file which didn't get restored by Thunar?

Kev Bowring (flocculant) wrote :

No - it doesn't fix the bug - just deals with restoring if the normal way fails.

We fixed this in Caja (the MATE filemanager). This might be useful:

  * https://github.com/mate-desktop/caja/pull/459

Sean Davis (bluesabre) wrote :

Tested with both Thunar and Nautilus. Cannot restore from trash in either.

Created the file.
Deleted the file in each file manager.
Tried to restore the file in each file manager.

Nautilus displays:
Could not determine original location of “delete.me”
The item cannot be restored from trash

Thunar displays:
Could not restore "delete.me".
Failed to determine the original path for "delete.me".

Kev Bowring (flocculant) wrote :

Installed thunar, pcmanfm and caja in ubuntu wily daily

All give the same error.

Installed nautilus, pcmanfm and caja in xubuntu wily

All give the same error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers