WebDAV moves files using PUT and DELETE instead of MOVE

Bug #1297773 reported by Matt Ward on 2014-03-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Wishlist
gvfs (Ubuntu)
Low
Unassigned

Bug Description

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04
(I'm told this also happens on 12.04)

WebDAV moves files using PUT and DELETE instead of MOVE

How to reproduce the issue:

Pre-requisites:
  - WebDAV server.
  - Packet sniffer (e.g. Wireshark) or set appropriate log levels in the WebDAV server to observe HTTP requests being made.

Mount a webdav server:
1. open a nautilus window
2. use menu "files > connect to server"
3. enter the server address (e.g. dav://localhost:8080/alfresco/webdav) and connect

Create two folders: "test-move1" and "test-move2".

Create a text file in test-move1 named move.txt with some short text in it.

Select the file in nautilus and type Ctrl-X.

Navigate to "test-move2".

Move the file by typing Ctrl-V.

Observed behaviour:
A multi-request move operation is executed.

GET on test-move1/move.txt
HEAD on test-move2/move.txt
PUT on test-move2/move.txt
...
DELETE on test-move1/move.txt

Expected behaviour:
The move is performed using the WebDAV MOVE command.

By using GET, PUT, DELETE instead of a single MOVE:
- The client must wait for the entire file to be downloaded before it can be uploaded to the new location. By using MOVE the entire operation may be highly optimized and performed only on the server.
- Any associated metadata (including versioning) for the file is lost - since we are in fact creating a new file and deleting the old one.
- There is a lack of atomicity and potentially, data integrity. What would happen if an update is made to test-move1/move.txt just before the DELETE happens?

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.3-0ubuntu16
ProcVersionSignature: Ubuntu 3.8.0-35.50-generic 3.8.13.13
Uname: Linux 3.8.0-35-generic i686
ApportVersion: 2.9.2-0ubuntu8.5
Architecture: i386
Date: Wed Mar 26 10:14:41 2014
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'800x550+148+73'"
InstallationDate: Installed on 2013-07-19 (249 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
MarkForUpload: True
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Matt Ward (matt-ward-u) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Undecided → Low
Matt Ward (matt-ward-u) wrote :

I have created an upstream bug report:

https://bugzilla.gnome.org/show_bug.cgi?id=727096

Sebastien Bacher (seb128) wrote :

Thanks

Changed in gvfs (Ubuntu):
status: New → Triaged
Changed in gvfs:
importance: Unknown → Wishlist
status: Unknown → New
Changed in gvfs:
status: New → In Progress
Changed in gvfs:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.