Unable to mount audio disc - Message did not receive a reply (timeout by message bus)

Bug #1268838 reported by thedanyes on 2014-01-14
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Medium
Unassigned
libcdio (Debian)
Fix Released
Unknown
libcdio (Ubuntu)
Undecided
Unassigned

Bug Description

I have an Asus external slim USB optical drive and when I insert an Audio CD, Unity pops up a message with the text in the summary: "Unable to mount audio disc - Message did not receive a reply (timeout by message bus)". I'm able to open VLC and successfully play the audio disc, so I don't think it's a hardware issue. I've tried checking the box marked "Never prompt or start programs on media insertion" in the System Settings in the Details -> Removable media section with no change in behavior.

Here is some hopefully relevant info:
$dmesg
[237213.087542] usb 2-1.4: new high-speed USB device number 4 using ehci-pci
[237213.180052] usb 2-1.4: New USB device found, idVendor=1c6b, idProduct=a223
[237213.180059] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[237213.180064] usb 2-1.4: Product: Mass Storage Device
[237213.180068] usb 2-1.4: Manufacturer: USB2.0 External
[237213.180071] usb 2-1.4: SerialNumber: 317509428611220
[237213.183251] scsi11 : usb-storage 2-1.4:1.0
[237214.191690] scsi 11:0:0:0: CD-ROM ASUS SDRW-08D2S-U B701 PQ: 0 ANSI: 0
[237214.217823] sr0: scsi3-mmc drive: 188x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[237214.217831] cdrom: Uniform CD-ROM driver Revision: 3.20
[237214.218127] sr 11:0:0:0: Attached scsi CD-ROM sr0
[237214.218291] sr 11:0:0:0: Attached scsi generic sg4 type 5
[237259.241566] pool[22376]: segfault at 7f3381ee7a02 ip 00007f338112b040 sp 00007f337e895f00 error 4 in libc-2.17.so[7f33810de000+1bf000]
[237290.913773] pool[22391]: segfault at 7f92d260aa02 ip 00007f92d184e040 sp 00007f92cefb8f00 error 4 in libc-2.17.so[7f92d1801000+1bf000]
[237295.156452] pool[22397]: segfault at 7f9e11abda02 ip 00007f9e10d01040 sp 00007f9e0e46bf00 error 4 in libc-2.17.so[7f9e10cb4000+1bf000]
[237297.896343] pool[22401]: segfault at 7f1d7206ba02 ip 00007f1d712af040 sp 00007f1d6ea19f00 error 4 in libc-2.17.so[7f1d71262000+1bf000]
[237375.705697] pool[22418]: segfault at 7f5ea9e29a02 ip 00007f5ea906d040 sp 00007f5ea67d7f00 error 4 in libc-2.17.so[7f5ea9020000+1bf000]
[237410.121426] systemd-hostnamed[22463]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[237539.458769] pool[22585]: segfault at 7f3745bf8a02 ip 00007f3744e3c040 sp 00007f37425a6f00 error 4 in libc-2.17.so[7f3744def000+1bf000]
[238169.384091] pool[22744]: segfault at 7fe9ba823a02 ip 00007fe9b9a67040 sp 00007fe9b71d1f00 error 4 in libc-2.17.so[7fe9b9a1a000+1bf000]

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

$ uname -a
Linux 3.8.0-34-lowlatency #26-Ubuntu SMP PREEMPT Wed Nov 20 23:57:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

thedanyes (thedanyes) wrote :
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1268838/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
John Kim (kotux) on 2014-03-03
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1268838

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc5-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
bitinerant (bitinerant) wrote :

Same issue here--but only with one particular audio CD. DVDs and other audio CDs work fine. I have Ubuntu 12.04 kernel 3.5.0-47-generic. The same CD causes the same problem on another laptop with a different CD drive (same Ubuntu kernel). Syslog has this line for each time I insert the CD:

Mar 29 16:13:37 system kernel: [151273.462458] pool[16054]: segfault at 7fe6b2d5570e ip 00007fe6b21ea3b1 sp 00007fe6b0921eb0 error 4 in libc-2.15.so[7fe6b219f000+1b5000]

I cannot test another kernel at this time.

bitinerant (bitinerant) wrote :

Update: the troublesome audio CD was not accepted by an old MacBook (OS X 10.6.8) but WORKED FINE in another MacBook (also 10.6.8). I also found a second audio CD with the same issue, which also worked in the second MacBook. Could the CDs have bad checksums which the drive firmware or kernel on the second MacBook somehow ignore?

thedanyes (thedanyes) wrote :

I just tried again on 14.04.

dmesg:
[ 1795.792457] usb 3-8: new high-speed USB device number 12 using xhci_hcd
[ 1795.809368] usb 3-8: New USB device found, idVendor=1c6b, idProduct=a223
[ 1795.809398] usb 3-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1795.809400] usb 3-8: Product: Mass Storage Device
[ 1795.809401] usb 3-8: Manufacturer: USB2.0 External
[ 1795.809402] usb 3-8: SerialNumber: 317509428611220
[ 1795.812245] usb-storage 3-8:1.0: USB Mass Storage device detected
[ 1795.812285] scsi9 : usb-storage 3-8:1.0
[ 1796.822144] scsi 9:0:0:0: CD-ROM ASUS SDRW-08D2S-U B701 PQ: 0 ANSI: 0
[ 1796.845743] sr0: scsi3-mmc drive: 188x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ 1796.845746] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 1796.845848] sr 9:0:0:0: Attached scsi CD-ROM sr0
[ 1796.845903] sr 9:0:0:0: Attached scsi generic sg4 type 5
[ 1850.460646] pool[10913]: segfault at 7ff3ebb8ef22 ip 00007ff3eadc5cb3 sp 00007ff3e7bb9f40 error 4 in libc-2.19.so[7ff3ead7a000+1bc000]

uname -a:
Linux Win7 3.13.0-24-lowlatency #46-Ubuntu SMP PREEMPT Thu Apr 10 19:40:23 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

thedanyes (thedanyes) wrote :

It gave the same error window as indicated in the bug title. Sorry I didn't specifically mention that.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Thomas Schwinge (tschwinge) wrote :

This is a crash in "/usr/lib/gvfs/gvfsd-cdda". I'm having a look.

affects: linux (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Thomas Schwinge (tschwinge)
status: Expired → New
Thomas Schwinge (tschwinge) wrote :
Download full text (3.7 KiB)

(At least in my case) it's a SIGSEGV in libcdio (libcdio13:amd64 0.83-4.2ubuntu1), reproducable with the "cd-info" tool:

    $ LD_LIBRARY_PATH=./lib/driver/.libs:./lib/iso9660/.libs gdb -q --args src/.libs/cd-info /dev/sr1
    Reading symbols from src/.libs/cd-info...done.
    (gdb) r
    [...]
    CD Analysis Report

    Program received signal SIGSEGV, Segmentation fault.
    __strcpy_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strcpy-sse2-unaligned.S:296
    296 ../sysdeps/x86_64/multiarch/strcpy-sse2-unaligned.S: Datei oder Verzeichnis nicht gefunden.
    (gdb) bt
    #0 __strcpy_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strcpy-sse2-unaligned.S:296
    #1 0x00007ffff79b2b02 in cdtext_data_init (p_user_data=p_user_data@entry=0x55555575e480, i_first_track=<optimized out>,
        wdata=wdata@entry=0x7fffffffbe60 "\001j", i_data=72, i_data@entry=360,
        set_cdtext_field_fn=set_cdtext_field_fn@entry=0x7ffff79b06c0 <set_cdtext_field_generic>) at cdtext.c:298
    #2 0x00007ffff79bd53b in mmc_init_cdtext_private (p_user_data=p_user_data@entry=0x55555575e480, run_mmc_cmd=0x7ffff79b4360 <run_mmc_cmd_linux>,
        set_cdtext_field_fn=set_cdtext_field_fn@entry=0x7ffff79b06c0 <set_cdtext_field_generic>) at mmc/mmc.c:384
    #3 0x00007ffff79b146a in init_cdtext_generic (p_env=p_env@entry=0x55555575e480) at _cdio_generic.c:452
    #4 0x00007ffff79b14d6 in get_cdtext_generic (p_user_data=0x55555575e480, i_track=<optimized out>) at _cdio_generic.c:278
    #5 0x0000555555557996 in print_cdtext_track_info (p_cdio=<optimized out>, i_track=<optimized out>, psz_msg=0x5555555599c3 "\nCD-TEXT for Disc:")
        at cd-info.c:413
    #6 0x0000555555558443 in print_cdtext_info (i_first_track=1 '\001', i_tracks=<optimized out>, p_cdio=0x555555762860) at cd-info.c:433
    #7 print_analysis (ms_offset=0, cdio_iso_analysis=..., fs=1, first_data=-1, num_audio=8, i_tracks=<optimized out>, i_first_track=1 '\001',
        p_cdio=0x555555762860, track_format=<optimized out>) at cd-info.c:641
    #8 0x0000555555557317 in main (argc=<optimized out>, argv=<optimized out>) at cd-info.c:1222
    (gdb) frame 1
    #1 0x00007ffff79b2b02 in cdtext_data_init (p_user_data=p_user_data@entry=0x55555575e480, i_first_track=<optimized out>,
        wdata=wdata@entry=0x7fffffffbe60 "\001j", i_data=72, i_data@entry=360,
        set_cdtext_field_fn=set_cdtext_field_fn@entry=0x7ffff79b06c0 <set_cdtext_field_generic>) at cdtext.c:298
    298 sprintf(buffer,"%s",cdtext_genre[(p_data->text[0] << 8) + p_data->text[1]]);
    (gdb) list
    293 /* not a character pack */
    294 if (p_data->type == CDIO_CDTEXT_GENRE) {
    295 i_track = p_data->i_track;
    296 /* seems like it is a uint_16 in the first 2 bytes */
    297 if((p_data->text[0] << 8) + p_data->text[1] != CDIO_CDTEXT_GENRE_UNUSED) {
    298 sprintf(buffer,"%s",cdtext_genre[(p_data->text[0] << 8) + p_data->text[1]]);
    299 SET_CDTEXT_FIELD(CDTEXT_GENRE);
    300 }
    301 #ifdef _DEBUG_CDTEXT
    302 printf("GENRE information present: %02x %02x %02x %02x %02x %02x %02x %02x %0...

Read more...

Changed in gvfs (Ubuntu):
assignee: Thomas Schwinge (tschwinge) → nobody
Thomas Schwinge (tschwinge) wrote :

Apparently I had analyzed this (or, at least a very similar issue) already a few years ago: <https://bugs.debian.org/695865>...

This doesn't happen anymore/has been fixed in a later version, such as the one packaged in Debian libcdio15:amd64 0.92-2.

Rebuilding the gvfs packages against that one (no source code changes required), and installing these, the SIGSEGV then doesn't happen anymore, and the audio CD can be mounted/played fine.

As there as been quite some churn in the CD-Text source code in libcdio, I couldn't easily identify the actual change that fixed this issue.

Should libcdio15 be added to Ubuntu, and gvfs build-depend on that one?

Changed in libcdio (Debian):
status: Unknown → New
Changed in libcdio (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.