gvfs-afc-volume-monitor crashed with SIGSEGV in g_type_check_instance_is_a()

Bug #1214204 reported by Tim Lunn on 2013-08-20
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Medium
Martin Pitt

Bug Description

This happened after logging in while iphone was connected.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gvfs-backends 1.17.2-0ubuntu6
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
Date: Tue Aug 20 12:21:55 2013
ExecutablePath: /usr/lib/gvfs/gvfs-afc-volume-monitor
InstallationDate: Installed on 2012-09-23 (331 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
MarkForUpload: True
ProcCmdline: /usr/lib/gvfs/gvfs-afc-volume-monitor
SegvAnalysis:
 Segfault happened at: 0x7f73c16f9cdc <g_type_check_instance_is_a+60>: testb $0x4,0x16(%r8)
 PC (0x7f73c16f9cdc) ok
 source "$0x4" ok
 destination "0x16(%r8)" (0x73c16fbb40000016) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 g_type_check_instance_is_a (type_instance=type_instance@entry=0x7f73b8002000, iface_type=iface_type@entry=80) at /build/buildd/glib2.0-2.37.5/./gobject/gtype.c:3975
 g_object_ref (_object=0x7f73b8002000) at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:3054
 g_list_foreach (list=<optimised out>, list@entry=0x1302b80, func=0x404bd0 <g_object_ref@plt>, user_data=user_data@entry=0x0) at /build/buildd/glib2.0-2.37.5/./glib/glist.c:949
 g_vfs_afc_volume_monitor_get_volumes (_self=<optimised out>) at afcvolumemonitor.c:153
 handle_list (object=0x130b270, invocation=0x7f73b000a4f0, user_data=<optimised out>) at gvfsproxyvolumemonitordaemon.c:936
Title: gvfs-afc-volume-monitor crashed with SIGSEGV in g_type_check_instance_is_a()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Tim Lunn (darkxst) wrote :

StacktraceTop:
 g_type_check_instance_is_a (type_instance=type_instance@entry=0x7f73b8002000, iface_type=iface_type@entry=80) at /build/buildd/glib2.0-2.37.5/./gobject/gtype.c:3975
 g_object_ref (_object=0x7f73b8002000) at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:3054
 g_list_foreach (list=<optimized out>, list@entry=0x1302b80, func=0x404bd0 <g_object_ref@plt>, user_data=user_data@entry=0x0) at /build/buildd/glib2.0-2.37.5/./glib/glist.c:949
 g_vfs_afc_volume_monitor_get_volumes (_self=<optimized out>) at afcvolumemonitor.c:153
 handle_list (object=0x130b270, invocation=0x7f73b000a4f0, user_data=<optimized out>) at gvfsproxyvolumemonitordaemon.c:936

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2013-09-02
information type: Private → Public
Martin Pitt (pitti) on 2013-09-02
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

I uploaded gvfs 1.17.90 to saucy which will fix this, but it won't go in until after the beta freeze.

Changed in gvfs (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.17.90-0ubuntu1

---------------
gvfs (1.17.90-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Works with current libimobiledevice API. (LP: #1214204)
  * debian/control.in: Bump libimobiledevice build dep.
  * Drop 00git_tests.patch, upstream now.
 -- Martin Pitt <email address hidden> Mon, 02 Sep 2013 14:45:58 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers