Ubuntu

gvfsd-mtp crashed with SIGSEGV in backend_died()

Reported by Thomas Hotz on 2013-02-19
404
This bug affects 71 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
High
gvfs (Ubuntu)
Medium
Philip Langdale

Bug Description

I have a Samsung Wave M and had a LG Optimus L7 (P700). On my Thinkpad Edge E530 I get this crash when I unmount the device.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: gvfs-backends 1.15.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-6.13-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Tue Feb 19 13:43:47 2013
ExecutablePath: /usr/lib/gvfs/gvfsd-mtp
InstallationDate: Installed on 2013-02-19 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130219)
MarkForUpload: True
ProcCmdline: /usr/lib/gvfs/gvfsd-mtp --spawner :1.16 /org/gtk/gvfs/exec_spaw/3
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANGUAGE=de_AT:de
 LANG=de_AT.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f2d2649a0bc: mov 0x20(%rax),%rax
 PC (0x7f2d2649a0bc) ok
 source "0x20(%rax)" (0xaaaaaaaaaaaaaaca) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_value_unset () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gvfsd-mtp crashed with SIGSEGV in g_object_unref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Thomas Hotz (thotz) wrote :
Thomas Hotz (thotz) on 2013-02-25
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
poetzmij (poetzmij) wrote :

I'm guessing were all seeing this on different devices right?
It affects my galaxy nexus as well.

Vincent Ladeuil (vila) wrote :

Same here with a nexus 7

Lucas Benninger (lucas8060) wrote :

I get this error when trying to read from files I already wrote to my nexus 4.

Philip Langdale (langdalepl) wrote :

When you all say you're seeing this error, you have confirmed you're getting the same stack trace? I'm still waiting for the retracer to fill in the blanks but I've never seen this personally.

crtm (carlosrtm) wrote :

crash when I unmount the device. (Samsung Galaxy SII)

Thomas Hotz (thotz) wrote :

... waiting for the retracer? ... how much time will it take?

Bartek Feltman (bfeltman) wrote :

also crash when unmounting Xiaomi M2. MTP device.

StacktraceTop:
 backend_died (monitor=0x7f2d140019e0, old_backend=<optimized out>) at gvfsmonitor.c:77
 g_cclosure_marshal_VOID__PARAMv (closure=0x7f2d14026d80, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x1edc280) at /build/buildd/glib2.0-2.35.8/./gobject/gmarshal.c:1070
 handler_list_lookup (instance=<optimized out>, signal_id=<optimized out>) at /build/buildd/glib2.0-2.35.8/./gobject/gsignal.c:422
 g_signal_emitv (instance_and_params=0x1edf9c0, signal_id=<optimized out>, detail=0, return_value=0x7f2d25fb9276 <parse_value_from_blob+2150>) at /build/buildd/glib2.0-2.35.8/./gobject/gsignal.c:3044
 ?? ()

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
summary: - gvfsd-mtp crashed with SIGSEGV in g_object_unref()
+ gvfsd-mtp crashed with SIGSEGV in backend_died()
tags: removed: need-amd64-retrace
Changed in gvfs (Ubuntu):
assignee: nobody → Philip Langdale (langdalepl)
tags: added: rls-r-incoming
Changed in gvfs:
importance: Unknown → High
status: Unknown → In Progress
Changed in gvfs:
status: In Progress → Fix Released
Philip Langdale (langdalepl) wrote :

Fixed in 1.16.1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.16.0-1ubuntu4

---------------
gvfs (1.16.0-1ubuntu4) raring; urgency=low

  * debian/patches/git_shutdown_segfault.patch:
    - backport fix for a common mtp backend segfault (lp: #1130101)
  * debian/patches/git_obex_dbus_segfault.patch:
    - backport another fix for a obexftp segfault (lp: #1057546)
  * debian/patches/gvfsd_http_handle_socketpair_error.patch:
    - replace with the upstream version
 -- Sebastien Bacher <email address hidden> Wed, 03 Apr 2013 21:40:19 +0200

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.