gvfsd-archive crashed with SIGSEGV in mount_failed()

Bug #1099550 reported by Daniel Winzen on 2013-01-14
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Medium
Unassigned

Bug Description

I tried to open an archive: http://processing.googlecode.com/files/processing-2.0b7-linux64.tgz
After re-downloading it, it worked, because the file wasn't completely downloaded (around 20 MB were missing).

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: gvfs-backends 1.14.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Mon Jan 14 20:42:33 2013
ExecutablePath: /usr/lib/gvfs/gvfsd-archive
InstallationDate: Installed on 2012-04-03 (285 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120403)
MarkForUpload: True
ProcCmdline: /usr/lib/gvfs/gvfsd-archive file=/home/username/Dokumente/processing-2.0b7-linux64.tgz
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f3f7405ab88: mov 0x8(%rsi),%rcx
 PC (0x7f3f7405ab88) ok
 source "0x8(%rsi)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
Title: gvfsd-archive crashed with SIGSEGV in g_signal_emit_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

information type: Private → Public

StacktraceTop:
 mount_failed (op_job=0x1a511d0, error=0x0) at gvfsjobmount.c:150
 _g_closure_invoke_va (closure=0x1a48520, return_value=0x0, instance=0x1a511d0, args=0x7f3f6f43bc68, n_params=0, param_types=0x0) at /build/buildd/glib2.0-2.34.3/./gobject/gclosure.c:840
 g_signal_emit_valist (instance=0x1a511d0, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7f3f6f43bc68) at /build/buildd/glib2.0-2.34.3/./gobject/gsignal.c:3211
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=detail@entry=0) at /build/buildd/glib2.0-2.34.3/./gobject/gsignal.c:3356
 g_vfs_job_send_reply (job=<optimized out>) at gvfsjob.c:236

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
summary: - gvfsd-archive crashed with SIGSEGV in g_signal_emit_valist()
+ gvfsd-archive crashed with SIGSEGV in mount_failed()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers