guvcview detects wrong camera output by default on my hp webcam

Bug #1382224 reported by Brendan Perrine on 2014-10-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
guvcview (Ubuntu)
Medium
Unassigned

Bug Description

To reproduce on an hp pavillion dv1230 us in the utopic daily from 10-16 boot into a live session from usb and open guvcview Then the picture from the webcam will show a black screen. I switched to the video tab and it still showed the black screen.

guvcview:
  Installed: 1.7.3-1.1build2
  Candidate: 1.7.3-1.1build2
  Version table:
 *** 1.7.3-1.1build2 0
        500 http://archive.ubuntu.com/ubuntu/ utopic/universe i386 Packages
        100 /var/lib/dpkg/status

Description: Ubuntu 14.10
Release: 14.10

I was expecting the guvcview to work and show a working image. Instead I had to change the video and now it works and takes picture and video fine just it selects the wrong camera output by default.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: guvcview 1.7.3-1.1build2
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.14.7-0ubuntu7
Architecture: i386
CasperVersion: 1.345
CurrentDesktop: LXDE
Date: Thu Oct 16 20:30:47 2014
LiveMediaBuild: Lubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20141016)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: guvcview
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1382224

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in guvcview (Ubuntu):
status: New → Confirmed
Brendan Perrine (walterorlin) wrote :

I am unable to reproduce this in vivid with guvcview:
  Installed: 2.0.1+debian-1
  Candidate: 2.0.1+debian-1
  Version table:
 *** 2.0.1+debian-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

Changed in guvcview (Ubuntu):
importance: Undecided → Medium
sudodus (nio-wiklund) wrote :

I can confirm this bug

Brendan Perrine (walterorlin) wrote :

If I install kernel 3.13 and boot using that kernel in trusty using the guvcview in the repos it works through installing linux image generic . On kenrel 3.19 it does not out of the box. If I add the ppa https://launchpad.net/~pj-assis/+archive/ubuntu/ppa?field.series_filter=trusty Then I get it to work in trusty with 3.19. It appears kernel 3.16 + need guvcview 2.0 or greater to interoperate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers