CUPS suggests the wrong driver for the Epson CX5900 printer

Bug #72508 reported by Robin Sheat on 2006-11-20
2
Affects Status Importance Assigned to Milestone
gutenprint (Ubuntu)
Low
Unassigned

Bug Description

When attempting to install the Epson CX5900 printer, CUPS doesn't know about it, and suggests using the CX5100 driver. This driver doesn't work, and just causes blank pages to be spat out. Instead, the CX5800 driver should be used as this seems to work correctly.

More details here: http://www.kallisti.net.nz/blog/2006/11/ubuntu-and-the-epson-stylus-cx5900/

Till Kamppeter (till-kamppeter) wrote :

The problem is that this printer is not (yet) in the printer database.

The printer seems to work with the Gutenprint version which comes with Edgy, as the PPD for the Epson Stylus CX5800 (you do not need to generate this PPD, it comes already with Ubuntu Edgy) makes it working.

The problem is that Gutenprint does not ship a PPD directly for the CX5900. The upstream Gutenprint needs to be updated for this new model.

Changed in gutenprint:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Till Kamppeter (till-kamppeter) wrote :

An additional remark: The package foomatic-filters-ppds is obsolete for Edgy, as CUPS 1.2 auto-generates PPDs from the Foomatic XML data, so the pre-built PPDs are not needed any more. You can uninstall this package again.

Till Kamppeter (till-kamppeter) wrote :

I have packaged Gutenprint 5.0.1 for Gutsy, it adds support for many new printers. Please test.

Changed in gutenprint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers