Ubuntu

Epson Stylus CX4900 poor color

Reported by Stanislav German-Evtushenko on 2008-11-04
4
Affects Status Importance Assigned to Milestone
gutenprint (Ubuntu)
Medium
Unassigned

Bug Description

Epson CX4900 print in Ubuntu Intrepid with very poor color. In Hardy all colors is normal. See scanned images in attachment.

Anthony Noto (angusthefuzz) wrote :

Thank you for filing this bug report to help make ubuntu better. Is it possible that the ink cartridge is low or some settings have been changed in System->Administration->Printing?

I made a test on two LiveCD (Hardy and Intrepid) with default settings at the same time.

Anthony Noto (angusthefuzz) wrote :

Based on your screenshots and your test with the livecd's it appears that this may be an issue with the default driver settings in Intrepid. Please check these settings, located under System->Administration->Printing to ensure that the settings are the same between Hardy and Intrepid. Thanks for your patience.

The settings is the same, besides text had been printed by browser, openoffice (or smth. else) was fuzzy (vague?).

I mean it isn't sharp.

Anthony Noto (angusthefuzz) wrote :

To move this bug forward, please attach the output of the cups printing bug info script found here: https://wiki.ubuntu.com/PrintingBugInfoScript

The results of script working in attachment.

Till Kamppeter (till-kamppeter) wrote :

Can you try the following?

First, download this file:

http://www.openprinting.org/download/printing/ghostscript-cups-patches/pdftoraster.c

This is an alternative Ghostscript-based pdftoraster filter.

Install the packages needed to compile it:

sudo apt-get install libcups2-dev libcupsimage2-dev

Compile it:

gcc -lcups -lcupsimage -o pdftoraster pdftoraster.c

Install it:

sudo mv /usr/lib/cups/filter/pdftoraster /usr/lib/cups/filter/pdftoraster.orig
sudo cp pdftoraster /usr/lib/cups/filter/
sudo chmod 755 /usr/lib/cups/filter/pdftoraster

Now try to print again. Does it work correctly now?

$ ls -l /usr/lib/cups/filter/pdftoraster*
-rwxr-xr-x 1 root root 23111 2008-11-13 23:52 /usr/lib/cups/filter/pdftoraster
-rwxr-xr-x 1 root root 22184 2008-11-06 20:22 /usr/lib/cups/filter/pdftoraster.orig

Compile -> install -> reboot -> print. Same result. Poor colors and not sharp fonts.

Anthony Noto (angusthefuzz) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in cups:
status: Incomplete → Confirmed

There are known problems with some Epsons in Gutenprint 5.2.1 which should get fixed in 5.2.2 to be released upstream this weekend. Perhaps this will fix your problem.

I installed gutenprint 5.2.2 from source (from cvs). Printing is a bit better now but not as in Gutsy and Hardy.

I tried to remove all gutenprint related packages (5.2.0-rc1) and installed it from hardy (5.0.2). It's work! Now printer work perfectly!

I have informed the upstream developers of Gutenprint. Perhaps it is fixed in 5.2.2 which got released today.

Changed in gutenprint:
importance: Undecided → Medium

According to upstream the bug is fixed in 5.2.2, but you will have to select the CX4800 as your printer model.

Stanislav German-Evtushenko,
Thank you for reporting this bug to Ubuntu. Intrepid reached EOL on April 30, 2010.
Please see this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases.
Is this still a problem with Ubuntu 10.04 LTS or higher?

Changed in gutenprint (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for gutenprint (Ubuntu) because there has been no activity for 60 days.]

Changed in gutenprint (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers