foomatic-db-gutenprint NEEDs ijsgutenprint

Bug #149899 reported by Till Kamppeter on 2007-10-06
4
Affects Status Importance Assigned to Milestone
gutenprint (Ubuntu)
Critical
Unassigned
kubuntu-meta (Ubuntu)
Critical
Jonathan Riddell

Bug Description

To fix bug 99372 Jonathan Riddell has decided on using foomatic-db-gutenprint to provide the Gutenprint PPDs as the KDE Printing Manager cannot cope with the on-the-fly PPD generator of cupsys-driver-gutenprint. To save space in Kubuntu he has released the "Depends" on ijsgutenprint.

foomatic-db-gutenprint contains Foomatic XML data to generate PPD files for the IJS driver of Gutenprint, ijsgutenprint. These PPDs are not able to use the cupsys-driver-gutenprint driver. Not having ijsgutenprint installed makes the PPDs generated from the data in foomatic-db-gutenprint non-functional. So the "Depends" on ijsgutenprint cannot be removed to save space on Kubuntu. The correct solution is to take cupsys-driver-gutenprint out of the Kubuntu seed and add ijsgutenprint instead.

Changed in gutenprint:
importance: Undecided → Critical
status: New → Confirmed
Changed in kubuntu-meta:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → jr
Changed in gutenprint:
status: Confirmed → Fix Committed
Till Kamppeter (till-kamppeter) wrote :

gutenprint (5.0.1-0ubuntu8) gutsy; urgency=low

  * debian/control, debian/control.in: Re-introduced foomatic-db-gutenprint's
    dependency on ijsgutenprint, foomatic-db-gutenprint NEEDs ijsgutenprint
    (LP: #149899).
    Added also dependencies on foomatic-db-engine (needed to generate the PPDs)
    and foomatic-filter (needed to print with the PPDs).
    Also updated Ghostscript dependency in ijsgutenprint to the current
    situation.
  * debian/rules: Do not include obsolete link /usr/share/cups/model/gutenprint
    which is deleted by the post-install script anyway (LP: #149729).

 -- Till Kamppeter <email address hidden> Sat, 6 Oct 2007 17:47:33 +0100

Changed in gutenprint:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2007-10-10
Changed in kubuntu-meta:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers