Upgrade gummi package to version 0.8.1

Bug #1872667 reported by Alexander on 2020-04-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gummi (Debian)
Fix Released
Unknown
gummi (Ubuntu)
Low
Unassigned
Focal
High
Unassigned

Bug Description

[Impact]

The package in focal is based on an unofficial, not to be used in production version of the package. Because of that it suffers from a critical bug and multiple other issues. Backporting a single fix is not feasible, as the synced version is in overall not in production-ready state. The best option to proceed is to backport the whole version before people actually lose their data by using the deprecated software.

The bug in mention is a racing/thread safety problem, as reported here:
https://github.com/alexandervdm/gummi/issues/126

[Test Case]

The original critical bug is hard to reproduce. Users can randomly encounter the segfault after some time of regular usage.

As part of validation, since this is a new upstream release, regular usage of the -proposed package is required for longer periods of time (let's say, up to 45 minutes). This means checking for the basic functionality:
 * Opening and saving LaTeX documents
 * Inserting graphics
 * Live preview check

The upstream maintainer will help performing the required validation.

[Regression Potential]

As this is a new upstream release, there is always chance of regression. That being said, the current version has been deemed more risky and dangerous than 0.8.1 as it is not an 'officially tagged' release. As such, it was not meant to be used in production, so the situation can't actually get much worse.

[Original Description]

Dear Maintainer,

I am the upstream developer for gummi. After a long hiatus I have in recent months resumed development. Unfortunately the gummi package that was imported from Debian sid for this Ubuntu release is a development build that suffers from a critical bug.

I hereby request to:

1. Update the package to stable release 0.8.1 (see [2])
2. Remove the package from ubuntu universe/tex

Thanks in advance and with kind regards,

alexandervdm

[1] https://github.com/alexandervdm/gummi/issues/33
[2] https://github.com/alexandervdm/gummi/releases/tag/0.8.1

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gummi 0.7.999-1
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu26
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: MATE
Date: Tue Apr 14 10:54:35 2020
InstallationDate: Installed on 2020-02-24 (49 days ago)
InstallationMedia: Ubuntu-MATE 20.04 LTS "Focal Fossa" - Alpha amd64 (20200211)
SourcePackage: gummi
UpgradeStatus: No upgrade log present (probably fresh install)

Alexander (5-accounts) wrote :
Changed in gummi:
status: Unknown → New
Changed in gummi:
status: New → Fix Released
Alexander (5-accounts) wrote :

I really hope this can get fixed soon as the development build that is being distributed contains critical problems.

In the meantime I have prepared a package repository for Ubuntu users on the official website. Please see: https://packages.gummi.app/

Łukasz Zemczak (sil2100) wrote :

Thank you for reporting this bug. The only logical way forward here is to update the package to the new upstream version in focal or distro-patching the critical issues that you have mentioned. Both of these require performing an SRU, about which you can read more here: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

I'll subscribe ubuntu-sponsors so that someone can take a look and sponsor the package for you just in case.

Changed in gummi (Ubuntu):
status: New → Fix Committed
Mathew Hodson (mhodson) on 2020-05-08
Changed in gummi (Ubuntu):
importance: Undecided → Low
Changed in gummi (Ubuntu Focal):
importance: Undecided → Low
tags: added: upgrade-software-version
summary: - gummi package is development build with critical bugs
+ Upgrade gummi package to version 0.8.1
Mathew Hodson (mhodson) on 2020-05-20
affects: gummi → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
Changed in gummi (Debian):
status: Unknown → Fix Released
Alexander (5-accounts) wrote :

Hi Łukasz, thanks for your response. In this particular case distro-patching is not an option. There is one critical bug, but the development build that is being offered contains many more bugs that were eventually fixed in the actual release. I'd like to emphasize again that the build that Ubuntu is offering right now was never meant to go into production.

I've taken a look at the SRU procedure, and it sounds like it could take a while (as it should of course). For this reason I honestly would prefer for the package to be removed from focal alltogether so users don't potentially lose data.

Łukasz Zemczak (sil2100) wrote :

Hello Alexander! As per what we discussed, removing it from focal might be tricky at this moment. I think what needs to be done anyway is backporting 0.8.1 to focal, which is something I can help with. One thing that I need to know before we can proceed - for the SRU rationale I need to know more about the 'critical bug' that you are referring to. I know you have mentioned that this development build has multiple issues, but for transparency and understanding of the rationale, we would need to know what are the critical bugs about? Are those reported anywhere? What would be the test case to validate that the critical bugs are no longer present with the upgraded package?

Those are essential information. We know that you, as the software maintainer, know best what versions should be used and which ones should not. But as an open source community we need to know as much as possible, especially when we're talking about stable Ubuntu series.

Thank you!

description: updated
Alexander (5-accounts) wrote :

Hi Łukasz, the development build being offered now suffers from one critical bug with the potential to cause data loss. This particular issue causes a racing / thread safety problem leading to a crash that was introduced due to an oversight on my part when I migrated the code-base to GTK3/Sourceview3/etc. It was reported here [1].

Due to the nature of the bug, it is difficult to reliably trigger. The user who reported the bug mentions it could happen within 30 minutes of normal gummi usage, or not happen at all after 10+ hours of working. I was able to reliably trigger it within the hour by using a script that simulated constant user input. The patch I wrote and included in 0.8.1 was verified to solve the problem using the same method.

[1] https://github.com/alexandervdm/gummi/issues/126

Łukasz Zemczak (sil2100) wrote :

Sponsored 0.8.1-1ubuntu0.20.04.1 to the focal-proposed Unapproved queue. Now we need someone from the SRU team to review and accept the package.

Setting the devel series to Fix Released as 0.8.1 has been auto-synced into groovy.

description: updated
Changed in gummi (Ubuntu Focal):
importance: Low → High
status: New → Confirmed
Changed in gummi (Ubuntu):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

When testing the version of the package from -proposed I'd like to see the script mentioned in comment #6 used to confirm that the critical bug is fixed. Ideally that should be part of the test case.

Changed in gummi (Ubuntu Focal):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-focal

Hello Alexander, or anyone else affected,

Accepted gummi into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gummi/0.8.1-1ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Alexander (5-accounts) wrote :

I prepared a focal installation this morning and was able to trigger the bug on the 0.7.999-1 package using the simulated input approach mentioned above. After enabling the focal-proposed channel and upgrading to the new package, the simulation ran without triggering said bug or other unintended side effects multiple times for several hours.

Alexander (5-accounts) wrote :

As far as I can tell I can't set the verification-done-focal tag myself, so hereby hoping someone can do this for me and move the focal-proposed package further along. Thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.