guile-pg 0.16-4.2 FTBFS in maverick

Bug #611965 reported by Bhavani Shankar on 2010-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
guile-pg (Debian)
Fix Released
Unknown
guile-pg (Ubuntu)
Wishlist
Unassigned

Bug Description

Originally this bug intended to be a sync as debian fixed FTBFS due to missing build-dep on libltdl-dev but the version incorporating the change again FTB'd due to build error on a directory removal (See Benjamin's comments below)

Related branches

Benjamin Drung (bdrung) wrote :

The package fails to build on amd64:

rm /tmp/buildd/guile-pg-0.16/debian/guile-pg/usr/share/info/dir*
rm: cannot remove `/tmp/buildd/guile-pg-0.16/debian/guile-pg/usr/share/info/dir*': No such file or directory
make: *** [install] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2

Please resubscribe ubuntu-sponsors once addressed the build failure.

Bhavani Shankar (bhavi) on 2010-07-31
summary: Please sync guile-pg 0.16-4.2 (universe) from Debian unstable (main).
+ (FTBFS in maverick on latest rebuild)

Hello benjamin

it seems to be FTBFS in debian rebuild today

here is a attached minimal diff to fix build problems

regards

Changed in guile-pg (Ubuntu):
status: New → Confirmed
Bhavani Shankar (bhavi) on 2010-07-31
summary: - Please sync guile-pg 0.16-4.2 (universe) from Debian unstable (main).
- (FTBFS in maverick on latest rebuild)
+ guile-pg 0.16-4.2 FTBFS in maverick
Changed in guile-pg (Debian):
status: Unknown → New
Bhavani Shankar (bhavi) wrote :
description: updated
tags: added: ftbfs patch sync
Benjamin Drung (bdrung) on 2010-07-31
tags: added: merge
removed: sync
Stefano Rivera (stefanor) wrote :

Bhavi: Please attach this patch to the debian bug report (and tag it patch), we can give them a few days to give us something syncable.

Bhavani Shankar (bhavi) wrote :

done stefano,

regards

Stefano Rivera (stefanor) wrote :

You need to CC <email address hidden> if you want to process commands like that. I suggest re-sending that e-mail directly to <email address hidden>.

oops sorry missed the CC

done stefano,

regards

On Wed, Aug 4, 2010 at 1:14 PM, Stefano Rivera <email address hidden> wrote:
> You need to CC <email address hidden> if you want to process commands
> like that. I suggest re-sending that e-mail directly to
> <email address hidden>.
>
> --
> guile-pg 0.16-4.2 FTBFS in maverick
> https://bugs.launchpad.net/bugs/611965
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “guile-pg” package in Ubuntu: Confirmed
> Status in “guile-pg” package in Debian: New
>
> Bug description:
> Originally this bug intended to be a sync as debian fixed FTBFS due to missing build-dep on libltdl-dev but the version incorporating the change again FTB'd due to build error on a directory removal (See Benjamin's comments below)
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/guile-pg/+bug/611965/+subscribe
>

--

Bhavani Shankar.R
https://launchpad.net/~bhavi, a proud ubuntu community  member.
What matters in life is application of mind!,
It makes great sense to have some common sense..!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package guile-pg - 0.16-4.2ubuntu1

---------------
guile-pg (0.16-4.2ubuntu1) maverick; urgency=low

  * debian/rules:
    + Drop rm rule on /usr/share/info/dir* and hence fix build
      problems (Closes: #590952, LP: #611965)

guile-pg (0.16-4.2) unstable; urgency=low

  * Non-maintainer upload.
  * Use patch by Hideki Yamane <email address hidden>
  * debian/control
    - add "Build-Depends: libltdl-dev" to fix FTBFS (Closes: #562313)
  * Update config.{guess,sub}
 -- Bhavani Shankar <email address hidden> Sat, 31 Jul 2010 20:11:29 +0530

Changed in guile-pg (Ubuntu):
status: Confirmed → Fix Released
Changed in guile-pg (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.