Sync guile-2.0 2.0.3+1-2 (universe) from Debian testing (main)

Bug #906678 reported by Jeremy Bicha on 2011-12-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
guile-2.0 (Debian)
Fix Released
Unknown
guile-2.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync guile-2.0 2.0.3+1-2 (universe) from Debian testing (main)

All changelog entries:

guile-2.0 (2.0.3+1-2) unstable; urgency=low

  * Disable SLIB setup for now, since SLIB doesn't support Guile 2.0
    yet. Thanks to "Aaron M. Ucko" <email address hidden> for the report.
    (Closes: #648680)

  * Add build-deps: libunistring-dev, libgc-dev libffi-dev, and
    pkg-config. Thanks to "Aaron M. Ucko" <email address hidden> for the
    report, and Svante Signell <email address hidden> for an initial
    patch. (Closes: #648679)

  * Automatically extract versions from debian/changelog in
    debian/rules.

  * Create .version and .tarball-version from the values in
    debian/changelog. Automatically generate a top-level .version and
    .tarball-version based on the values in debian/changelog, so that
    the Guile PACKAGE_VERSION (and output of the version function) will
    include the Debian revision, i.e. (version) => "2.0.3-deb+1-2".

 -- Rob Browning <email address hidden> Tue, 22 Nov 2011 21:36:50 -0600

guile-2.0 (2.0.3+1-1) unstable; urgency=low

  * Incorporate new upstream release, and eliminate the DFSG split. The
    upstream GFDL licensed files no longer have invariant clauses.

  * Adjust debian/* for guile-2.0, and remove alpha and sh4 CFLAGS
    alterations.

  * Finally re-enable threads.

  * Include gc.h rather than gc/gc_version.h in pthread test. See
    comments in recent gc_version.h. It should never be included
    directly, and doing so was causing build failures.
    (0003-Include-gc.h-rather-than-gc-gc_version.h-in-pthread-.patch).

 -- Rob Browning <email address hidden> Thu, 10 Nov 2011 02:33:11 -0600

guile-1.8 (1.8.8+1-7) unstable; urgency=low

  * Allow guile-1.8 and guile-2.0 manpages to coexist. Rename the manpage
    from guile.1 to guile-X.Y.1 and use update-alternatives --slave so
    that the Guile manpage will be available via "man guile" or "man
    guile-X.Y".

  * Configure with --disable-error-on-warning. This fixes build failures
    caused by newer versions of gcc that report new warnings. Thanks to
    Matthias Klose <email address hidden> for the report, <email address hidden> (Ludovic
    Courtès) for the fix, and Nobuhiro Iwamatsu <email address hidden> for
    the 1.8.8+1-6.1 NMU which included it. (Closes: #625355)

  * Add upstream patch to fix sockets.test on non-IPV6 kernels. Add
    0006-Make-sockets.test-more-robust.patch. Thanks to Nobuhiro Iwamatsu
    <email address hidden> for the report and the pointer to the upstream
    patch. (Closes: #631254)

 -- Rob Browning <email address hidden> Wed, 09 Nov 2011 19:17:30 -0600

guile-1.8 (1.8.8+1-6) unstable; urgency=low

  * Add "Replaces: guile-1.8-dev" to guile-1.8-libs to accommodate .so
    moves. Thanks to Marc Glisse <email address hidden> for the
    report. (closes: #628087)

 -- Rob Browning <email address hidden> Fri, 27 May 2011 18:27:28 -0500

guile-1.8 (1.8.8+1-5) unstable; urgency=low

  * Add a copy of the guile binary to /usr/lib/guile-1.8/bin in
    guile-1.8-libs to support the slib postinst trigger; remove the
    guile-1.8-libs dependency on guile-1.8. Thanks to Bill Allombert
    <email address hidden> for the report. (closes: #626167)

 -- Rob Browning <email address hidden> Sun, 15 May 2011 18:27:49 -0500

guile-1.8 (1.8.8+1-4) unstable; urgency=low

  * Add guile-1.8 dependency to guile-1.8 for slib related postinst code.
    Thanks to Peter De Wachter <email address hidden> for the report.
    (closes: #625243)

 -- Rob Browning <email address hidden> Sun, 08 May 2011 12:40:21 -0500

guile-1.8 (1.8.8+1-3) unstable; urgency=low

  * Drop guile-1.8-slib package again, and handle SLIB via a
    guile-1.8-libs /usr/share/slib trigger. Among other things, these
    changes should fix the recent problems with SLIB support, and should
    also make sure that Guile's SLIB support is adjusted properly whenever
    the slib package is updated. Thanks to Gert Michael Kulyk
    <email address hidden> for the report. (closes: #624531)

  * Move libguile?*.so files to guile-1.8-dev now that .la files are gone.
    Guile dynamically loads these libraries via dlopen, so it needs the
    .so files for operations like (use-modules (srfi srfi-13)). Given the
    way Guile handles the library names upstream (changing the library
    names for ABI changes), putting the .so files in guile-X.Y-libs won't
    cause file conflicts across different major versions. Thanks to
    Tomasz Melcer <email address hidden> for the report. (closes: #622280)

  * Rename debian/*.lintian to debian/*.lintian-overrides; update
    overrides.

 -- Rob Browning <email address hidden> Sun, 01 May 2011 21:55:44 -0500

guile-1.8 (1.8.8+1-2) unstable; urgency=low

  * Don't access uninitialized memory in scm_to_sockaddr().
    Thanks to Thorsten Glaser <email address hidden> for the patch.

  * Add flex as a build dependency.
    Thanks to Thorsten Glaser <email address hidden> for the patch.

 -- Rob Browning <email address hidden> Wed, 27 Apr 2011 22:26:20 -0500

guile-1.8 (1.8.8+1-1) unstable; urgency=low

  * Incorporate upstream release 1.8.8. (closes: #616694)

  * Switch to 3.0 (quilt) source format.

  * Rewrite debian/rules to use "dh $@"; update debian/compat to 8, and
    let dh_auto* handle as much as possible.

  * Depend on libltdl-dev and libgmp-dev, not libltdl3-dev and libgmp3-dev.
    Thanks to Jordi Mallach <email address hidden> for the fix.

  * Remove *.la files from all debs (wheezy release goal).
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #621240)

  * Add guile1.4 conflict to guile-1.8 package.
    Thanks to Jordi Mallach <email address hidden> for the fix. (closes: #523949)

  * Add a homepage field to the control file.
    Thanks to Jordi Mallach <email address hidden> for the suggestion.

  * Make guile-1.8 and guile-1.8-dev depend on current guile-1.8-libs version.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441241)

  * Restore guile-1.8-slib package now that Guile supports it again.
    Thanks to Jordi Mallach <email address hidden> for the patch. (closes: #441110)

  * Update package descriptions.

  * Export fake HOME to make sure the build process doesn't touch the real one.
    Thanks to Jordi Mallach <email address hidden> for the fix.

 -- Rob Browning <email address hidden> Tue, 26 Apr 2011 20:41:29 -0500

guile-1.8 (1.8.7+1-3) unstable; urgency=low

  * Change debian/control sections to lisp to match Debian distribution
    overrides.

  * Fix problem with make check and newer libltdl
    (fix-make-check-for-new-libltdl.diff). Thanks to Lucas Nussbaum
    <email address hidden> for the report. (closes: #560653)

 -- Rob Browning <email address hidden> Mon, 18 Jan 2010 22:32:29 -0800

guile-1.8 (1.8.7+1-2) unstable; urgency=low

  * Add -Xusr/share/info/dir to dh_install and depend on "dpkg (>= 1.15.4)
    | install-info". Thanks to Jordi Mallach <email address hidden> for an
    interim NMU (1.8.7+1-1.1).

  * Add debhelper ${misc:Depends} to debian/control for all binary
    packages. Thanks to Jordi Mallach <email address hidden> for an interim
    NMU (1.8.7+1-1.1).

  * Install ./examples to /usr/share/doc/guile-1.8-dev/examples. Thanks
    to Mario Lang <email address hidden> for the suggestion. (closes: 539317).

  * Add /usr/share/doc/guile-1.8-libs/README.Debian to discuss the
    --with-threads issue. Thanks to <email address hidden> (Riku Saikkonen) for
    the suggestion. (closes: 530010)

  * Change dependency from libreadline5-dev to libreadline6-dev. Thanks
    to Trafire Arcanegrin <email address hidden> for the report and Jordi
    Mallach <email address hidden> for an interim NMU (1.8.7+1-1.1).
    (closes: #550131)

 -- Rob Browning <email address hidden> Sun, 25 Oct 2009 19:54:08 -0700

guile-1.8 (1.8.7+1-1) unstable; urgency=low

  * Incorporate new upstream stable release.

  * Do not redefine jmp_buf in a public header, rather define
    scm_jump_buf, etc. Thanks to <email address hidden> and Kurt Roeckx
    <email address hidden>, and to Ben Hutchings <email address hidden> for the
    patch. (closes: 527527, 506684)

  * Add support for Renesas SuperH architecture. Thanks to Nobuhiro
    Iwamatsu <email address hidden>. (closes: 531378)

 -- Rob Browning <email address hidden> Mon, 06 Jul 2009 23:12:42 -0700

guile-1.8 (1.8.6+1-1) unstable; urgency=low

  * Incorporate new upstream stable release. (closes: #522717, #396975)

 -- Rob Browning <email address hidden> Sun, 12 Apr 2009 19:56:55 -0700

guile-1.8 (1.8.5+1-4) unstable; urgency=medium

  * Change Architectures back to any where appropriate (i.e. include
    ia64). (closes: #495209)

 -- Rob Browning <email address hidden> Tue, 26 Aug 2008 22:58:14 -0700

guile-1.8 (1.8.5+1-3) unstable; urgency=medium

  * Fix the stack direction check again in order to fix builds on hppa.
    Thanks to Neil Jerram <email address hidden> for the final
    patch. (closes: #481378)

  * Add kfreebsd-i386 and kfreebsd-amd64 to the relevant Architectures
    lines in debian/control. Thanks to Petr Salinger
    <email address hidden> for the fix. (closes: #493164)

  * Fix ia64 continuations. Thanks to Neil Jerram
    <email address hidden> for the patch. (closes: #401400)

 -- Rob Browning <email address hidden> Sun, 10 Aug 2008 17:44:21 -0700

guile-1.8 (1.8.5+1-2) unstable; urgency=medium

  * Fix the stack direction check on a number of architectures, and the
    mips gc definitions. Thanks to Thiemo Seufer <email address hidden> for
    the initial report and Neil Jerram <email address hidden> for the
    final patches. (closes: #481378)

 -- Rob Browning <email address hidden> Sun, 03 Aug 2008 16:35:39 -0700

guile-1.8 (1.8.5+1-1) unstable; urgency=medium

  * Incorporate new upstream stable release.

  * Fix gcc 4.3 compilation problems (fixed upstream now). Thanks to
    Alexander Schmehl <email address hidden> for the previous, related
    1.8.4+1-2.1 NMU, and to Maximiliano Curia and Daniel Schepler for the
    original patch. (closes: #462384, #466778)

 -- Rob Browning <email address hidden> Sat, 10 May 2008 12:18:50 -0700

guile-1.8 (1.8.4+1-2) unstable; urgency=low

  * Remove ia64 from Architectures. Since it doesn't look like "!ia64" is
    legal syntax for Architectures, just enumerate them all. Guile
    doesn't support ia64 yet. (closes: #400401)

  * Use -Os on alpha rather than -O2. Right now -O2 causes make check to
    fail with a segfault in r4rs.test.

 -- Rob Browning <email address hidden> Sun, 09 Mar 2008 11:49:23 -0700

guile-1.8 (1.8.4+1-1) unstable; urgency=low

  * Incorporate new upstream stable release.

  * Use @DEB_SRC_EFF_VER@ in debian/guile-doc.install.

  * Add NEWS to /usr/share/doc/guile-*-doc/. (closes: #405231)

  * Add const to ucontext_t* in gc.c for ia64. Thanks to Matthew Wilcox
    <email address hidden> and <email address hidden>. (closes: #465191, #460106)

  * Move menu entry from Apps to Applications.

 -- Rob Browning <email address hidden> Sat, 23 Feb 2008 15:04:32 -0800

guile-1.8 (1.8.3+1-1) unstable; urgency=low

  * Incorporate new upstream stable release.

  * Re-disable threads. It turns out that Guile's libraries aren't ABI
    compatible when compiled with and without threads. Since Etch shipped
    --without-threads, threads will remain disabled for now. (closes: #439923)

  * Add some lintian overrides. Thanks to Ludovic RESLINGER.
    (closes: #396977, #397009)

 -- Rob Browning <email address hidden> Sun, 18 Nov 2007 14:19:05 -0800

guile-1.8 (1.8.2+1-2) unstable; urgency=low

  * Re-enable threads.

 -- Rob Browning <email address hidden> Sat, 25 Aug 2007 17:59:12 -0700

guile-1.8 (1.8.2+1-1) unstable; urgency=low

  * Incorporate new upstream stable release. (closes: #435548)

 -- Rob Browning <email address hidden> Fri, 24 Aug 2007 19:09:56 -0700

guile-1.8 (1.8.1+1-5) unstable; urgency=low

  * Add NEWS to guile-1.8-doc. (closes: #405231)

  * Fix GNU/kFreeBSD build. Thanks to Petr Salinger. (closes: #401168)

 -- Rob Browning <email address hidden> Sun, 4 Mar 2007 17:01:16 -0800

guile-1.8 (1.8.1+1-4) unstable; urgency=low

  * Fix additional problems with the test suite on 64-bit
    architectures. (closes: #396119)

  * Fix srfi-14.test (use throw rather than thrown). (closes: #397740)

 -- Rob Browning <email address hidden> Fri, 1 Dec 2006 19:08:57 -0800

guile-1.8 (1.8.1+1-3) unstable; urgency=low

  * Add build dependency on texinfo.

 -- Rob Browning <email address hidden> Thu, 30 Nov 2006 20:51:41 -0800

guile-1.8 (1.8.1+1-2) unstable; urgency=low

  * Add build dependency on libltdl3-dev. (closes: #395235)

  * Add build dependency on libgmp3-dev. (closes: #396922)

  * Add libltdl3-dev dependency to guile-1.8-dev. (closes: 395290)

  * Add libgmp3-dev dependency to guile-1.8-dev. (closes: #395454)

  * Update Standards-Version. (closes: #396972)

  * Update debhelper dependency to match debian/compat. (closes: #396974)

  * Fix problem with copy-bit and with various tests on 64-bit
    architectures. (closes: #396119)

 -- Rob Browning <email address hidden> Thu, 30 Nov 2006 19:04:43 -0800

guile-1.8 (1.8.1+1-1) unstable; urgency=medium

  * Incorporate new upstream stable release.

  * Remove the debian/patches for items fixed upstream (all of them).

  * In accordance with the recent General Resolution
    (http://www.debian.org/vote/2006/vote_001), move all non-DFSG files to
    new packages that will be included in Debian's non-free section. The
    debian/dfsg-splitter script has been used to split the upstream
    archive.

  * Version the doc package info files so that the doc package for each
    Guile stable series no longer conflicts with the doc package for other
    stable series. This has made the virtual guile-doc package obsolete.

  * Delete debian/need-empty-autofiles-diff when not needed, always start
    with an empty autofiles.diff when regenerating, and fix a few other
    things in rules.

  * Work around a dh_installinfo bug. It always inserts \Q and \E around
    the --section, which doesn't work.

 -- Rob Browning <email address hidden> Sun, 8 Oct 2006 20:34:21 -0700

guile-1.8 (1.8.0-1) unstable; urgency=low

  * Incorporate new upstream release. (closes: #383910, #316083)

  * Compile --with-threads=no for now to avoid a thread-related bug. This
    should be a temporary measure.

  * Move guile-config, guile-snarf, guile-tools, and guile scripts to
    guile-1.8-dev package.

  * Disable SLIB support for now since Guile 1.8 doesn't support SLIB
    upstream yet.

  * Rewrite the #! line of appropriate guile scripts to use the versioned
    binary name. This should have already been the case, but the code in
    debian/rules wasn't quite right.

  * When autofiles.diff is empty, it doesn't show up in the resulting
    Debian source tree (via dpkg-source -x), so fix debian/rules to
    accommodate.

  * NOTE: the 1.8 package was branched from the 1.6 package before the
    1.6.7-3 release, so there are more recent 1.6 releases that are not
    shown below.

 -- Rob Browning <email address hidden> Wed, 13 Sep 2006 00:13:02 -0700

guile-1.6 (1.6.7-2) unstable; urgency=low

  * Migrate from dpatch to quilt.

  * Fix FTBFS with gcc-4.0. Thanks to Daniel Schepler
    <email address hidden>. (closes: #300146)

  * Rebuild with current dpkg-dev to fix the cpp version in guile-snarf.
    Thanks to Daniel Schepler <email address hidden>. (closes: #317600)

  * Update debian/rules to support autofiles.diff, autofiles-sync, etc.

  * Add (pending) upstream patch for compatibility with newer SLIB, but
    adjust the new slib.scm to load slib/init/guile.init rather than
    slib/guile.init in order to accomodate Debian's slib.
    (closes: #334735, #337346, #338823, #340149)

 -- Rob Browning <email address hidden> Thu, 12 Jan 2006 20:08:32 -0800

guile-1.6 (1.6.7-1) unstable; urgency=medium

  * new upstream bugfix release. (closes: #279282)
  * updated guile-X.Y-slib package description.
  * changed build dependency to libreadline5-dev. (closes: #279280)

 -- Rob Browning <email address hidden> Tue, 21 Dec 2004 13:14:00 -0600

guile-1.6 (1.6.4-4) unstable; urgency=low

  * Fix release oversight (forgot to delete beta pkg warning(s)).

 -- Rob Browning <email address hidden> Fri, 29 Aug 2003 15:21:05 -0500

guile-1.6 (1.6.4-3) unstable; urgency=low

  * patch 50_gc-realloc fixes snd gc segfault. Thanks to Sam Hocevar
    <email address hidden>. (closes: #198896)
  * patch 50_m68k-smob-crash fixes m68k build crash. Thanks to Sam
    Hocevar <email address hidden>. (closes: #193870)
  * patch 50_ia64-ucontext fixes ia64 ucontext related build failure.
    Thanks to Sam Hocevar <email address hidden>. (closes: #193868)
  * fix guile-1.6 conflicts with libguile-dev -- didn't have epoch so
    wasn't having any effect. guile-1.6 needs to conflict with earlier
    libguile-dev versions because they didn't use update-alternatives for
    bin/guile-X.Y*. It can't conflict with later versions
    (i.e. guile-1.6-dev and on) because guile-X.Y-dev is supposed to
    provide/conflict with libguile-dev. (closes: #198858)

 -- Rob Browning <email address hidden> Fri, 29 Aug 2003 11:13:02 -0500

guile-1.6 (1.6.4-2) unstable; urgency=low

  * continuations.h: include ucontext.h rather than sys/ucontext.h on
    ia64. This fixes a compilation problem for things that use libguile.
    Thanks to James Treacy. (closes: bug#191464)
  * make guile-1.6 conflict with libguile-dev since libguile-dev didn't
    use update-alternatives for guile-config and guile-tools. I believe
    this is what has been hosing guile-config in guile-1.6.
    (closes: bug#183977, bug#188322)
  * really fix debian/rules to avoid --enable-maintainer-mode during
    normal package builds.

 -- Rob Browning <email address hidden> Mon, 12 May 2003 23:21:57 -0500

guile-1.6 (1.6.4-1) unstable; urgency=low

  * remove --list-missing from debian/rules. (closes: bug#187926)
  * try fix for libqthreads-12 per-arch build problem. Try just producing
    an empty libqthreads-12 .install file on unsupported arches.
    (closes: bug#183686)
  * fix alpha qt assembly bugs. (closes: bug#186981)
  * upstream arch related fixes.
    (closes: bug#189316, bug#189315, bug#186981, bug#186877, bug#184773)

 -- Rob Browning <email address hidden> Mon, 21 Apr 2003 13:11:35 -0500

guile-1.6 (1.6.3-4) unstable; urgency=low

  * first 1.6 upload to unstable.

 -- Rob Browning <email address hidden> Thu, 27 Feb 2003 18:49:46 -0600

guile-1.6 (1.6.3-3) unstable; urgency=low

  * change some /usr/bin/guile references to /usr/bin/guile-1.6 so we make
    sure to get the right version (thanks Dale).
  * unreleased test version.

 -- Rob Browning <email address hidden> Fri, 7 Feb 2003 12:09:34 -0600

guile-1.6 (1.6.3-2) unstable; urgency=low

  * rearrange guile so it allows guile1.4 and guile-1.6 to coexist.
  * unreleased test version.

 -- Rob Browning <email address hidden> Wed, 5 Feb 2003 15:09:16 -0600

guile-1.6 (1.6.3-1) unstable; urgency=low

  * unreleased test version.

 -- Rob Browning <email address hidden> Sat, 1 Feb 2003 10:16:48 -0600

guile-1.6 (1.6.2-1) unstable; urgency=low

  * new upstream release (still not ready for Debian proper yet).

 -- Rob Browning <email address hidden> Thu, 30 Jan 2003 14:17:23 -0600

guile-1.6 (1.6.1-3) unstable; urgency=low

  * handle non-qthreads architectures properly.

 -- Rob Browning <email address hidden> Mon, 16 Dec 2002 23:48:51 -0600

guile-1.6 (1.6.1-2) unstable; urgency=low

  * include libguilereadline-v-12.so.* too.
  * add conflicts/replaces goops-doc to guile-1.6-doc.

 -- Rob Browning <email address hidden> Sat, 23 Nov 2002 17:12:33 -0600

guile-1.6 (1.6.1-1) unstable; urgency=low

  * trial pkg.

 -- Rob Browning <email address hidden> Mon, 11 Nov 2002 10:52:58 -0600

Jeremy Bicha (jbicha) on 2011-12-20
Changed in ubuntu:
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) wrote :

guile-2.0 is required for aisleriot 3.3. Please also add to the ubuntu-desktop set. We don't need a MIR for this since guile-1.8 is already in main, right?

Micah Gersten (micahg) wrote :

Being a new dep would be a good reason not to upload aisleriot 3.3. Is there a plan to migrate to guile-2.0 for precise? Are we ok with both in main? Current rdeps in main:
-- precise/main build deps on guile-1.8-dev:
aisleriot
autogen
gnutls26
graphviz
swig2.0

The universe list is much longer.

Changed in ubuntu:
status: New → Incomplete
Jeremy Bicha (jbicha) wrote :

The Lilypond developer says on the attached Debian bug that guile 2.0 which has been out since February features "a much improved garbage collection (based on libgc), proper unicode support, compiled code and is MUCH faster."

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615479

Micah Gersten (micahg) wrote :

subscribed pitti for comment
pitti, what do you think of this?

Changed in guile-2.0 (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

As the binary packages don't overlap, I have no objection to syncing it into universe. At some point this happens through the auto-syncs anyway.

Whether we can actually use it in main depends on the answer to Micah's questions in comment 2: As long as we can migrate all rdepends in main to 2.0 without much pain, i. e. the API did not change too dramatically (or Debian is already converting), then no objection from me.

Martin Pitt (pitti) wrote :

synced into universe

affects: ubuntu → guile-2.0 (Ubuntu)
Changed in guile-2.0 (Ubuntu):
status: Incomplete → Fix Released
Changed in guile-2.0 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.