KDE4 guidance-power-manager tooltip allways shows top left of icon

Bug #269483 reported by Bart Kroon on 2008-09-12
4
Affects Status Importance Assigned to Milestone
guidance-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: guidance-power-manager

When I hover over the systray icon of the guidance-power-manager it shows a tool-tip window with information about CPU speed and battery charge. This behavior is as expected, but since I have the systray on the left side of my screen on a vertical panel the tool-tip goes left off my screen and is of no use to me.

Expected behavior: The tool-tip is shown on whatever side is available just like all the other tooltips.

$ guidance-power-manager --version
Qt: 4.4.1
KDE: 4.1.1 (KDE 4.1.1)
Guidance Power Manager: 4.1.0

I have the same problem. My systray is in a top panel, so I can't see the tooltip.

With this simple patch and got it working. I could not test it in a multi-head machine and I'm not sure what QDesktopWidget().screenGeometry() will return in that case, but I guess it will work.

Bart Kroon (tarmack) wrote :

Thank you Murillo Fernandes Bernardes,

I tested your patch and it looks good to me, but I am also not able to test on a multi-head machine.
could someone test this one would expect its required to get it committed.

Thanks again

I tried to test the patch with two monitors, but because of https://bugs.launchpad.net/ubuntu/+bug/270646 I can't. My system just freeze :(

Looks like it was fixed. It's working fine in my top panel now.

guidance-power-manager 4:4.1.1-0ubuntu1

$ guidance-power-manager --version
Qt: 4.4.2
KDE: 4.1.1 (KDE 4.1.1)
Guidance Power Manager: 4.1.1

Bart Kroon (tarmack) wrote :

In version 4:4.1.1-0ubuntu1 the tooltip placement is as expected.

Changed in guidance-power-manager:
status: New → Fix Released
Bart Kroon (tarmack) wrote :

So I obviously changed the status to fix released.

why can't I edit my own comment!?!! ;) I always make mistakes :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers