gufw will not open in ubuntu wayland 17.10

Bug #1713238 reported by ventrical on 2017-08-26
This bug affects 28 people
Affects Status Importance Assigned to Milestone
gui-ufw (Ubuntu)

Bug Description

when clicking on gufw icon it will not run the program in wayland.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gufw 17.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
ApportVersion: 2.20.6-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Aug 26 09:17:58 2017
InstallationDate: Installed on 2017-08-22 (3 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170820)
PackageArchitecture: all
SourcePackage: gui-ufw
UpgradeStatus: No upgrade log present (probably fresh install)

ventrical (dale-f-beaudoin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gui-ufw (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

If I remember correctly, this app used to have proper PolicyKit implementation but it was replaced by pkexec. GNOME Shell does not currently support pkexec.

tags: added: wayland
Changed in gui-ufw (Ubuntu):
importance: Undecided → High
ventrical (dale-f-beaudoin) wrote :

It works just fine with GNOME SHELL.

Please see my message "it will not run the program in wayland"!

Thanks :)

ventrical (dale-f-beaudoin) wrote :

It works just fine with GNOME SHELL.

Please see my message "it will not run the program in wayland"!

synaptic also works just swell in gnome-shell as does pkexec.

testing unity7 and gnome-shell are a breeze. It's 'wayland' we want to get up to speed.

Thanks :)

ventrical (dale-f-beaudoin) wrote :


Will not run gufw in Ubuntu (17.10)amd64

Hi, is this a wayland issue then? Is it working gparted? Thanks in advance.
Best regards.

On Aug 26, 2017 17:25, "ventrical" <email address hidden> wrote:

> #append#
> Will not run gufw in Ubuntu (17.10)amd64
> --
> You received this bug notification because you are subscribed to gui-ufw
> in Ubuntu.
> Title:
> gufw will not open in ubuntu wayland 17.10
> To manage notifications about this bug go to:
> 1713238/+subscriptions

ventrical (dale-f-beaudoin) wrote :

Yes. Wayland issue. gparted works fine in gnome-shell. Calls policykit for authentication .. etc..

Lets get this firewall fixed in wayland first as it is a potential security risk for those needing a firewall while testing gnome(wayland) on line.

costales (costales) wrote :

I didn't like politykit in the past, so so so complicate to debug. I
migrated Gufw looking into the Gparted code.

I don't understand the issue, gnome shell - wayland. Gnome shell is the UI
and Wayland is the graphic engine (?). Gnome shell is running over wayland,
then Gufw or GParted should not work (?).

Anyway it is a so big change in the code and I don't time for it now :(

costales (costales) on 2017-08-26
Changed in gui-ufw:
status: New → Confirmed
importance: Undecided → Critical
ventrical (dale-f-beaudoin) wrote :

It is important to have this working by release day for 17.10 We will be testing wayland hard during 18.04 cycle and we need a graphical firewall. It makes it hard to recruit new testers when synaptic,gufw and gparted are not working nativley in wayland when thy should be.

Thanks for your attention.


Jeremy Bicha (jbicha) wrote :

Yes, gparted does not work with the default Ubuntu 17.10 session since Ubuntu is now using GNOME on Wayland.

GNOME (or Ubuntu) on Wayland does not support pkexec the way gparted or synaptic use it.

costales (costales) wrote :


I tried Ubuntu current daily image.

The resume would be (IMO):

- Ubuntu with xorg: works everything.
- Ubuntu with wayland: doesn't work [sudo|pkexec]? apps (Synaptic, GParted,

Best regards.

ventrical (dale-f-beaudoin) wrote :


Yes, that is correct.
My apologies for belaboring the matter. It is just an issue that since wayland will eventually be default we should have these well used and well know apps working (on wayland) before the next toolchain if not from a developers point of view, at least from a beta testers perspective.

Thank you for your attention in this matter.


Norbert (nrbrtx) wrote :

For you information - here is a list of all affected pkexec'ed applications - see bug 1713313 .

Norbert (nrbrtx) wrote :

And also we have a list of gksu/gksudo applications here - see bug 1713311 .

AsciiWolf (asciiwolf) wrote :

Still not fixed.

ventrical (dale-f-beaudoin) wrote :

I am glad they marked it up critical, especially in light of Specter/Meltdown exloitables. Not sure if gufw would do any good anyways , but at least it is one layer of security.

Matej Kovacic (matej-kovacic) wrote :

The same problem here.

Anyway, I can understand Gufw cannot be run in current state from Wayland. But is there any GUI for firewall in Ubuntu?

I mean, it is 2018, GUI is a must have and firewall is a standard security package not intended for advanced users only!

ventrical (dale-f-beaudoin) wrote :

Since xorg is now the new default the wayland/gnome devs can take a breather. So can the rest of us.

AsciiWolf (asciiwolf) wrote :

Yep, but it still should be fixed so users could switch to Wayland without having any issues in the future.

@asciiwolf: I wish this interface allowed me to upvote posts like yours.

PeterPall (peterpall) wrote :

The problem is that wayland as a security measure *either* gives you access to the display server *or* to root => the interactive part of gufw needs to be running with the user account and the small portions root privilleges are needed for need to be run by policykit. Which is a good idea - but which synaptic and gufw currently fail to do.

Wayland is planned to be default Ubuntu Desktop session from 20.04 LTS. This should be fixed quickly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers