gufw is not displayed under GNOME session

Bug #1071915 reported by Tim on 2012-10-26
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Gufw
Undecided
Manish Wadhwani
gui-ufw (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]
Under unity, gufw is displayed under 'other' in system settings. However under gnome-shell and gnome-classic it is not displayed at all. So the only way to launch it is from the command line.

[TESTCASE]
1. Under gnome-shell goto system settings
2. firewall is not displayed

[Regression Potential]
None. Just updating the desktop file so it can display in GNOME.

ProblemType: BugDistroRelease: Ubuntu 12.10
Package: gufw (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Sat Oct 27 08:27:03 2012
InstallationDate: Installed on 2012-09-23 (33 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
MarkForUpload: TrueSourcePackage: gui-ufw
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tim (darkxst) wrote :
Tim (darkxst) on 2012-10-26
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gui-ufw (Ubuntu):
status: New → Confirmed
costales (costales) wrote :

What about Kubuntu? I'm using Xubuntu and the entry appears in the menu.

Changed in gui-ufw:
status: New → Confirmed
costales (costales) wrote :

As Gufw developer I confirm Tim's branch is OK. Thanks Tim! ;D
@Devid: Do I need to do something?

dino99 (9d9) on 2012-10-27
tags: added: i386
Jeremy Bicha (jbicha) wrote :

Why not just drop the OnlyShowIn: line? Unless a program actually conflicts with another program or is desktop-specific (such as gcalctool or kcalc), I think the OnlyShowIn line is just annoying.

Tim (darkxst) wrote :

jbicha, yes seems reasonable, have updated branch.

Joel Peláez Jorge (joelpelaez) wrote :

Please check this diff file. Remove OnlyShowIn line and move Gufw from Other to System in GNOME Panel Settings.

The attachment "gufw.desktop patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Yes I did remove the onlyShowIn line, maybe the merge
Request didn't pick that up. I will make the other change when I get back on tuesday.

--
Tim

On Saturday, 3 November 2012 at 8:46 AM, Joel Peláez Jorge wrote:

> Please check this diff file. Remove OnlyShowIn line and move Gufw from
> Other to System in GNOME Panel Settings.
>
> ** Patch added: "gufw.desktop patch"
> https://bugs.launchpad.net/ubuntu/+source/gui-ufw/+bug/1071915/+attachment/3422073/+files/gufw.desktop.diff
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1071915
>
> Title:
> gufw is not displayed under GNOME session
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gui-ufw/+bug/1071915/+subscriptions
>
>

costales (costales) on 2012-11-17
Changed in gui-ufw:
assignee: nobody → manish wadhwani (manishwr)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gui-ufw - 12.10.0-1ubuntu1

---------------
gui-ufw (12.10.0-1ubuntu1) raring; urgency=low

  * Set to display in GNOME (LP: #1071915)
 -- Tim Lunn <email address hidden> Fri, 23 Nov 2012 19:08:25 +1100

Changed in gui-ufw (Ubuntu):
status: Confirmed → Fix Released

Hello Tim, or anyone else affected,

Accepted gui-ufw into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gui-ufw/12.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gui-ufw (Ubuntu Quantal):
status: New → In Progress
status: In Progress → Fix Committed
tags: added: verification-needed
Tim (darkxst) wrote :

Tested package from quantal-proposed. Gufw is now shown correctly under both Applications and in System Settings.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gui-ufw - 12.10.0-0ubuntu2

---------------
gui-ufw (12.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Set to display in GNOME (LP: #1071915)
 -- Tim Lunn <email address hidden> Fri, 23 Nov 2012 20:25:10 +1100

Changed in gui-ufw (Ubuntu Quantal):
status: Fix Committed → Fix Released
costales (costales) on 2013-01-12
Changed in gui-ufw:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments