guessit FTBFS: Download error on https://pypi.python.org/simple/argparse/

Bug #1473026 reported by Hans Joachim Desserud on 2015-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
guessit (Ubuntu)
Undecided
Unassigned

Bug Description

The latest version of guessit (0.10.3-1) currently fails to build from source on Ubuntu Wily with the following error message:

I: pybuild base:170: python3.4 setup.py test
running test
Searching for argparse
Reading https://pypi.python.org/simple/argparse/
Download error on https://pypi.python.org/simple/argparse/: [Errno 111] Connection refused -- Some packages may not be found!
Couldn't find index page for 'argparse' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
Download error on https://pypi.python.org/simple/: [Errno 111] Connection refused -- Some packages may not be found!
No local packages or download links found for argparse
error: Could not find suitable distribution for Requirement.parse('argparse')
E: pybuild pybuild:256: test: plugin distutils failed with: exit code=1: python3.4 setup.py test
dh_auto_test: pybuild --test -i python{version} -p 3.4 --dir . returned exit code 13
make: *** [build] Error 13
debian/rules:6: recipe for target 'build' failed
dpkg-buildpackage: error: debian/rules build gave error exit status 2

see https://launchpad.net/ubuntu/+source/guessit/0.10.3-1/+build/7430740/+files/buildlog_ubuntu-wily-amd64.guessit_0.10.3-1_BUILDING.txt.gz for more details

For some reason, it attempts to pull in an additional dependency which of course fails since the builds are running offline. I investigated this some, and it looks like building the python2 packages runs smoothly, but something fails when it attempts to create the python3 packages.

I set some breakpoints, and was able to trace the problem to a call to self.distribution.fetch_build_eggs() which happens on line 131 in /usr/lib/python3/dist-packages/setuptools/command/test.py. This is easily reproducible by checking out the source code and running `python3.4 setup.py test` in the root directory.

It is not clear to me why it would run fine with python2.7 but attempt to fetch the additional dependency when running with python3. More interesting is that this doesn't fail in my Debian Sid vm, so it looks like an Ubuntu-only issue. Though, the packages I've looked at are all synced unpatched from Debian, so I don't see what caused the difference.

description: updated
Hans Joachim Desserud (hjd) wrote :

Looks like this has been resolved since newer version of guessit has built succesfully on Ubuntu 16.04 and later releases.

Changed in guessit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers