Ubuntu

package libgucharmap7 1:3.0.1-0ubuntu1 failed to install/upgrade: trying to overwrite '/usr/lib/libgucharmap_2_90.so.7.0.0', which is also in package libgucharmap-2-90-7 1:3.1.92-0ubuntu1

Reported by Steve Magoun on 2011-09-19
512
This bug affects 68 people
Affects Status Importance Assigned to Milestone
abiword (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
bluefish (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
gucharmap (Ubuntu)
Critical
Martin Pitt
Oneiric
Critical
Martin Pitt
pyabiword (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
stardict (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Package failed to upgrade during a routine upgrade within update-manager.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: libgucharmap7 1:3.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Mon Sep 19 12:04:50 2011
DuplicateSignature:
 Unpacking replacement libgucharmap7 ...
 dpkg: error processing /var/cache/apt/archives/libgucharmap7_1%3a3.1.92-0ubuntu1_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/libgucharmap_2_90.so.7.0.0', which is also in package libgucharmap-2-90-7 1:3.1.92-0ubuntu1
ErrorMessage: trying to overwrite '/usr/lib/libgucharmap_2_90.so.7.0.0', which is also in package libgucharmap-2-90-7 1:3.1.92-0ubuntu1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
SourcePackage: gucharmap
Title: package libgucharmap7 1:3.0.1-0ubuntu1 failed to install/upgrade: trying to overwrite '/usr/lib/libgucharmap_2_90.so.7.0.0', which is also in package libgucharmap-2-90-7 1:3.1.92-0ubuntu1
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (17 days ago)

Steve Magoun (smagoun) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gucharmap (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-09-19
Changed in gucharmap (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → Martin Pitt (pitti)
milestone: none → ubuntu-11.10-beta-2
Martin Pitt (pitti) wrote :

Adding tasks for the remaining reverse dependencies of the GTK 2 library, which is no more.

Changed in gucharmap (Ubuntu Oneiric):
status: In Progress → Fix Committed
Changed in abiword (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Ah, I'll just put back GTK 2 support for oneiric.

Changed in pyabiword (Ubuntu Oneiric):
status: New → Invalid
Changed in bluefish (Ubuntu Oneiric):
status: New → Invalid
Changed in stardict (Ubuntu Oneiric):
status: New → Invalid
Martin Pitt (pitti) on 2011-09-19
Changed in gucharmap (Ubuntu Oneiric):
status: Fix Committed → In Progress
Martin Pitt (pitti) on 2011-09-19
Changed in abiword (Ubuntu Oneiric):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gucharmap - 1:3.1.92-0ubuntu2

---------------
gucharmap (1:3.1.92-0ubuntu2) oneiric; urgency=low

  * Add 00_put_back_gtk2_support.patch: Put back GTK 2 support for oneiric, to
    avoid introducing NBS and broken rdepends at this point. (LP: #853973)
 -- Martin Pitt <email address hidden> Mon, 19 Sep 2011 19:27:18 +0200

Changed in gucharmap (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.