Please merge guarddog 2.6.0-1 from Debian unstable

Bug #160613 reported by Siegfried Gevatter on 2007-11-06
4
Affects Status Importance Assigned to Milestone
guarddog (Debian)
Fix Released
Unknown
guarddog (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: guarddog

guarddog (2.6.0-1ubuntu1) hardy; urgency=low

  * Merge from debian unstable, changes:
     - Bump standards version to 3.7.2 (no changes)
     - Bump debhelper build dependency to version >>5
     - Fix kde/guarddog.desktop
     - debian/rules: move .desktop file to /usr/share/applications
  * Use dh_icons.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Tue, 06 Nov 2007 23:43:11 +0100

guarddog (2.6.0-1) unstable; urgency=low

  * New upstream release (closes: #426272)
  * Patch for .de translation (thanks to Jens Seidel) (closes: #313762)
  * Swedish (sv) translation from Daniel Nylander (closes: #351116)

 -- Paul Cupis <email address hidden> Sun, 10 Jun 2007 14:29:20 +0100

Changed in guarddog:
assignee: nobody → rainct
importance: Undecided → Wishlist
status: New → In Progress
Siegfried Gevatter (rainct) wrote :

Changed version to hardy... Strange, I was sure I had run «dch -D hardy» :/.

description: updated
Changed in guarddog:
assignee: rainct → nobody
status: In Progress → New
description: updated
Siegfried Gevatter (rainct) wrote :
Luke Yelavich (themuso) wrote :

I get the following build error:

# move desktop file to /usr/share/applications
mv /build/luke/guarddog-2.6.0/debian/guarddog/usr/share/applnk/System/guarddog.desktop \
                /build/luke/guarddog-2.6.0/debian/guarddog/usr/share/applications/
mv: target `/build/luke/guarddog-2.6.0/debian/guarddog/usr/share/applications/' is not a directory: No such file or directory

Please ensure that the package builds successfully in a chroot environment such as pbuilder or sbuild. Please check whether you have missed anything in making the diff, and adjust where necessary. Once you have attached a new debdiff, re-subscribe ubuntu-universe-sponsors.

Changed in guarddog:
assignee: nobody → themuso
status: New → In Progress
assignee: themuso → nobody
status: In Progress → Incomplete
Siegfried Gevatter (rainct) wrote :

(This one should work, but I've not tested it yet. I'll test it this evening and subscribe u-u-s again if it works.)

Changed in guarddog:
assignee: nobody → rainct
status: Incomplete → In Progress
Siegfried Gevatter (rainct) wrote :

Build fine in a hardy pbuilder environment.

Changed in guarddog:
assignee: rainct → nobody
status: In Progress → Confirmed
Cesare Tirabassi (norsetto) wrote :

Since we are working on the .desktop file, it is worth bringing it in line with the current standards. In particular I would:

- change the Comment "Firewall utility" to GenericName
- add a Comment with something like "Set your Firewall"
- remove the SwallowExec and SwallowTitle keys which are deprecated

On the changelog, note that both

 * Use dh_icons.
 * Modify Maintainer value to match the DebianMaintainerField specification.

are remaining Ubuntu changes (even if you changed dh_iconcache to dh_icons, which you should mention).

Once corrected please report these changes to Debian too and resubscribe u-u-s.

Changed in guarddog:
assignee: nobody → rainct
status: Confirmed → Incomplete
Siegfried Gevatter (rainct) wrote :
Changed in guarddog:
status: Unknown → New
Changed in guarddog:
status: Incomplete → Confirmed
Cesare Tirabassi (norsetto) wrote :

Thanks, uploaded.

Changed in guarddog:
assignee: rainct → nobody
status: Confirmed → Fix Committed
Cesare Tirabassi (norsetto) wrote :
Changed in guarddog:
status: Fix Committed → Fix Released
Changed in guarddog:
status: New → Fix Committed
Changed in guarddog:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.