Can't use Ctrl as a modifier key to bring up Guake 0.4.2-7 (Precise)

Bug #939768 reported by komputes on 2012-02-23
This bug affects 7 people
Affects Status Importance Assigned to Milestone
guake (Ubuntu)

Bug Description

I can't use Ctrl+SPACE to bring up Guake's terminal 0.4.2-7 in Precise.

I'm not sure Guake is guilty for this bug, but it would be good to identify the cause so that this can be corrected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: guake 0.4.2-7
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.93-0ubuntu1
Architecture: i386
Date: Thu Feb 23 14:13:31 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120222)
 PATH=(custom, no user)
SourcePackage: guake
UpgradeStatus: No upgrade log present (probably fresh install)

komputes (komputes) wrote :
komputes (komputes) wrote :

This seems to affect Unity 2D as well. When I press SPACE the terminal comes down. I did some tests to see if the Ctrl key was pressed down (hardware) and it is not. I also tried selecting some text and pressing 'c' to see if it would copy, it did not. This appeared after installing yesterday's daily development image, followed by running updates today and then installing guake.

Kevin Hamer (khamer) wrote :

This actually doesn't seem to have anything to do with Space; the bug title should be "Can't use Ctrl as a modifier key to bring up Guake 0.4.2-7" as this same behavior is exhibited when using control with any hotkey in Guake. Again, behavior is that Guake ignores the "Control+" entirely and binds to the hotkey without the modifier.

It does seem to leave other modifiers alone: for example, Ctrl+Alt+P is interpreted as Alt+P instead. I expect this is related to the fact that Control shows up as "Primary" in other hotkey GUIs now.

Kevin Hamer (khamer) wrote :

Workaround - use gconf-editor (or equivalent) to set /apps/guake/keybindings/global/show_hide to "<Control>space" (for example) instead of "<Primary>space".

komputes (komputes) on 2012-03-12
summary: - Can't use Ctrl+SPACE to bring up Guake 0.4.2-7 (Precise)
+ Can't use Ctrl as a modifier key to bring up Guake 0.4.2-7 (Precise)
komputes (komputes) wrote :

Thanks for the workaround Kevin. I have changed the bug subject as suggested. What is yet to do is find out what package is responsible for having changed the hotkey "Control" to "Primary", and then assign the bug to that package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in guake (Ubuntu):
status: New → Confirmed

This bug affected me too, and workaround works, thank you!

crazybyte (vlzoltan) wrote :

Thank you for the workaround Kevin! It got very annoying not being able to use Ctrl+F12 to bring the terminal window up (usual shortcut in my case).

Sparhawk (sparhawkthesecond) wrote :

I see the same bug in Gnome Shell. It certainly worked in a previous version of guake, as I had ctrl+space set up fine before. Also (probably obvious), I think it's an issue in writing the preferences, as my previous ctrl+space binding worked recently, and it was only when I temporarily switched the bind to something else when I realised I couldn't switch it back.

Thanks for the workaround too.

Gage Peterson (justgage) wrote :

This is effecting me too on linux mint 14 (but worked before I updated in linux mint 12) It opens whenever I press space.

Sparhawk (sparhawkthesecond) wrote :

The equivalent fix using gconftool instead of gconf-editor is:
$ gconftool --type string --set /apps/guake/keybindings/global/show_hide "<Control>space"

Luciano Panepucci (lpanebr) wrote :

I tryed:

$ gconftool --type string --set /apps/guake/keybindings/global/show_hide "<Control><Alt>s"
$ gconftool --type string --set /apps/guake/keybindings/global/show_hide "<Alt>s"

Both gave me a keybinding error pop up. I am stuck with "<Shift><Alt>s" that works.

May I ask why this issue is being held back in backlogs for more than two years now?!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers