Restarting gnome-shell renders guake unusable

Bug #848142 reported by John M on 2011-09-12
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
guake (Ubuntu)
Undecided
Unassigned

Bug Description

gnome-shell's extensions system, as well as some of the advanced tweaks, sometimes require restarting the shell (through Alt+F2 r) in order to take effect. If guake was already open when gnome-shell is restarted (whether hidden or not), then guake becomes somehow unusable.

Whatever processes were active in guake's tabs continue without problem, but keyboard shortcuts like moving between tabs are not possible. Also, it's not possible to open new tabs either. Finally, selecting "Quit" from guake's tray icon doesn't have any effect and the only way to end it is by killing it ---which is not so straightforward, since the name of the process is simply "python".

...:~$ uname -rsvpm && lsb_release -rd && apt-cache policy guake
Linux 3.0.0-10-generic #16-Ubuntu SMP Fri Sep 2 18:32:04 UTC 2011 x86_64 x86_64
Description: Ubuntu oneiric (development branch)
Release: 11.10
guake:
  Installed: 0.4.2-5
  Candidate: 0.4.2-5
  Version table:
 *** 0.4.2-5 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: guake 0.4.2-5
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Mon Sep 12 12:02:15 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110829.1)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: guake
UpgradeStatus: No upgrade log present (probably fresh install)

John M (jwmwalrus) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in guake (Ubuntu):
status: New → Confirmed
Daniel Fett (fett-ubuntu) wrote :

The same happens in unity as well.

John M (jwmwalrus) wrote :

@Daniel Fett: At first sight, your comment doesn't seem to make sense. Restarting gnome-shell in unity renders guake unusable?

Because of bug #853582, I installed the proposed gconf (3.2.2-0ubuntu1 ), which seems to have solved guake's problem ---although, funnily, it still doesn't solve bug #853582.

With gconf's update, guake's behavior is consistent through multiple gnome-shell restarts, and even the nautilus action I just added (i.e., guake -tn %f ), works without problem.

Daniel Fett (fett-ubuntu) wrote :

Okay, to clarify: When unity crashes, it renders guake unusable.

John M (jwmwalrus) wrote :

@Daniel Fett: guake's behavior, in relation to gnome-shell, is not because of a crash, but because of a restart of the shell (i.e., something like Alt+F2 followed by "gnome-shell --replace") ---in unity's case, it would be analogous to Alt+F2 followed by "compiz --replace" or something like that. If your case is different, maybe it's a different bug as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers