Ubuntu

guake package does not install gconfig schema

Reported by Peter Lundqvist on 2009-04-25
72
This bug affects 22 people
Affects Status Importance Assigned to Milestone
guake (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Felix Zweig

Bug Description

After installing guake for the first time I get an error and the question "Have you installed guake.schemas properlly?"

Running the following fixes the problem:
  gconftool-2 --install-schema-file=/usr/share/gconf/schemas/guake.schemas

There is a line in the postinst script that does something similar
  gconf-schemas --register guake.schemas

but it seems to not get the job done (I know very little of these tools - which should be apparent by now :) ).

Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and Guake better by reporting this bug.
It has already been a while since you reported this bug. Can you still confirm the problem exists? I can't on Ubuntu 9.10 Alpha 4, with Guake 0.4.0-4, but maybe it is still there on earlier Ubuntu releases.

Changed in guake (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Alessio Treglia (quadrispro) wrote :

I can't reproduce this on Jaunty.

Sense Egbert Hofstede (sense) wrote :

I'm marking this as Fix Released since it seems it was fixed in the update to Jaunty. If you experience the bug, please reopen the report. Thanks for your cooperation.

Changed in guake (Ubuntu):
status: Incomplete → Fix Released
Brian Snipes (cbsnipes) wrote :

Not sure if the proper thing to do was to change it to New to get it reopened. I just installed guake on Jaunty today and experienced the exact same issue. I am running Jaunty x86_64 and the guake version installed is "Version: 0.3.1-5". Performing the actions from the first comment resolved the issue for me.

Changed in guake (Ubuntu):
status: Fix Released → New
mkluwe (mkluwe) wrote :

I can confirm that the issue still exists (I installed guake ten minutes ago unter Jaunty). I can also conform that the mentioned solution (running »gconftool-2 --install-schema-file=/usr/share/gconf/schemas/guake.schemas«) fixes the problem.

KevinR (kevin-rotz) wrote :

I can confirm this on a fresh install of the 64-bit Karmic Koala today. Running the suggested command fixed it.

Sense Egbert Hofstede (sense) wrote :

After removing Guake thoroughly I had the same experience. Apparently gconf-schemas doesn't do what it should do. I'm investigating the matter further.
This is a packaging mistake.

Changed in guake (Ubuntu):
status: New → Triaged
Sense Egbert Hofstede (sense) wrote :

Although upstream provides a /debian directory for packaging, Ubuntu has a different /debian directory, removing most of the rules file and adding the postrm and postinst files. Maybe we should stick closer to the upstream way since I have the impression from browsing the upstream bug tracker that their way isn't causing problems.

Pavek (avezzandrog) wrote :

I confirm both the bug under ubuntu 9.10 and the solution provided.

Sylvestre Ledru (sylvestre) wrote :

Sense, upstream stopped to provide debian/ directory and the operation works under Debian with the command:
                 gconf-schemas --register guake.schemas > /dev/null
Is ubuntu different here ?

Sense Egbert Hofstede (sense) wrote :

The bug description says the postint in Ubuntu uses 'gconf-schemas --register guake.schemas'.

If it works in Debian, maybe Guake should get a sync/merge request?

Sylvestre Ledru (sylvestre) wrote :

Probably ;)
By the way, you should anyway ask for a sync/merge from Debian. I uploaded a new version of the package and I tried to closed LP bugs in the upload too.

Felix Zweig (f.zweig) wrote :

I can confirm this for Lucid x86_64. True transparency via compiz only works after running said command.

This is *still* a problem on Maverick and the fix from 1 1/2 years ago still solves the problem.

I can confirm this bug in oneiric.

sliksoft (sliksoft) wrote :

This bug affected me on ubuntu 11.10 32-bit. Thanks for the manual fix

maurizio de santis (izietto) wrote :

This bug is still in forces on 12.04

jaduncan (jaduncan) wrote :

Confirmed still on precise as of beta 2.

Changed in guake (Ubuntu):
status: Triaged → Confirmed
Sylvestre Ledru (sylvestre) wrote :

I believe this bug is fixed in the Debian package.
As for a sync from debian => ubuntu if you want the fix.

Sylvestre Ledru (sylvestre) wrote :

-As+Ask

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package guake - 0.4.2-8

---------------
guake (0.4.2-8) unstable; urgency=low

  * No longer include directly glib headers (Closes: #665551)
  * Standards-Version updated to version 3.9.3
  * Improve the install of the schema (LP: #366621)
  * Refresh of some patches
  * Fix debian-rules-uses-deprecated-makefile
  * Fix a bug in the proxy setup (Closes: #631922) (LP: #735706)

 -- Sylvestre Ledru <email address hidden> Sat, 24 Mar 2012 20:27:33 +0100

Changed in guake (Ubuntu):
status: Confirmed → Fix Released
Mohammad Elmi (melmi) wrote :

Fixed? Not sure. I experienced it on 12.10 32bit. The manual fix worked for me.

Neal Daringer (1-neal) wrote :

This bug is still alive and kicking in Ubuntu 13.10 32bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers