Tab freezes when I exit the shell

Bug #1760621 reported by Manuel Vazquez Acosta on 2018-04-02
146
This bug affects 25 people
Affects Status Importance Assigned to Milestone
guake (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to exit a shell (either by pressing Ctrl-D or typing 'exit') guake freezes the tab: it doesn't close it, afterwards several things fail: like trying to open a new tab (Ctrl-Shift-T), copying and pasting, etc...

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: guake 3.0.5-1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 2 10:42:24 2018
InstallationDate: Installed on 2018-04-02 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180315)
PackageArchitecture: all
SourcePackage: guake
UpgradeStatus: No upgrade log present (probably fresh install)

Manuel Vazquez Acosta (mva-led) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in guake (Ubuntu):
status: New → Confirmed
Raül Cambeiro (raulcambeiro) wrote :

This has already been fixed upstream. It's a Python indenting issue.
https://github.com/Guake/guake/commit/f8699b4be6c058fd58a33a1d783cd404e9076b0e

In current 18.04 package (guake 3.0.5-1), it's this file (line 1420):
/usr/lib/python3/dist-packages/guake/guake_app.py

I confirm that the solution pointed out by Raül Cambeiro worked for me.

Chris Kankiewicz (phlak) wrote :

I can confirm the fix in #3 works. Thanks Raül!

flan_suse (flansuse) wrote :

So this fix will never make it to the Ubuntu 18.04 repositories? It was applied a long time ago upstream, yet the latest version in the 3.0.x series is 3.0.5, which contains the bug. According to Ubuntu's package update policies, 18.04 users will forever be stuck with 3.0.x. There is no version 3.0.6 which contains the upstream fix that is available on the 18.04 repositories.

flan_suse (flansuse) wrote :

The 18.10 repositories already provide Guake 3.3.0:

https://packages.ubuntu.com/cosmic/guake

I truly believe 18.04 LTS users are stuck with the buggy Guake version 3.0.5, unless there is a 3.0.6 release. Most end-users will not know to hunt for this bug, nor how to fix it manually by editing a *.py file. In fact, it was hard enough for me to find this bug since I did not know exactly what to search for. After multiple attempts, I finally used found this bug report.

Can there the fix be backported and released as version 3.0.6?

Rayner Pires (raynermp) wrote :

I confirm that the solution pointed out by Raül Cambeiro (comment #3) worked for me too.

Taylor Raack (track16) wrote :

I second flan_suse's comment; having a backport of this bug to the Ubuntu repositories seems like the right thing to do. I'd be happy to get involved to help, but I've never contributed a Ubuntu patch before, so I'd need quite a bit of handholding to move forward. Is there someone on the Guake maintainer team who could give me some pointers?

Serge (sdolgikh21) wrote :

I doubt this package is still maintained. This bug was opened in april, it's VERY critical (in fact, it makes Guake unusable) but nobody cares.

And if you look at this page: https://bugs.launchpad.net/ubuntu/+source/guake this critical bug is located in the bottom of this list, which definitely shows us how defected launchpad bugtracker is.

If you look for the mentor then you must know maintainers of Guake is not a good choice. I'm sure they even didn't do basic smoke tests for this package before releasing a new version. They'll teach you some bad habbits.

Best option for you is to download source package of this and apply manual patch to fix all issues (crash on closing tabs, unresizable window, etc)

CrazySky (makarovdenis11) wrote :

+1 fix works by Raül Cambeiro

Pebas (pebasmisc) wrote :

If you look at this ticket on github about this bug (https://github.com/Guake/guake/issues/1198) most people fix this by installing libutempter0 on Ubuntu 18.04. This library is not set as a dependency of guake. I wonder if it sholud be.

Anyway, I tried it and it works perfectly well for me too.

Sam Van den Eynde (samvde) wrote :

Fixed by comment #3

Jakub Kubień (kecalcze) wrote :

Fixed by comment #3

Fernando Parreira (fparreira) wrote :

The solution found by Raül worked for me. Thanks Raül.

Rohit (rohit-s) wrote :

Raül Cambeiro's fix worked for me as well on Ubuntu 18.04.1 with Guake Terminal 3.0.5.

Yuki (yuki64) wrote :

I fixed this bug in this way.

$ sudo apt-get install libutempter0

Yuki (yuki64) wrote :

Sorry, I comment #17 before try #3. Fixed by comment #3 too.

Almaron (almaron) wrote :

Great fix Raul! How do I implement it?

Adam Yang (adamyang) wrote :

@Daniel Echeverry or @epsilon77 , would you please update the bionic package to 3.0.6 since this issue is fixed in 3.0.6. See the following links for references.

https://github.com/Guake/guake/tree/3.0.6
https://github.com/Guake/guake/pull/1490#issuecomment-455819142

Gaetan Semet (gaetan-xeberon) wrote :

Hi. I am the maintainer of Guake. I try to fix bugs on HEAD as much as possible and I have very good contributors that fixes bugs or even adds new features. But I do not maintain backport, since the paste version is itself backward compatible up to Ubuntu 16.04.
So in short, latest version of Guake can be installed on any Ubuntu since 16.04. That’s the way Guake is developped.
And yes since 3.x libtempter0 is a mandatory dependency.

max ulidtko (ulidtko) wrote :

> I doubt this package is still maintained.

You shouldn't, as it is quite actively maintained.
Here's a 1-click check of that for you: https://github.com/Guake/guake/pulse

We don't actively monitor distribution support though, and are not really familiar with various package update policies.

In particular, as Gaetan said just above, we don't usually do any backports -- because the mainline (master branch) version supports Ubuntu back to 16.04.

So until someone like @adamyang pokes us, we might even *not be aware* that there're major issues with the version distributed in repositories.

To spare more word fight, let's just note this fact:
https://github.com/Guake/guake/releases/tag/3.0.6
Guake version 3.0.6 has been released, already a month ago.

Can someone PLEASE REBUILD and reupload a 3.0.6 package instead of the defective 3.0.5?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.