gtwitter computes times as if local clock is set to UTC

Bug #201766 reported by Mary Gardiner
2
Affects Status Importance Assigned to Milestone
gtwitter (Debian)
Fix Released
Unknown
gtwitter (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gtwitter

Recent twitter posts show up in gTwitter with my UTC offset added to them. A post I make was immediately posted "about 11 hours ago" (I am UTC+11). A post an hour old was posted "about 12 hours ago", and so on. (Goodness knows what happens with someone who is behind UTC, as it will think recent posts are from the future.)

For information, my system is set to use local time on the hardware clock, not UTC.

$ cat /etc/adjtime
-0.157515 1205406294 0.000000
1205406294
LOCAL

This is a regression from the Gutsy version.

Package: 1.0~beta-6ubuntu1

Revision history for this message
CafeNinja (cafeninja) wrote :

I can confirm this behavior for myself at GMT+2 and all posts in twitter are listed as "about 2 hours ago". On my Gutsy 7.10 system, the exact same post appears with "2 minutes ago".

What is Hardy doing different than Gutsy for time?

Revision history for this message
CafeNinja (cafeninja) wrote :

Output of lsb_release and adjtime from system with gtwitter (current version) showing correct time for the posts.

~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.10
Release: 7.10
Codename: gutsy

~$ cat /etc/adjtime
1.296468 1208736310 0.000000
1208736310
UTC

Revision history for this message
CafeNinja (cafeninja) wrote :

After making adjustment in timezone (something wrong and back to correct Europe/Rome) then I have these differences between my Gutsy system and Hardy system:

============Gutsy==============
:~$ cat /etc/adjtime
1.296468 1208736310 0.000000
1208736310
UTC

:~$ cat /etc/timezone
User defined

============Hardy===============
:~$ cat /etc/adjtime
1.684428 1209233679 0.000000
1209233679
UTC

:~$ cat /etc/timezone
Europe/Rome

Problem still persists.

Revision history for this message
Hidetomo Hosono (h12o) wrote :

It is also reported on the Debian BTS, #479348.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=479348

It seems to be an upstream bug.

If gTwitter is executed with the line:
> env TZ=JST gtwitter
it shows the right times.

Revision history for this message
AndyGoh (hantuvii) wrote :

I can confirm the bug as well.

LSB output:

:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

Timezone:

:~$ cat /etc/timezone
Australia/Melbourne

Revision history for this message
CafeNinja (cafeninja) wrote :

HOSONO: I can confirm that the environment setting issued with the application does resolve the time issue. I find that to be an acceptable solution to my issue. I have modified my session start command and it has resolved the time of post issue. Thank you for your help.

Changed in gtwitter:
status: Unknown → New
Daniel T Chen (crimsun)
Changed in gtwitter:
importance: Undecided → Low
status: New → Confirmed
Changed in gtwitter (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.