missing .desktop file in no icon for gtweakui

Bug #243545 reported by ajmal_82 on 2008-06-27
8
Affects Status Importance Assigned to Milestone
gtweakui (Ubuntu)
Low
Harald Sitter

Bug Description

These application "gtweakui-nautilus,gtweakui-sessions,gtweakui-menus doesnt have icons to put onto desktop.i was asked to report missing .desktop file by the developers on brainstorm.so please make icons for these.i reported for these in combination because they sound similar,and forgive the title.
thanks

Related branches

Ralph Janke (txwikinger) wrote :

I can confirm this by looking in the sources.

gtweakui-galeon.desktop has the icon /usr/share/gTweakUI/g.png configured.

The desktop files gtweakui-menus.desktop, gtweakui-nautilus.desktop, and gtweakui-session.desktop have no icon configured.

Changed in gtweakui:
status: New → Triaged
Changed in gtweakui:
assignee: nobody → nhandler
status: Triaged → In Progress
Nathan Handler (nhandler) wrote :

gtweakui (0.4.0-2ubuntu2) intrepid; urgency=low

  * gtweakui-{menus,nautilus,session}.desktop
    - Set /usr/share/gTweakUI/g.png as Icon (LP: #243545)
  * gtweakui-{galeon,menus,nautilus,session}.desktop
    - Modify to validate with desktop-file-validate

 -- Nathan Handler <email address hidden> Sun, 29 Jun 2008 11:32:05 -0500

Changed in gtweakui:
assignee: nhandler → nobody
status: In Progress → Confirmed
Changed in gtweakui:
assignee: nobody → dktrkranz
status: Confirmed → In Progress
Luca Falavigna (dktrkranz) wrote :

/usr/share/gTweakUI/g.png does not exists, did you mean /usr/share/gtweakui/g.png instead?

Changed in gtweakui:
assignee: dktrkranz → nhandler
Nathan Handler (nhandler) wrote :

You are correct Luca. The Icon should be /usr/share/gtweakui/g.png. However, it looks like /usr/share/gTweakUI/g.png also works. When you build and install the deb, it displays the appropriate icon. Either way, here is a new debdiff that sets the correct path to the icon.

gtweakui (0.4.0-2ubuntu2) intrepid; urgency=low

  * gtweakui-{menus,nautilus,session}.desktop
    - Set /usr/share/gtweakui/g.png as Icon (LP: #243545)
  * gtweakui-{galeon,menus,nautilus,session}.desktop
    - Modify to validate with desktop-file-validate

 -- Nathan Handler <email address hidden> Sat, 26 Jul 2008 08:05:32 -0500

Nathan Handler (nhandler) wrote :

I forgot to fix gtweakui-galeon.desktop in the previous patch.

gtweakui (0.4.0-2ubuntu2) intrepid; urgency=low

  * gtweakui-{galeon,menus,nautilus,session}.desktop
    - Set /usr/share/gtweakui/g.png as Icon (LP: #243545)
    - Modify to validate with desktop-file-validate

 -- Nathan Handler <email address hidden> Sat, 26 Jul 2008 08:13:30 -0500

Changed in gtweakui:
assignee: nhandler → nobody
status: In Progress → Confirmed
Harald Sitter (apachelogger) wrote :

Please make the

Harald Sitter (apachelogger) wrote :

...se changes in a patch.

Unsubscribing Ubuntu Sponsors for universe for now.

Nathan Handler (nhandler) wrote :

gtweakui currently does not have a patch system implemented. I know that this topic has been recently discussed on the mailing lists. Was a consensus ever reached? I know that we are meant to use patches to modify files outside of the debian directory, but it seems kind of pointless to add a patch system for a patch as simple as this one. It also would create a much larger diff between the Ubuntu and Debian versions.

Harald Sitter (apachelogger) wrote :

The diff to Debian might be bigger. But, patches are easier to maintain, especially if Debian doesn't have a patch system in their package at all.

Nathan Handler (nhandler) wrote :

gtweakui (0.4.0-2ubuntu2) intrepid; urgency=low

  * Add dpatch patch system
    - Add 01_desktop-files.dpatch (LP: #243545)

 -- Nathan Handler <email address hidden> Sat, 06 Sep 2008 21:33:43 -0500

Changed in gtweakui:
assignee: nobody → apachelogger
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtweakui - 0.4.0-2ubuntu2

---------------
gtweakui (0.4.0-2ubuntu2) intrepid; urgency=low

  [ Nathan Handler ]
  * Add dpatch patch system
    - Add 01_desktop-files.dpatch (LP: #243545)

  [ Harald Sitter ]
  * Add the changes from 0.4.0-2ubuntu1 to 01_desktop-files.dpatch

 -- Nathan Handler <email address hidden> Sat, 06 Sep 2008 21:33:43 -0500

Changed in gtweakui:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers