Ubuntu

gedit crashed with SIGABRT: (g_slist_length (ce->priv->invalid) <= 1)

Reported by kyleabaker on 2012-01-12
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gtksourceview3 (Ubuntu)
Medium
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
gedit:
  Installed: 3.3.2-0ubuntu1
  Candidate: 3.3.2-0ubuntu1
  Version table:
 *** 3.3.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gedit 3.3.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Wed Jan 11 22:19:07 2012
ExecutablePath: /usr/bin/gedit
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcCmdline: gedit /home/User Name/Downloads/monster/persona.ini
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: gedit
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libgtksourceview-3.0.so.0
Title: gedit crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-01-12 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

kyleabaker (kyleabaker) wrote :

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7fa119feb7d9 "update_syntax", message=0x11cd070 "assertion failed: (g_slist_length (ce->priv->invalid) <= 1)") at /build/buildd/glib2.0-2.31.8/./glib/gtestutils.c:1860
 g_assertion_message_expr (domain=0x7fa119fec216 "GtkSourceView", file=0x7fa119fea791 "gtksourcecontextengine.c", line=5595, func=0x7fa119feb7d9 "update_syntax", expr=<optimized out>) at /build/buildd/glib2.0-2.31.8/./glib/gtestutils.c:1871
 update_syntax (ce=0xff62c0, end=0x0, time=10) at gtksourcecontextengine.c:5595
 first_update_callback (ce=0xff62c0) at gtksourcecontextengine.c:2390
 gdk_threads_dispatch (data=<optimized out>) at /build/buildd/gtk+3.0-3.3.6/./gdk/gdk.c:745

Changed in gedit (Ubuntu):
importance: Undecided → Medium
summary: - gedit crashed with SIGABRT in raise()
+ gedit crashed with SIGABRT in g_assertion_message()
tags: removed: need-amd64-retrace
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

summary: - gedit crashed with SIGABRT in g_assertion_message()
+ gedit crashed with SIGABRT: (g_slist_length (ce->priv->invalid) <= 1)
visibility: private → public
Changed in gedit (Ubuntu):
status: New → Incomplete
affects: gedit (Ubuntu) → gtksourceview3 (Ubuntu)
Launchpad Janitor (janitor) wrote :

[Expired for gtksourceview3 (Ubuntu) because there has been no activity for 60 days.]

Changed in gtksourceview3 (Ubuntu):
status: Incomplete → Expired
Changed in gtksourceview3 (Ubuntu):
status: Expired → Triaged
status: Triaged → Invalid
KillaW0lf04 (michaelaquilina) wrote :

Hi, i can consistently reproduce this with a file. I would prefer not to share this publicly as it is a personal file but maybe you could tell me what i could look out for within its content?

Richard Eames (naddiseo) wrote :
Richard Eames (naddiseo) wrote :
Changed in gtksourceview3 (Ubuntu):
status: Invalid → New
Richard Eames (naddiseo) wrote :

I ran into this bug today. It happened when I dragged the attached file from nautilus to gedit over an sftp connection. The strange thing is if I created a new file, and c&p the contents from "recovery.html" to the new file, then dragged it to gedit it didn't crash, I'm guessing due to file endings. Dragging/opening it from a local filesystem worked.

gedit:
  Installed: 3.6.2-0ubuntu1
  Candidate: 3.6.2-0ubuntu1
  Version table:
 *** 3.6.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Anthony Borrow (arborrow) wrote :

gedit version.php
**
GtkSourceView:ERROR:gtksourcecontextengine.c:5520:update_syntax: assertion failed: (g_slist_length (ce->priv->invalid) <= 1)
Aborted

I had a file that would not open and I was getting this error. Perhaps having a file to test against will help resolve this issue. If I can be of any help just let me know. Peace - Anthony

Anthony Borrow (arborrow) wrote :

Just a quick followup, when I did cat version.php I received the following as the first line:



Marwane K. (marwane-ka) wrote :

I confirm that the BOM character crashes Gedit, removing it puts everthing back in order (an easy way is to recreate the file by copy/pasting the file contents with another editor, in my case Geany).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtksourceview3 (Ubuntu):
status: New → Confirmed

I don't have to open any file, and then it closes. Almost impossible to work.

But I do have a dashboard plugin that opens the it starts.

    gedit > ../log.txt 2>../err.txt

err.txt

Traceback (most recent call last):
  File "/usr/lib/gedit/plugins/sessionsaver/__init__.py", line 67, in do_activate
    self._insert_menu()
  File "/usr/lib/gedit/plugins/sessionsaver/__init__.py", line 118, in _insert_menu
    self._update_session_menu()
  File "/usr/lib/gedit/plugins/sessionsaver/__init__.py", line 84, in _update_session_menu
    _("Recover '%s' session") % session.name,
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 14: ordinal not in range(128)

(gedit:7720): Gtk-CRITICAL **: gtk_list_store_set_column_types: assertion `priv->columns_dirty == 0' failed

(gedit:7720): Gtk-CRITICAL **: gtk_window_set_default: assertion `gtk_widget_get_can_default (default_widget)' failed

(gedit:7720): Gtk-CRITICAL **: gtk_text_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
**
GtkSourceView:ERROR:gtksourcecontextengine.c:5586:update_syntax: assertion failed: (g_slist_length (ce->priv->invalid) <= 1)

If I open a text file gedit somelife.txt, it starts ok.

When I disabled the 'dashboard' plugin, it starts all right.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers