Perl highlighting incorrect

Bug #178746 reported by Jeffrey Ratcliffe on 2007-12-26
6
Affects Status Importance Assigned to Milestone
GtkSourceView
Fix Released
Medium
gtksourceview2 (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

In the following example, gedit marks everything after the first ( to the end of the file in pink:

system(q("()\n" ));

If you remove the innermost (), the highlighting is correct.

Should have noted that I am using Gutsy, i.e. gedit 2.20.3

Pedro Villavicencio (pedro) wrote :

Confirmed, thanks for your report.

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=507075

Changed in gtksourceview:
status: Unknown → New
Changed in gtksourceview:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in gtksourceview2:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version is in intrepid

Changed in gtksourceview2:
status: Fix Committed → Fix Released
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gtksourceview2:
status: Confirmed → Fix Committed

2008/7/9 Martin Pitt <email address hidden>:
> Accepted into -proposed, please test and give feedback here. Please see
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!

I'll do my best to do this in the mean time, but Real Life means I
probably won't have time for the next couple of weeks.

2008/7/9 Martin Pitt <email address hidden>:
> Accepted into -proposed, please test and give feedback here. Please see
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!

Upgrading libgtksourceview did not solve the problem, but
libgtksourceview-common did.

Another highlighting error has now popped up, though. Do you want me
to file a new bug for this?

Martin Pitt (pitti) wrote :

Jeffrey Ratcliffe [2008-07-12 11:58 -0000]:
> Another highlighting error has now popped up, though. Do you want me
> to file a new bug for this?

Please do, and please add the bug # here. Did that occur before, or
was it a regression which came with this update?

Thanks, Martin

2008/7/13 Martin Pitt <email address hidden>:
> Please do, and please add the bug # here. Did that occur before, or
> was it a regression which came with this update?

#247877

I can't tell without reinstalling the old version because this bug was
hiding the new one.

Regards

Jeff

Tim Caswell (tim-creationix) wrote :

I still have the old version and I can confirm that it's not a regression, the other bug was there before the upgrade.

After installing the proposed update and restarting gedit, the first bug (178746) is fixed, but the other (247877) is still not fixed.

Pedro Villavicencio (pedro) wrote :

verification done:

- test with gtksourceview 2.2.1-1, after open gedit and type the example, gedit marks everything after the first ( as pink which is incorrect, the issue is solved if you removed the innermost ().
- test with gtksourceview 2.2.2-0ubuntu1, after open gedit and type the example, the gedit highlight is now correct, the bug is fixed, thanks.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gtksourceview2:
status: Fix Committed → Fix Released
Changed in gtksourceview:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.