gtkpod crashed with signal 5 in g_settings_bind_with_mapping()

Bug #945727 reported by Koen Kaldenberg
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gtkpod (Ubuntu)
Undecided
Unassigned

Bug Description

crashed while reading my ipod classic

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gtkpod 2.1.1-1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Sat Mar 3 18:38:30 2012
ExecutablePath: /usr/bin/gtkpod
InstallationMedia: Ubuntu-Studio 12.04 "Precise Pangolin" - Beta amd64 (20120228.1)
ProcCmdline: gtkpod
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gtkpod
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_settings_bind_with_mapping () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_settings_bind () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 anjuta_preferences_register_property () from /usr/lib/libanjuta-3.so.0
Title: gtkpod crashed with signal 5 in g_settings_bind_with_mapping()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Koen Kaldenberg (koen-fietst) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? () at /build/buildd/glib2.0-2.31.20/./gio/gsettingsschema.c:676 from /tmp/tmpBm0MKi/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? ()
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gtkpod (Ubuntu):
status: New → Invalid
Revision history for this message
Apport retracing service (apport) wrote : Crash report cannot be processed

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

fontconfig version 2.8.0-3ubuntu5 required, but 2.8.0-3ubuntu6 is available
libgtk-3-common version 3.3.16-0ubuntu1 required, but 3.3.18-0ubuntu1 is available
libfontconfig1 version 2.8.0-3ubuntu5 required, but 2.8.0-3ubuntu6 is available
libxcb-shm0 version 1.8-2 required, but 1.8-2ubuntu1 is available
glib-networking version 2.31.16-0ubuntu2 required, but 2.31.20-0ubuntu1 is available
libgail-3-0 version 3.3.16-0ubuntu1 required, but 3.3.18-0ubuntu1 is available
libselinux1 version 2.1.0-4ubuntu1 required, but 2.1.0-4.1ubuntu1 is available
libxcb-render0 version 1.8-2 required, but 1.8-2ubuntu1 is available
glib-networking-common version 2.31.16-0ubuntu2 required, but 2.31.20-0ubuntu1 is available
fontconfig-config version 2.8.0-3ubuntu5 required, but 2.8.0-3ubuntu6 is available
libglib2.0-0 version 2.31.18-0ubuntu2 required, but 2.31.20-0ubuntu1 is available
libxcb1 version 1.8-2 required, but 1.8-2ubuntu1 is available
libanjuta-3-0 version 2:3.3.90-0ubuntu1 required, but 2:3.3.91-0ubuntu1 is available
libcups2 version 1.5.2-5 required, but 1.5.2-6 is available
libc-bin version 2.15-0ubuntu3 required, but 2.15-0ubuntu4 is available
glib-networking-services version 2.31.16-0ubuntu2 required, but 2.31.20-0ubuntu1 is available
libatk1.0-0 version 2.3.3-0ubuntu1 required, but 2.3.91-0ubuntu1 is available
libgtk-3-0 version 3.3.16-0ubuntu1 required, but 3.3.18-0ubuntu1 is available
libatk1.0-data version 2.3.3-0ubuntu1 required, but 2.3.91-0ubuntu1 is available
multiarch-support version 2.15-0ubuntu3 required, but 2.15-0ubuntu4 is available
anjuta-common version 2:3.3.90-0ubuntu1 required, but 2:3.3.91-0ubuntu1 is available
libc6 version 2.15-0ubuntu3 required, but 2.15-0ubuntu4 is available
libsoup2.4-1 version 2.37.90-0ubuntu1 required, but 2.37.91-0ubuntu1 is available

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
Revision history for this message
Martin Pool (mbp) wrote :

reproduced with current precise.

Changed in gtkpod (Ubuntu):
status: Invalid → Triaged
status: Triaged → Confirmed
visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers