cannot add m4a files

Bug #883962 reported by Алексей
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gtkpod (Ubuntu)

Bug Description

When trying to add m4a files gtkpod sais it does not regognize them.
Natty version worked fine.
Using Kubuntu Oneiric.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtkpod (Ubuntu):
status: New → Confirmed
Revision history for this message
Piotr Kęplicz (keplicz) wrote :

It seems that the gtkpod 1.0 from natty used a libmp4v2 library in order to process M4A files. The newer version doesn't nor is libmp4v2 available.

Downgrading gtkpod using gtkpod, gtkpod-data, libgpod4 and libmp4v2-0 packages from natty seems to do the trick.

Revision history for this message
Spam Jim (spamjim) wrote :

I found some success with this alternate PPA for gtkpod and libmp4v2

Because Ubuntu updates/upgrades have messed with ipod compatibility in the past, I also use some commercial apps from the Apple appstore to manage media on my 2nd gen iPod touch. For podcasts, I have used Instacast but now use Downcast. Both of these can download new episodes via wi-fi. For music and video files, I use Files Pro, which lets me mount a webdav location in Ubuntu. I rarely connect my ipod and computer by cable anymore unless I need to manage playlists.

Revision history for this message
carlosv (cvedovatti) wrote :

I try the forage PPA but id doesnt work properly. I try to add MP4 and M4V format (converted by Arista) and it adds the files but on the my IPOD 5.5, recognized them as music, not as video. I had to purge the PPA.

Revision history for this message
Exeleration-G (exeleration-g) wrote :

Still a problem in Ubuntu 12.04, Banshee 2.4.0

Revision history for this message
Charlie Shaw (n2924-dotcom) wrote :

Seeing same problem with gtkpod 2.1.0 installed on Ubuntu 11.10 and gtkpod 2.1.2 on Lubuntu 12.10; trying to load data to an old iPod Photo

Just before the error dialogue re .m4a files not being recognized, there is a couple of errors reported related to trying to write to the users home directory (eg /home/user ) and 'user.ext'.

gtkpod also does not seem to be consistent in terms of the how/when/if it recognizes the mounted / loaded iPod; dmesg contains complaints about sending ioctl 2285 to a partition.

Fix described above by keplicz works for me on the Lubuntu system (not yet tried the 11.10 machine).

NOTE: you need ensure that whatever programme is creating the .m4a files, the mp3/mp4 'tag fields' are populated with artist name, track etc (not sure what the minimum requirement is).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.