gtkpod hangs on attempt to sync contacts

Bug #681249 reported by Michael Hendry on 2010-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtkpod (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gtkpod

Description: Ubuntu 10.04.1 LTS
Release: 10.04

gtkpod 0.99.14

iPod Classic 160GB

I have edited /usr/share/gtkpod/sync-evolution.sh so that it refers to my iPod's mount point, and have confirmed that this works correctly when run directly from the command-line.

I have set up Edit=>Repository/iPod Options to point Calendar sync command to this script, but when I try to synchronise the contacts list using Tools=>Synchronize Contacts, gktpod hangs.

Michael Hendry (hendry-michael) wrote :

In the hope that my problem would have been solved in a later version, I downloaded the source for 1.0.0, and compiled and installed it.

Unfortunately the same problem is there - attempts to call the various "sync" commands all cause the program to hang, although the synchronisation works fine if the commands are run from a command-line.

In an attempt to track down what's going on, I've tried running gtkpod from the command line and watching the error messages come up on the terminal, or sending them to a file.

The file resulting from starting gtkpod and then plugging in my iPod Classic 160GB is > 160,000 lines long, although much of it is made up of the following two lines...

** (gtkpod:3524): CRITICAL **: file /build/buildd/libgpod-0.7.93/src/itdb_playlist.c: line 497 (itdb_splr_eval): should not be reached

** (gtkpod:3524): WARNING **: Unknown action type 1

...so I may have some difficulty in seeing the wood for the trees as I try to fix it!

Michael Hendry (hendry-michael) wrote :

I've just realised that it's necessary to prefix "sh " to the command line to ensure that the synchronisation script is called.

There's still one problem in this part of the setup - gtkpod "forgets" the sync commands when it's shut down and replaces them with the default values the next time I insert my iPod.

Michael Hendry (hendry-michael) wrote :

Further investigation reveals that there is a file stored on the iPod (in my case in /media/Michael%20HEN/iPod_Control/iTunes/gtkpod.prefs) when it is first set up to work with gtkpod, and which isn't changed in line with subsequent changes made in Edit=>Repository/iPod Options.

I edited the .../gtkpod.prefs directly with gVim, and all now appears to be behaving the way I want it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers