Evolution freezes when you try to change the font colour

Bug #1003884 reported by Kim d'Audretsch on 2012-05-24
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
gtkhtml4.0 (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

[Impact]
Evolution becomes unresponsive due to GtkHtml not ungrabbing input; this may also affect other applications. When using HTML editing, changing font color or adding emoticons causes the input to be grabbed and never released.

[Test Case]
1) Open Evolution
2) Compose a new message (Click the "New" button at the left of the toolbar)
3) Switch to HTML mode if necessary using the combo box at the bottom left of the message header.
4) Change font color.

[Regression Potential]
Potential regression scenarios include issues with editing messages as HTML; including how the message will be formatted when received or whether other parts of the message composer UI become unresponsive or don't appear to produce results.

---
When I make a new email in evolution and select the text and change the font colour Evolution freezes. If you try to close the window you get a pop up menu but its impossible to press the buttons.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evolution 3.2.3-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Thu May 24 13:01:19 2012
EcryptfsInUse: Yes
SourcePackage: evolution
UpgradeStatus: Upgraded to precise on 2011-10-13 (223 days ago)

Kim d'Audretsch (kimda) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Jonathan Ernst (jonathan.ernst) wrote :

Link to (fixed) upstream bug (the other one has been marked as a duplicate)

Changed in evolution:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in evolution (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Changed in evolution (Ubuntu):
importance: Undecided → Medium
Changed in evolution (Ubuntu Precise):
status: Confirmed → Triaged
Changed in evolution (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in evolution (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Fixed in Quantal; I uploaded a new gtkhtml with a patch from upstream. It still need to be applied the same patch as SRU for Precise.

affects: evolution (Ubuntu) → gtkhtml4.0 (Ubuntu)
Changed in gtkhtml4.0 (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
status: In Progress → Fix Released
Seby Carta (sebycarta) wrote :

" It still need to be applied the same patch as SRU for Precise."

When it will be fixed for precise?

Soon ;)

description: updated
Changed in gtkhtml4.0 (Ubuntu Precise):
status: Triaged → In Progress

Uploaded to precise-proposed, waiting in the queue for review by the SRU team.

Changed in gtkhtml4.0 (Ubuntu Precise):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody

Hello Kim, or anyone else affected,

Accepted gtkhtml4.0 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtkhtml4.0/4.2.2-1ubuntu1.2 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtkhtml4.0 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Hi Brian,

Will try this today. Thank you!

On Sat, Jun 30, 2012 at 1:04 AM, Brian Murray <email address hidden> wrote:

> Hello Kim, or anyone else affected,
>
> Accepted gtkhtml4.0 into precise-proposed. The package will build now
> and be available at
> http://launchpad.net/ubuntu/+source/gtkhtml4.0/4.2.2-1ubuntu1.2 in a few
> hours and then in the -proposed repository. Please help us by testing
> this new package. See https://wiki.ubuntu.com/Testing/EnableProposed
> for documentation on how to enable and use -proposed. Your feedback will
> aid us getting this update out to other Ubuntu users.
>
> If this package fixes the bug for you please change the bug tag from
> verification-needed to verification-done. If it does not, change the
> tag to verification-failed. In either case details of your testing will
> help us make a better decision. Further information regarding the
> verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: gtkhtml4.0 (Ubuntu Precise)
> Status: In Progress => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1003884
>
> Title:
> Evolution freezes when you try to change the font colour
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evolution/+bug/1003884/+subscriptions
>

--
Best regards,

Kim

Kim d'Audretsch (kimda) wrote :

Hi Brian,

I've installed the package and now evolution doesn't crash anymore. Unfortunately I couldn't install only your packages because it wanted to remove evolution so I had to upgrade more packages of proposed.

Kim d'Audretsch (kimda) wrote :

verification-done

tags: added: verification-done
removed: verification-needed
Jane Atkinson (irihapeti) wrote :

I can confirm that the fix works.

Rajesh VP (rjsvp7) wrote :

I just now installed evolution and is experiencing the same issue. All the software in my Ubuntun 12.04 is up-to-date and evolution is installed just now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtkhtml4.0 - 4.2.2-1ubuntu1.2

---------------
gtkhtml4.0 (4.2.2-1ubuntu1.2) precise-proposed; urgency=low

  * debian/patches/fix-keybord-mouse-grab.patch: unbreak keyboard and mouse
    grab after using the font color or emoticon buttons when composing messages
    in HTML mode. (LP: #1003884, #1010692)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 26 Jun 2012 18:22:48 -0400

Changed in gtkhtml4.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
Alonso Murillo (alonsomm2000) wrote :

My system does have gtkhtml4.0-4.2.2-1ubuntu1.2 and does work when change font color but as soon as you change:
Font size
Paragraph style

The KEYBOARD STOP RESPONDING on Evolution until you close the message, after that keyboard start working again.

Is there a way to fix this, it is very annoying on such a great program.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.