ghc library packages all have bad dependencies

Bug #129050 reported by Ralf Nieuwenhuijsen
30
Affects Status Importance Assigned to Milestone
gtk2hs (Ubuntu)
Fix Released
Medium
Michael Bienia

Bug Description

Binary package hint: ghc6

All GHC6 library packages have these two incompatible dependencies:

  Depends GHC6 (>6.6.1)
  Depends GHC6 (<6.6.1+)

Which makes it impossible to install any ghc library.
Please fix!

Revision history for this message
Michael Bienia (geser) wrote :

The current package version of ghc6 in gutsy is 6.6.1-2 which is greater than 6.6.1 and smaller as 6.6.1+ (for dpkg).

Which error message do get when you try to install a ghc6 library?

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) wrote :

sudo apt-get install libghc6-gtk-dev

...

  libghc6-gtk-dev: Vereisten: ghc6 (< 6.6+) maar 6.6.1-2 zal geïnstalleerd worden
                   Vereisten: libghc6-cairo-dev (= 0.9.10.5-1ubuntu1) maar het zal niet geïnstalleerd worden
E: Niet-werkende pakketten:

-------------------------------------------
Translation to English:
-------------------------------------------

    libghc6-gtk-dev:
      Requirements: ghc6 (< 6.6+) however 6.6.1-2 will be installed
      Requirements: libghc6-cairo-dev (= 0.9.10.5-1ubuntu1) however it will NOT be installed

E: Non-functional packages

-------------------------------------

Can you install these libraries?
For me this happens with all libghc6-* packages..

Revision history for this message
Andy Price (andy-price) wrote :

The following packages have unmet dependencies:
  libghc6-glib-dev: Depends: ghc6 (< 6.6+) but 6.6.1-2 is to be installed.

"apt-cache unmet | grep ghc" is a little primitive but highlights a fair few ghc6 packages with unmet deps

Revision history for this message
Michael Bienia (geser) wrote :

These packages (libghc6-gtk-dev, libghc6-cairo-dev) are build from gtk2hs (it also builds libghc6-mozembed-dev, gtk2hs-doc, libghc6-gtkglext-dev, libghc6-gconf-dev, libghc6-glib-dev, libghc6-soegtk-dev, libghc6-sourceview-dev, libghc6-glade-dev).

gtk2hs needs to be updated for ghc 6.6.1. This already happened in Debian unstable but this package needs to be fixed first as it fails to build in Ubuntu gutsy (see bug #129301). Until this problem is fixed the packages build from gtk2hs can't currently be installed. Sorry.

Changed in gtk2hs:
importance: Undecided → Low
status: New → Triaged
importance: Low → Medium
Revision history for this message
Pierre R (pradermecker) wrote :

Could you be a bit more precise ? The bug you refer to seems to have a fix attached to it. Can we expect an upgrade before the final release of Gutsy ?

I have tried today with 0.9.10.5-1 without much luck. I have been trying to build 'yi' on Feisty too but it does require a more recent version of gtk2hs.

Thanks for any further information.

Revision history for this message
Michael Bienia (geser) wrote :

Gutsy has gtk2hs 0.9.12 but unfortunately it only successfully build on amd64 (but not i386 and others). Unfortunately I don't know how to fix it.

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) wrote :

Just out of curiosity, why is the importance just 'medium'?
Isn't getting the toolchain to work one of the most important aspects?

I'm aware not many haskell-related programs are included in the repositories, but this problem excludes most if not all of the Haskell written programs to be unavailable to Ubuntu.

What about a small downgrade?

Revision history for this message
Aleksi Hankalahti (aleksi-hankalahti) wrote :

The attached patch fixes the compilation issue in gtk2hs 0.9.12. The fix is from Duncan Coutts' message in gtk2hs-commit mailing list (http://sourceforge.net/mailarchive/message.php?msg_id=20070904123600.GA22481%40cvs.haskell.org).

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) wrote :

Aleksi, you are my hero!

Dear maintainers, please update the package to make the Gutsy release!

Revision history for this message
Scott Kitterman (kitterman) wrote :

motu-uvf ack. Please make sure you use a version number appropriate for -proposed (I'd imagine 0.9.12-0ubuntu1.1)

Revision history for this message
Michael Bienia (geser) wrote :

I've uploaded a fixed package to gutsy-proposed. I'll let you know when it's ready for testing.

Changed in gtk2hs:
assignee: nobody → geser
status: Triaged → In Progress
Revision history for this message
Michael Bienia (geser) wrote :

Fixed packages are available for testing in gutsy-proposed.
If you want to test them, add

deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed universe

to your sources.list and add a comment if the packages work for you now.

Thanks.

Revision history for this message
Aleksi Hankalahti (aleksi-hankalahti) wrote :

The packages in gutsy-proposed works fine. Thanks Michael.

Revision history for this message
Ian (typppo) wrote :

Just wanted to echo my thanks. Everything seems to work well in gutsy-proposed.

Revision history for this message
Chris Wagner (chris-wagner) wrote :

Another success: Gtk2Hs now seems to work okay for me. Thanks. :o)

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in gtk2hs:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers