Pcbnew fails to start with Segmentation fault on Ubuntu Mate 18.04 LTS

Bug #1769215 reported by Dmitry Me on 2018-05-04
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gtk2-engines (Ubuntu)
Undecided
Unassigned

Bug Description

After installing a fresh copy of the new Ubuntu Mate 18.04 LTS, I'm not able to start the Pcbnew. In the console it throws the following error:

     Segmentation fault (core dumped)

I'm able to view footprints and 3D models in CvPcb.

Before installing the new Ubuntu Mate, I used Ubuntu GNOME 16.04 LTS on the same laptop without any problems.

In bug #1768174 they advised me to open a bug here.

The laptop is a Dell Vostro 5468-P75G001 with Intel Corporation HD Graphics 620 (rev 02).

KiCad version is:

Application: kicad
Version: 4.0.7-e2-6376~60~ubuntu18.04.1 release build
wxWidgets: Version 3.0.3 (debug,wchar_t,compiler with C++ ABI 1011,GCC 7.3.0,wx containers,compatible with 2.8)
Platform: Linux 4.15.0-20-generic x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.65.1
Curl version: libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gtk2-engines 1:2.20.2-5
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: MATE
Date: Fri May 4 20:01:45 2018
InstallationDate: Installed on 2018-04-28 (6 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: gtk2-engines
UpgradeStatus: No upgrade log present (probably fresh install)

Dmitry Me (4x1md) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk2-engines (Ubuntu):
status: New → Confirmed
Element Green (jgreen-users) wrote :

Do you have any Python plugins in ~/.kicad_plugins or other plugin paths? pcbnew started crashing on me with Ubuntu 18.04 and now 18.10 when I install any plugins, works again after removing them. I've attached a gdb dump. I wonder if this is the same bug? Looking at this backtrace it seems like it might be something related to the status bar creation. I'm going to try building Kicad from latest source to see if I can figure out anything more.

Kicad package: 5.0.1-stable-201810221457+33cea8e~68~ubuntu18.04.1
OS: Ubuntu 18.10
Plugins tried: replicate_layout and delete_selected from https://github.com/MitjaNemec/Kicad_action_plugins

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers