[Needs 2.9.1] GTK+ apps do not render in Kubuntu 9.10 beta

Bug #448865 reported by Kaustubh on 2009-10-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
gtk2-engines-qtcurve (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: qtcurve

In karmic beta, in Firefox the arrows for the scrollbar, recent pages and the search engine chooser do not appear. This happens when using qtcurve. When I set the GTK+ widget style to Raleigh, the rendering is fine.

Binary package hint: qtcurve

In karmic beta, in Firefox the arrows for the scrollbar, recent pages and the search engine chooser do not appear. This happens when using qtcurve. When I set the GTK+ widget style to Raleigh, the rendering is fine.

Kaustubh (kaustubh-gadkari) wrote :
Kaustubh (kaustubh-gadkari) wrote :
Giovanni Masucci (gio-grifis) wrote :

I have this problem too. Maybe the new version of qtcurve have solved this problem?

Giovanni Masucci (gio-grifis) wrote :

ok bug fixed in qtcurve 0.69 (this only happened with gtk2 applications, like firefox)

here is the changelog:
It has been reported that under intel Xorg drivers > 2.8, that QtCurve's arrows are not appearing. This seems to be due to the fact that QtCurve is using cairo to draw non-antialised lines in this case. To work-around this issue QtCurve has been changed to use the older Gdk to draw arrows. To revert back to cairo, use the following cmake option: -DQTC_USE_CAIRO_FOR_ARROWS=true

I have the latest qtcurve in the karmic repo, as of this morning.

On Sun, Oct 11, 2009 at 11:36 AM, Giovanni Masucci <email address hidden> wrote:
> I have this problem too. Maybe the new version of qtcurve have solved
> this problem?
>
> --
> GTK+ apps do not render in Kubuntu 9.10 beta
> https://bugs.launchpad.net/bugs/448865
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Kaustubh Gadkari
kaustubh [dot] gadkari [at] gmail [dot] com

affects: kde-style-qtcurve (Ubuntu) → gtk2-engines-qtcurve (Ubuntu)

Fixed with commit 7e8f32d0a7279dce1976f87612833d9092554cfe
Author: Chris Wilson <email address hidden>
Date: Mon Oct 12 14:33:08 2009 +0100

    uxa: Free the ScratchPixmapHeader after its associated Picture

    Fixes: http://bugs.freedesktop.org/show_bug.cgi?id=24459
    Intel Driver > 2.8: Cairo rendering bug, triggered in QtCurve GTK engine

    Signed-off-by: Chris Wilson <email address hidden>

Thank you for the bug report.

That was quick.

Thanks for the quick reaction, I'll inform the QtCurve maintainer that he can remove the workaround for further QtCurve versions as major distributions provide updated drivers.

Thanks for the good support, kind regards

Christian

What about backporting it to 2.9 branch?

The bug has been fixed by intel (I attached to thi bug report the url to the upstream bug report).

Well, here is the final situation:

bug comes with:
intel 2.9 + qtcurve <= 0.68
intel fixed it in their main branch (proper fix), while the qtcurve mantainer found a workaround and included it in qtcurve 0.69.

So to fix this we can:
1) backport the fix from intel
2) update qtcurve to 0.69
3) both 1 and 2

Changed in gtk2-engines-qtcurve (Ubuntu):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Changed in gtk2-engines-qtcurve (Ubuntu):
status: New → Triaged
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged
Changed in gtk2-engines-qtcurve (Ubuntu):
milestone: none → ubuntu-9.10
Changed in xserver-xorg-video-intel (Ubuntu):
milestone: none → ubuntu-9.10
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in gtk2-engines-qtcurve (Ubuntu):
status: Triaged → Fix Released

This fix was included with the 2.9.1 maintenance release - thanks.

*** Bug 24478 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) on 2009-11-03
summary: - GTK+ apps do not render in Kubuntu 9.10 beta
+ [Needs 2.9.1] GTK+ apps do not render in Kubuntu 9.10 beta
Changed in gtk2-engines-qtcurve (Ubuntu Karmic):
status: New → Fix Released
Bryce Harrington (bryce) on 2010-02-25
tags: added: kubuntu
tags: added: karmic
Bryce Harrington (bryce) wrote :

We include 2.9.1 in Lucid so we can consider this bug resolved for lucid.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Oibaf (oibaf) wrote :

Karmic support expired an year ago, closing.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.